VS.NET: Debug on public server

Posted on 2005-05-07
Last Modified: 2010-04-07
I'd like to configure VS to run from my public internet server so I can edit
and update apps anywhere I have a terminal services connection.
Currently upon firing 'F5' I'm getting a 'Unable to start debugging on the
web server. You do not have permission to debug the app. The URL for this
project is in the Internet Zone'.

I'm able to Build Solution but not debug.

I've added my login to the 'Debugging' user group. Anything else to try?

winserv2003 / Framework 1.1.4322

many thx
Question by:juststeve
    LVL 13

    Assisted Solution

    I'm not sure, but doesn't the debug mode use non-standard ports? I.e. ports probably firewalled either at your end or at the provider? I've never been able to get that to work on a public server :)) (but maybe I'll learn from the *real experts* who post after me) :)
    LVL 5

    Expert Comment

    Debugging on a remote server is prohibitively slow - in my experience, not worth pursuing (so if you have to run things remotely, you get a whole lot better at using tracing ;-). Debugging remotely with Whidbey (VS2005) will be totally possible however (along with so many other wonderful things!).


    Author Comment

    This isn't remote debugging...I'm running VS _on the server...trying to run with the F5/debug mode.
    LVL 5

    Accepted Solution

    Ah, sorry. Thus the Terminal Service reference. Win2003 server really locks down the browser, so my assumption (have not checked it out as of yet myself) would be that you need to  adjust your IE security settings ("Internet Zone" term hints this).

    Many other different possibilities, but not enough info to do more than guess. Have you seen this blog yet?, especially this document I'm sure you'll find what you're looking for in that.



    Author Comment

    This entry from nailed down my specific problem:

    If you get the following error when trying to debug an ASP .NET project:

    Error while trying to run project: Unable to start debugging on the web server. You do not have permission to debug the application. The URL for this project is in the Internet Zone. Click Help for more information.

    From Internet Options (in IE go to Tools -> Internet Options), the Security tab, at the bottom of the Custom Settings for Internet Zone, set "Automatic logon with current username and password".

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Threat Intelligence Starter Resources

    Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

    In this Article, I will provide a few tips in problem and solution manner. Opening an ASPX page in Visual studio 2003 is very slow. To make it fast, please do follow below steps:   Open the Solution/Project. Right click the ASPX file to b…
    In an ASP.NET application, I faced some technical problems. In this article, I list them out and show the solutions that I found.  I hope it will be useful. Problem: After closing a pop-up window, the parent page should be refreshed automaticall…
    To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
    This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor ( If you're looking for how to monitor bandwidth using netflow or packet s…

    737 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    21 Experts available now in Live!

    Get 1:1 Help Now