• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 286
  • Last Modified:

Tricky FTP File Upload Download Problem w/ Win XP Pro

  I have been trying to set up an FTP service for file uploads and downloads on a Win 2003 Server sp2.  I have a Linksys BEFSR41 firewall/router on my network.  Port 21 TCP and UDP are forwarded to the server.  Port 20 TCP is forwarded to the server.
   My customer running XP Pro sp2 and IE 6.0 can connect to the FTP server and navigate the directory, but he cannot transfer a file in either direction.  The upload begins and then becomes infinitely long as the message "Calculating the time required to upload the files." never clears.  The download has a similar failure showing "Copying file..." forever until I kill the operation.  In that case I also get the followup error message "Remote procedure call failed".
   HOWEVER, a workstation running Win98 sp2 and IE 6.0 at the same location CAN upload and download files.  We have verified that the Advanced Options for IE are identical for both workstations.  Both of these workstations are on the same LAN behind the same firewall, etc.
   In IE Advanced Options I have set PASV=ON and PASV=OFF, likewise for enabling folder view for FTP sites, and none of this solves the problem of FTP file transfers in XP Pro.  Does anyone have a clue?  
   Bonus question:  When the FTP service was on a Win 2000 Server, I believe file transfers with the client running XP Pro DID WORK (my memory as to what changed where and when could be wrong).  Does this make sense?

Thank you for your time,
Bruce Anderson
0
bruceeanderson
Asked:
bruceeanderson
  • 7
  • 3
1 Solution
 
nicholassolutionsCommented:
I seem to have been having an almost identical problem -- in my case, another computer running XP also can send files from within my network, but my main computer all of a sudden is unable to. Even when I ftp from a command prompt the upload stalls. I don't know if we have the same problem or just the same symptoms, but I'll let you know if I come up with a solution.
0
 
bruceeandersonAuthor Commented:
I keep wondering if I am transgressing some "security" concern now being thrown up by MS.  I take comfort in knowing that one other person sees the same behaviour and thus we are victims of the conspiracy rather than I am being dangerously paranoid.
0
 
nicholassolutionsCommented:
>> comfort in knowing that one other person sees the same behaviour and thus we are >>victims of the conspiracy rather than I am being dangerously paranoid.
me too :)

And that was my thought, too, about some MS security problem. I think the first thing I'll try when I get home tonight is turning off all the SP2 security junk and seeing if that makes any difference.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
bruceeandersonAuthor Commented:
Please let me know the outcome, and if successful, exactly where you found the snake.
0
 
nicholassolutionsCommented:
Will do -- BTW, you might want to put a pointer to this question in the Windows XP section. I am pretty sure this is client side issue, so some of the regulars in that asection may have some better advice.
0
 
bruceeandersonAuthor Commented:
How do I post a pointer?
Bear of Small Brain
0
 
nicholassolutionsCommented:
just start a question in that section, and call it something like 'pointer to ftp problem question' and then in the question, just say it's a pointer to this page, and give the URL:

http://www.experts-exchange.com/Operating_Systems/Windows_Server_2003/Q_21416203.html#14000134

When the question gets closed, you can ask tech support to close the pointer as well, and you will get the pts refunded.
0
 
nicholassolutionsCommented:
LOL 'Tech support?' -- Man, I need friday to be over. What I meant was, you can ask the moderators in the support forum
0
 
nicholassolutionsCommented:
I seem to have fixed my problem. Not sure if this will help you or not, but here is what I did:

In your client's LAN, access the web interface to their router(for my d-link router that's http://192.168.0.1/). Somewhere in the WAN configuration pages, you should be able to set the MTU size. This is basically the size of the largest packet of data that can be sent at once, without having to be broken down into smaller chunks. Mine was set to 1500. When I set it to 1450, that solved the problem. I really don't know why this worked, since I would have guessed it would have caused problems for all the computer on the network. Anyway, don't know if that will help you, but it might be worth a try.

Also, have you looked in the firewall settings in the security control panel? Make sure that the is a firewall exception listed for the ftp program. I don't think this has anything to do with your server -- TCP is the same no matter what computer or operating system you are running, and if anyone can upload, I tend to think that if someone can't, the problem is on their end.
0
 
nicholassolutionsCommented:
well, I fixed the problem on another machine using the procedure I described. Whether that fixed this problem too, I don't know, so my feeling is to just find out from the asker. Either way, I would put this question in the PAQ database, in case someone else experiences the problem and the underlying causes are the same as the ones on my local machine.

Matt
0

Featured Post

Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

  • 7
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now