[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 353
  • Last Modified:

Cat5 Works on One Network But the Other

I made a network cable -- Cat5e -- to connect to a new Compaq Presario laptop on my home network. I have a 4 port linksys router that has two pcs already connected and working fine over a broadband connection.

The laptop has a Realtek RTL8139/810x Family Fast Ethernet NIC. When I use the cable I made to connect between laptop and router port, the connection status says "connected at 100.0 Mbps" but I can't access the Internet.

I tried a different cable (a cat6 I bought from store) and it worked. I also tried a cat5 cable from work where we have a LAN and it didn't work on the laptop either but it did work on my other two tower computers when I tested it (HP EN1207D-TX PCI 10/100 NIC and 3COM Etherlink XL 10/100 PCI NIC). The one I made doesn't work on any of the computers or the laptop at home.

The Cat5e cable I made worked on a computer at work when I connected to the network jack (we have a TI). It also worked on the laptop (using same cable I made) while at work but just not a home.

OS:
XP Home on laptop
XP Professional on one PC at home
Windows 2000 Pro. on second PC at home


First question:
Why does connection status say "connected" but I get no Internet access when using two cables I tested on the laptop at home (the one I made and one from work)?

Second question:
Why does the cable I made work on the network on my job but not at home?


Thanks!
0
tracyms
Asked:
tracyms
  • 6
  • 5
1 Solution
 
ZoidlingCommented:
There could be a number of things going on.  

Try connecting your laptop to your router/switch with the the cable you made, then releasing/renewing your IP address. (Assuming your laptop is running either Win2K or XP, from the laptop, open a command prompt and type "ipconfig /release" without the quotes and hit [Enter].  After you get your prompt back, type: "ipconfig /renew" without the quotes and hit [Enter]).  Once you've renewed your IP address, try and see if you've got internet connectivity.  If it doesn't work with the cable you made, switch to the LAN cable from work to see if there's any difference and post back the results.

Also, did you check the cable you made with a LAN cable tester to make sure all pairs are connected properly?
0
 
tracymsAuthor Commented:
I have static IP adresses (private) on home network not DHCP so I got an error about not completing operation when I tried renew/release. I did test the cable with a cable tester and all pins connected properly.  Thanks.
0
 
ZoidlingCommented:
On the laptop, check that the DNS settings are the same as the other working workstations on your LAN.
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 
tracymsAuthor Commented:
Everything is the same. The only time I changed the DNS numbers were when I tested the laptop at work and it wouldn't connect until I put in the DNS numbers for work - don't know why as I thought you can use any DNS. Plus, I tried new DNS numbers when I first had the problem and it didn't work. It seems strange that the connection status says its connected but I can't get Internet access using those cables...? I want to say the cable I made is bad but since it works on another network and other PCs  on that network is just has me stumped.  Could it be the difference in the T1 and cable internet speeds?
0
 
tracymsAuthor Commented:
Aslo, switched network at work...
0
 
ZoidlingCommented:
Nah, difference between T1 and cable speed doesn't matter here.  DNS settings are specific to each ISP, so you shouldn't try and use your work DNS settings on your home LAN unless your ISP is the same for both sites.  

If your cable tester gave the cable you made a clean bill of health AND it worked on your office LAN, I'd look harder at your home LAN setup.   If you want to pursue this further, post the IP address, subnet mask, default gateway and DNS server settings for each of your home PC's and the laptop.  
0
 
ZoidlingCommented:
Hmm. Another contributing factor could be is the autodetect capabilities on your Linksys router vs. your network switch at work.   Verify that one of your home pc's has access to the internet.  Quickly swap the cable connecting that pc to your router with the cable you made.  Check whether the PC still has internet connectivity.
0
 
tracymsAuthor Commented:
Zoidling,

I'm beginning to think it may have to do with auto sensing too. I have tried all you suggested before posting my problem. I'm using the 192.168.1.xxx IP scheme with the router 192.168.1.1 as the default gateway on all PCs at home. I've swapped cables on the router too, thinking maybe a bad port on the router but still the same problem.

I've also did a quick swap of the cables while connected, and tried again (refreshed the page) but no Internet. I'm going to try a switch (I have a mini workgroup switch and a 24 port Baystack switch that I'll test with) between the cable modem and the PCs at home to see what happens and post back the results. Thanks.
0
 
tracymsAuthor Commented:
Zoidling,

I set my NIC card's Link Speed/Duplex Mode on the laptop to 10Mbps/Full Duplex and tested it with the cable I made and it worked! I was able to browse the Internet with no problem and no noticable decrease in speed while browsing the Net. I also tested on 10Mbps/Half Duplex and that worked with the cable I made too.

It was orginally set to 100Mbps/Full Duplex. I tested my cable on the last option which was 100Mbps/Half Duplex and the cable didn't work on that setting.

I guess this means the cable's throughput is only capable of 10Mbps...? Didn't test on the other PCs yet but thinking it will do the same. Thanks for giving me the idea, and the points are yours.

By the way, I tested my cable with the Baystack switch from work too with no success even though the switch light was green -- indicating 100Mbps. Thanks!

 
0
 
tracymsAuthor Commented:
Meant to say the laptop's original Link Speed/Duplex Mode was set to Auto Negotiation, just to be accurate...:-).
0
 
ZoidlingCommented:
Cool. Glad I was able to help.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 6
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now