Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 213
  • Last Modified:

Pix Configuration helo

My question just need to be confirmed:

I have a pix with the following configuration (at the bottom).  I want to add a one to one nat and then give www accesses.  I am thinking I would enter the following commands, but not sure

static (inside,outside) 1.3.3.69 10.0.7.10 netmask 255.255.255.255 0 0
access-list 1 permit tcp any host 1.3.3.69 eq www


PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 1 permit icmp any any
access-list 1 permit gre any any
access-list 1 permit tcp any host 1.3.3.67 eq pop3
access-list 1 permit tcp any host 1.3.3.67 eq smtp
access-list 1 permit tcp any host 1.3.3.67 eq imap4
access-list 1 permit tcp any host 1.3.3.67 eq 8010
access-list 1 permit tcp any host 1.3.5.67 eq 8100
access-list 1 permit tcp any host 1.3.3.68 eq 3389
access-list 1 permit tcp any host 1.3.3.68 eq pptp
access-list 1 permit tcp any host 1.3.3.67 eq 9010
access-list 1 permit tcp any host 1.3.3.66 eq 1666
access-list 1 permit tcp any host 1.3.3.68 eq 1700
access-list 1 permit tcp any host 1.3.3.68 range 27000 27009
access-list 1 permit udp any host 1.3.3.68 range 27000 27009
access-list 1 permit tcp any host 1.3.3.68 eq 2027
access-list 1 permit tcp any host 1.3.3.68 eq 2031
access-list 1 permit tcp any interface outside eq www
access-list 10 permit ip 10.0.7.0 255.255.255.0 10.1.7.0 255.255.255.0
pager lines 24
logging on
mtu outside 1500
mtu inside 1500
ip address outside 1.3.3.66 255.255.255.240
ip address inside 10.0.7.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool remote-users 10.1.7.50-10.1.7.200
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 10
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface 1666 10.0.7.6 1666 netmask 255.255.255.255
 0 0
static (inside,outside) tcp interface www 10.0.7.11 www netmask 255.255.255.255
0 0
static (inside,outside) 1.3.3.67 10.0.7.3 netmask 255.255.255.255 0 0
static (inside,outside) 1.3.3.68 10.0.7.2 netmask 255.255.255.255 0 0
access-group 1 in interface outside
route outside 0.0.0.0 0.0.0.0 1.3.3.65 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 0.0.0.0 0.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map ipsec-maps 10 ipsec-isakmp dynamic dynmap
crypto map ipsec-maps interface outside
isakmp enable outside
isakmp identity address
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup vpn3000 address-pool remote-users
vpngroup vpn3000 dns-server 10.0.7.2 10.0.7.4
vpngroup vpn3000 wins-server 10.0.7.2 10.0.7.4
vpngroup vpn3000 default-domain transmedics.com
vpngroup vpn3000 split-tunnel 10
vpngroup vpn3000 idle-time 1800
vpngroup vpn3000 password ********
telnet 10.0.7.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:bf21a29bdcb0a93e4264f52b486196e6
: end
0
akita29
Asked:
akita29
  • 2
1 Solution
 
lrmooreCommented:
Those are exactly the right commands. Only thing is that whenever you change an access-list by adding a line, you need to re-apply it to the interface
add this command -again-
   access-group 1 in interface outside
0
 
akita29Author Commented:
so i would addd by commands

static (inside,outside) 1.3.3.69 10.0.7.10 netmask 255.255.255.255 0 0
access-list 1 permit tcp any host 1.3.3.69 eq www
access-group 1 in inface outside

and that should do it..

0
 
lrmooreCommented:
Yes, exactly..
0
 
alex_yalaCommented:
I personally would go a step further than just mapping the whole IP address.

static (inside,outside) tcp 1.3.3.69 www 10.0.7.10 www netmask 255.255.255.255 0 0
access-list 1 permit tcp any host 1.3.3.69 eq www
access-group 1 in interface outside

But that's just me being too cautious about everything.

I think the following command in your current configuration might clashed with suggestion.
    static (inside,outside) tcp interface www 10.0.7.11 www netmask 255.255.255.255 0 0
You might want to put a specific external IP address on the current static command.

Good Luck.

- Alex.
0

Featured Post

Choose an Exciting Career in Cybersecurity

Help prevent cyber-threats and provide solutions to safeguard our global digital economy. Earn your MS in Cybersecurity. WGU’s MSCSIA degree program was designed in collaboration with national intelligence organizations and IT industry leaders.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now