[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 517
  • Last Modified:

Wireless internet doesn't work when i turn on ethernet

INFO:
i have windows xp home with sp2
this is how i get internet to my computer
i have a D-Link DI-624 wireless router that is connected to the internet. then i have a D-Link DWL-G520 (D-Link Airplus Xtreme G) wireless card in my computer. thats how i get internet.
But i also have a D-Link DI-514 wireless router next to my computer. this router does not get internet. i connect to that one with an ethernet wire.
PROBLEM:
the problem is that when ever i connect to the DI-514 router with an ethernet wire my internet to my pc goes down. but my wireless connection doesn't get totaly over thrown. i can still log into the DI-624 router that im connected to wirelessly but i have no internet until i turn off my ethernet. i have gotten it to work with that setup before but that was after alot of screwing around and doing random stuff and it only worked for a little while

my question is why does it do that and how do i configure it to make it work?
0
done121
Asked:
done121
1 Solution
 
savoneCommented:
A couple of questions for you, if you dont mind:

1) Do you have DHCP turned on, in both routers?

2) If so are they different IP schemes.  Example: wired network 192.168.1.X and Wireless 10.1.10.X

3) Is there a network bridge?


You might try to statically assign the wireless connection so it does not look at any other gateways.  That should do it.

Hope this helps
0
 
Leon FesterCommented:
Sounds like you're getting a default gateway assigned to both network cards.

from cmd prompt, run ipconfig /all and check if each NIC has a Default gateway assigned. You will only need 1, if you're running DHCP then your DHCP server is problably populating that field with you connect to the different networks.

You need to decide how you want to connect to your network, either statically configure the default gateway(Can be done even when using DHCP), but bear in mind your system essentially has 2 NIC's so if the one is not present it will default to the other, so you could run into this problem each time you change your connection. Running ipconfig /flushdns after changing connection, could help to ensure network connectivety.
0
 
purplepomegraniteCommented:
You are using two routers, which is the problem.

Wireless connections have a lower metric than wired connections, so as soon as you plug into your router using the wire, this connection scores higher in the routing table and so any internet traffic will be directed via the wire.

One way round this in your case would be to manually assign a metric to an interface.  This is done by:

- Open Network Connections.
- Right-click on the network connectio (e.g. Local Area Connection) and click Properties.
- Select TCP/IP and then click Properties.
- Click Advanced
- Untick the "Automatic Metric" tickbox at the bottom, and assign a metric. For your situation, use 20 for the wireless and 100 for the wired connection.
- OK everything.

That should solve your problem, though the fundamental problem is that you are connected to two routers at all - this is unusual, what are you using the none internet router for?
0
New Tabletop Appliances Blow Competitors Away!

WatchGuard’s new T15, T35 and T55 tabletop UTMs provide the highest-performing security inspection in their class, allowing users at small offices, home offices and distributed enterprises to experience blazing-fast Internet speeds without sacrificing enterprise-grade security.

 
done121Author Commented:
purplepomegranite, i did what you said but once i select 'internet protocol (tcp/ip)'  all i see is general and alternate configuration. and that stuff is just for setting the ip address. i dont see anything in thier that just says 'TCP/IP'

the second router is for when i play xbox connect, since im on a wireless connection i need it to link up my computer and xbox
0
 
done121Author Commented:
acutualy giving the ethernet a static ip address with no default gateway worked like what dvt_localboy was talking about works perfectly
0
 
purplepomegraniteCommented:
In my answer, you should click the Advanced button under the General tab... it is detailed above, but easy to overlook!

If a static address is ok for you though, leave it as it is!
0
 
done121Author Commented:
ok so the accepted answer and yours also works. but he did give me a working answer first so i gave him the points
0
 
purplepomegraniteCommented:
lol, yes, I have no problem with that... just wanted to clarify my solution!!
0
 
done121Author Commented:
are you trying to show your mad with the exclamations?
0
 
purplepomegraniteCommented:
Um... I'm not entirely sane... is that what you mean? :)
0
 
done121Author Commented:
it just seemed if you were mad...
0

Featured Post

Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

Tackle projects and never again get stuck behind a technical roadblock.
Join Now