[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 435
  • Last Modified:

redhat hangs on boot due to apachectl error

I modified httpd.conf and rebooted, now my rhes hangs at "starting apachectl"

Unfortunately, I had added symbolic links to apachectl for run levels 3,4 and 5 in the appropriate rc directories and neglected to remove them before rebooting, so now the only run levels that work are 1 and 6.

I can mount my home directory to another rhes machine on my lan via nfs, but I haven't exported any other directories.

Is there any way out of this?
   
0
klukac
Asked:
klukac
  • 3
  • 2
1 Solution
 
jlevieCommented:
Boot into single user mode, remove the symlinks for apachectl in run levels 3-5, and then exit to multi-user mode.
0
 
klukacAuthor Commented:
Thanks jlevie.  I ssh'd from my other Linux machine and removed the symbolic links before reading this.  Can't believe how responsive this service (and you!) can be!  It's good to know another option, although I don't know how would get to the boot prompt in this case - with a floppy disk or by halting the boot process at some point?  
0
 
jlevieCommented:
After POST you can interrupt the boot process when you see the Grub boot screen and tell it to go to single user mode from there
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
klukacAuthor Commented:
I tried to interrupt the boot process in 2 ways - with Ctl+Alt+F3, which switches to non-GUI and Ctl+Alt+F7 which switches back to GUI.  That didn't work.  I looked up interrupting the boot process in dogpile and found that if you press the Caps lock key after the POST completes you should be able to get to a boot prompt and type in "single" for single-user mode.  That didn't work either. Do I have to reintroduce an error into the rc3.d folder to get this to work?
0
 
jlevieCommented:
What Redhat is this? There was an older version of Redhat needed a Ctrl-X after POST to get to the Lilo prompt or the Grub screen. RHEL 4 WS needs an escape. But in both cases it tells you that before it starts booting the OS.
0
 
surya_prabhakarCommented:
use the following steps to boot into single-user mode:

Select Red Hat Linux with the version of the kernel that you wish to boot and type e for edit. You will be presented with a list of items in the configuration file for the title you just selected.

Select the line that starts with kernel and type e to edit the line.

Go to the end of the line and type single as a separate word (press the [Spacebar] and then type single). Press [Enter] to exit edit mode.

Back at the GRUB screen, type b to boot into single user mode.
------------------------------------------------------------------------------------------------------------
If you are using LILO, specify one of these options at the LILO boot prompt (if you are using the graphical LILO, you must press [Ctrl]-[x] to exit the graphical screen and go to the boot: prompt):

boot: linux single
boot: linux emergency
 
Cheers
Surya.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now