• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3427
  • Last Modified:

RPC over HTTP - 503 Service Unavailable

Hi,

I have been struggeling with this problem for some time now, so mabye someone out there can help me. I have an Exchange Server running in a cluster. The OS is Windows 2003 and the Exchange is 2003 with SP1. I have installed the RPC over HTTP service, and created a virtual directory on both servers. I have got a VeriSign certificate, and now my question:

If I open a browser and type https://mail.server.com/rpc, and I type my username and password I get this message: HTTP/1.1 503 Service Unavailable

Is this the correct error message og is the virtual directory configured in a wrong way????

The reason for this question is that I can't get the RPC over HTTP to work. OWA and Active Server Sync work fine, but not RPC/HTTP.

Best regards

Morten Hem
0
mortenhem
Asked:
mortenhem
  • 4
  • 4
1 Solution
 
SembeeCommented:
The error you should be getting is "403.2 - Forbidden: Read access denied". As you aren't getting that error, the core RPC/HTTPS functionality isn't working properly.

Are you using this feature in a front-end/back-end scenario?
How did you configure the service? Registry keys or GUI?

Simon.
Exchange MVP.
0
 
mortenhemAuthor Commented:
Hi Simon,

I don't have a front-end server. The Exchange server is configured as "Not part of an Exchange managed RPC-HTTP topology". I have tried to set it as "RPC-HTTP back-end server" but this results in the same error.

I installed the RPC/HTTP service with the GUI in Windows.

Best regards

Peter Jordan
0
 
SembeeCommented:
If you aren't using a front-end/back-end then it is registry hacks.

By GUI I meant through ESM, which you have already answered.

Take a look at my web site. http://www.amset.info/exchange/ where I have the registry hacks required to make it work.

Simon.
0
NEW Veeam Backup for Microsoft Office 365 1.5

With Office 365, it’s your data and your responsibility to protect it. NEW Veeam Backup for Microsoft Office 365 eliminates the risk of losing access to your Office 365 data.

 
mortenhemAuthor Commented:
Hi Simon,

Okay I have changed all the registry keys as you descriped. Now instead of the 503 error I get HTTP error 403 - Forbidden. Not "403.2" is that a problem or is that a browser version issue.

The RPC/HTTPS is still not working, but perhaps I've moved a bit closer to my goal now.

Best regards

Peter Jordan
0
 
SembeeCommented:
Which error code are you seeing with forbidden? You might have to turn off friendly http error messages so that you can see the actual error code.

Simon.
0
 
mortenhemAuthor Commented:
Hi Simon,

The error I'm getting is "HTTP/1.1 403 Forbidden"

Best regards

Peter Jordan
0
 
SembeeCommented:
That is a friendly HTTP message.
You need to disable the friendly HTTP messages in Internet Explorer to see the real error message.

Simon.
0
 
mortenhemAuthor Commented:
Hi Simon,

Okay problem solved. It was the virtual directory created by the Exchange installation. On my Exchange cluster I have 2 sites under IIS. I have the "Default Web Site" and "Exchange Virtual Server (EX01)". The RPC Proxy GUI installation has placed the Rpc virtual directory under "Default Web Site". I originally created the directory under the "Exchange Virtual Server (EX01)" site, and configured it the same way as the one under "Default Web Site". Since it is a cluster, the clussvc is controlling the IIS sites, and the "Default Web Site" is therefore Stopped, since it is the "Exchange Virtual Server (EX01)" that is online.

I solved the problem by exporting the Rpc virtual directory under the "Default Web Site" to an XML file, and the importing the folder configuration under the "Exchange Virtual Server (EX01)" site. Bingo everything works.

In the future ask people if the Rpc folder is located in the "Default Web Site" or in another site in IIS.

Thank you for your help I apriciate it :-)

Best regards

Peter Jordan
0
 
gilm0079Commented:
Just a note, I've been looking into this problem for a while and found nothing.  I had a similar problem with another website in IIS7 and remembered that IIS7 has problems with tokenized binding paths.  By default exchange uses %windir%\system32\rpcproxy as the binding path for the rpc and rpcwithcert virtual directories.  I replaced these with c:\windows\system32\rpcproxy and now when running the cmdlet Test-OutlookWebServices it is not failing.  Before this change I was getting a failure on the rpc test with 503 server unavailable error.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now