Learn how to a build a cloud-first strategyRegister Now

  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 477
  • Last Modified:

Injoy Firewall not allowing ftp access on Windows 2003 Server

I have a Windows 2003 Server with a Firewall from fx.dk called Injoy.  
I am unable to access ftp server through this firewall.  If I shut down the firewall ftp works.
This is over a tcp stack on port 21.

Any ideas as to what the problem may be?

1 Solution
active or passive ftp? or both?
Do netstat -a on the server.
The ftp program might need more ports.
It will show.
Open them too.
When you say access, do you mean you cannot log in at all? Or do you mean, you can log in but cannot list folders, etc?
Well im using Injoy3.0 to - and had the same problems with opening some ports - have you check that you registaration key is properly registered? Check for at ---> C: -->Program files -->ijfw --> config --> gateway.cn_ (you open this file with notepad) and then it should NOT look like this:
; Purpose..:  InJoy Firewall basis configuration
; Syntax...:  Records begin in first position of a line.
;             Strings and IP addresses must be in quotes.
;             Blank line(s) terminate a record.
;             Lines starting with the '#' or ';' denote a comment.
;             Default values provided by matching file in the TEMPLATE dir.
;             Records must have unique names.
; Help.....:  Product documentation and matching template/.dct file.
; Errors...:  Written to LOGS/ACTIVITY.LOG

SETTINGS       Name = "Evaluation",
               Code = "2413e366e151629467b055666360626064600092ae658939a589250c3000003e6803b1932f163a0a",
               Internal-Net-1 = "",
               Internal-Netmask-1 = "",
               Internal-Net-2 = "",
               Internal-Netmask-2 = "",
               Internal-Net-3 = "",
               Internal-Netmask-3 = "",
               PPPoE = Disabled,
               PPTP = Disabled,
               IPSec = Disabled,
               DHCPd = Disabled,
               Fragment = Enabled,
               MTU = 1500,
               MSS-Adjust = 1200,
               Identd = Disabled,
               Identd-User = "JohnDoe",
               DNS-1 = "",
               DNS-2 = "",
               GUI-Server = Disabled,
               GUI-Password = "test",
               GUI-Port = 3333,

Evaluation is where youre key name should go in:

Code is where your code key should go in:

After this everything should work like a a charm!

Good luck!


Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now