?
Solved

Problems telneting to Cisco 827

Posted on 2005-05-09
4
Medium Priority
?
723 Views
Last Modified: 2012-08-14
I'm having problems telneting to my Cisco 827 using the public IP address (the ATM interface).  I have a fixed IP address assigned by my ISP.

I can telnet to the ethernet interface (192.168.1.1) just fine.  I can ping the WAN ip number from both the inside and outside.  But when I attempt to telnet to the WAN ip number, from either inside or outside, I get a "connection refused" error.

Here is the configuration for my router (with sensitive information blocked):

Current configuration : 1421 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname CiscoADSL
!
no logging rate-limit
enable secret 5 XXXXXXXXXXXXXXXXXXXXXX
!
ip subnet-zero
no ip finger
!
no ip dhcp-client network-discovery
!
!
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
!
interface ATM0
 no ip address
 ip nat outside
 no atm ilmi-keepalive
 pvc 0/100
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 bundle-enable
 dsl operating-mode auto
 hold-queue 224 in
!
interface Dialer0
 ip address negotiated
 ip nat outside
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp pap sent-username XXXXXXX password 7 XXXXXXXXXXXXXXX
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
!
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source static udp 192.168.1.45 20 XX.XX.97 20 extendable
ip nat inside source static tcp 192.168.1.45 22 XX.XX.97 22 extendable
ip nat inside source static tcp 192.168.1.45 20 XX.XX.97 20 extendable
ip nat inside source static tcp 192.168.1.45 21 12.XX.XX.97 21 extendable
access-list 1 permit 192.168.1.0 0.0.0.255

dialer-list 1 protocol ip permit
!
line con 0
 transport input none
 stopbits 1
line vty 0 4
 password XXXXXXXXX
 login
!
scheduler max-task-time 5000
end



0
Comment
Question by:netboss1
  • 2
  • 2
4 Comments
 
LVL 5

Expert Comment

by:Zoidling
ID: 13964953
I think your line 'transport input none' is the issue.  Try changing it to 'transport input telnet'.

0
 

Author Comment

by:netboss1
ID: 13964994
Sorry, that didn't solve the problem.  Still can't connect.  Thanks for trying.
0
 

Author Comment

by:netboss1
ID: 13974607
I would have never believed it, but rebooting the router solved the problem.  Thanks to Zoidling for his suggestion about the "transport" statement.
0
 
LVL 5

Accepted Solution

by:
Zoidling earned 750 total points
ID: 13974953
Cool.  Glad it worked out for you.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is a guide to configure bridging on Cisco Routers.  This is something I never knew was possible until after making a few phone calls to Cisco.  Using bridging saved our company money by not requiring us to purchase a new switch.  Bridgi…
We've been using the Cisco/Linksys RV042 for years as: - an internet Gateway - a site-to-site VPN device - a leased line site-to-site subnet-to-subnet interface (And, here I'm assuming that any RV0xx behaves the same way as an RV042.  So that's …
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

621 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question