ActiveX blocks and Zone Alarm Pro

Posted on 2005-05-09
Last Modified: 2013-11-16
Was having multiple attacks of backdoor programs, spyware, hijacks etc.  So I upgraded to the latest Norton Antivirus, ran Spywareblaster and upgraded to the pro version of Zone alarm.  Now I find I cannot go to any page that uses ActiveX with out the error message "Your current security settings prohibit running ActiveX controls". I removed Spywareblaster as it blocks ActiveX controls and the problem continued...I disabled Nortons and it continued....I disabled Zone Alarm and I stopped getting the error message.  Now Zone Alarm tech support says this error is caused by settings for mobile computing and to set that zone to off...but mine is already off. When I open Yahoo almost any page I jump to give me the dread ActiveX message...their music Launch program fails for the same reason....when I disable ZA pro the problem ceases.  Spywareblaster put a zillion things in the restricted sites area....could these somehow relate to the problem?  I used Hoster.exe to set the host file back to the out of the box microsoft setting.  I am out of ideas and very nervous to run without a firewall that monitiors incoming  and outgoing traffic.  Firefox does not support ActiveX so I don't get the error on every page but I cannot use a site such as Yahoo Launch for music play as it requires ActiveX.  Probably not related but also ran virus scan...all clean...HiJack this and everything analyzed as safe.  This ain't my area of expertise and I am flat out of ideas.  Any help would be greatly appreciated.
Question by:George_Evanson
    LVL 15

    Accepted Solution

    Have you tried going into Tools-Internet Options-Security (tab)-Custom Level and changing the settings for Active X controls?   The default settings for them in IE6 on XP-SP2 are:

    Automatic prompting for ActiveX controls - disable
    Binary and script behaviors - enable
    Download signed Active X controls - prompt
    Download unsigned Zctive X controls - disable
    initialize and script active X controls not marked as safe - disable
    Run ActiveX controls and plugins - enable
    Script ActiveX controls marked safe for scripting - prompt
    LVL 27

    Assisted Solution

    Have you tried in ZA Pro:

    Tab Privacy -> Site List -> Add Button (down below) -> enter Yahoo Lauch Url.

    Allow Mobile Code.

    (checking it myself reight now)
    LVL 27

    Expert Comment

    Your hosts file in C:\WINDOWS\system32\drivers\etc has nothing to do with IE restricted sites.

    So if is in the restricted site list, activex should be disabled be default.

    Could you give me any link that is not working for firefox please, right now I'm listening to  System of a Down quite successful, just videos are broken.

    Btw. you can also go to ZA Pro -> Privacy tab -> Mobile Code control -> off

    Is it set that way?

    Maybe setting Cookie Control  -> off

    and Adblocking -> off

    might help, for testing.


    LVL 12

    Assisted Solution

    >>when I disable ZA pro the problem ceases
    >>...but mine is already off
    >>This ain't my area of expertise and I am flat out of ideas

    In that case... why not reinstall ZoneAlarm... the wizard should ask you if you want to block activeX n stuff. Talk you through it.

    Featured Post

    Free Trending Threat Insights Every Day

    Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

    Join & Write a Comment

    Suggested Solutions

    How to sign a powershell script so you can prevent tampering, and only allow users to run authorised Powershell scripts
    This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
    Hi everyone! This is Experts Exchange customer support.  This quick video will show you how to change your primary email address.  If you have any questions, then please Write a Comment below!
    Sending a Secure fax is easy with eFax Corporate ( First, Just open a new email message.  In the To field, type your recipient's fax number You can even send a secure international fax — just include t…

    745 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now