• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 250
  • Last Modified:

Network Shares

I have got a minor problem here.

I am running W2k3 server as a DC and a file server

Everyhting has been fine all network drives are set up and running.

All of a sudden today one of the drives Z is showing in 'My Computer' as a disconnected network drive. When I click on it it is fine., but then when I return to 'My Computer' it still shows as disconnected.

To add insult other users are also experiencing the same with Z:

when I examined a user profile and tried to connect Z:// as a home folder, it came back and told me that Z:// was being used as a root share?

What is this and how as it Happenned?

0
alanheaton
Asked:
alanheaton
  • 2
  • 2
1 Solution
 
Pete LongTechnical ConsultantCommented:
XP loses Mapped Drives after a few minutes (this process is carried out on the server)

XP does this by default (It's set in the registry) The usual (default is 15 minutes) and its set in the following key..

HKLM\System\CurrentControlSet\Services\Lanmanserver\parameters

In here you will see autodisconect you can set its value in minutes (The valid value range is -1 to 65535 minutes)

To disable it completely set it to -1

For more info see
http://support.microsoft.com/default.aspx?scid=kb;en-us;138365 (This also applies to XP)

Mapped Drive Connection to Network Share May Be Lost
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q297684

In windows 2000 Server environments you can use the following command also
net config server /autodisconnect:-1

Then On the XP Client

Click Start >Run >Type "gpedit.msc" {enter}

Navigate to

Local Computer Policy >Computer Configuration >Windows Settings >Security Settings >Local Policies >Security Options

Scroll down to

"Microsoft Network Server: Amount of idle time required before suspending session"

The default is 15 minutes change it to 99,999
0
 
alanheatonAuthor Commented:
That was quick!!

The problem is that when you log on and the computer is booting, it pops up in the right corner to say that Some Network Drives are disconnected.

This user has 4 network drives, but it is only z:// that causes the problem.

I dont think it is dropping off because it isn't connecting at first.
0
 
Pete LongTechnical ConsultantCommented:
how is it being mapped?
0
 
alanheatonAuthor Commented:
The strange thing is as well

When you double click it it opens fine

But it still says it is disconnected

Then when you go to disconnect it to re-map

It says there is no Connection.

They are all ampped through 'My Computer' 'Map Network Drive'
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now