Linux emacs printing problem.

Linux emacs printing problem (cups-lpr).

I have an MFC3820CN Brother printer that runs with a cups driver supplied by Brother.  

When I print a buffer in emacs the printer starts printing too low on the paper and causes a second sheet to be used for the last three or so lines that should have been on the previous sheet of paper.   In other words two sheets of paper are used per page because the top margin is too big.

This same problem happens with gLabels label software, so it's not an emacs problem.  Neither software uses the regular cups drivers directly.  I assume they are using cups-lpr.

All programs that are using the Cups driver are printing fine.

Does anyone have any idea what might be causing this problem.

Thanks,
ibanja
ibanjaAsked:
Who is Participating?
 
ibanjaAuthor Commented:
maimon22,

Thanks maimon22 - I'm halfway there.  The glabels software is printing fine now, but emacs is not.  Although the print is now higher on the page with the emacs printout, it still puts the last 2 lines on a second sheet of paper.  

emacs adds a header to the printout with the date, time, filename, and page number. This header info starts one line (one character height) from the top. It then skips two lines and prints to the very bottom of the page (less than a character height from bottom). It then prints two lines on the following page (one character height from top) and ejects that page, continuing until all pages are printed.

I am wondering if I am not properly setting the default paper type to "letter".

I have the following line in my .emacs file.
(setq ps-paper-type 'letter)

Thanks,
ibanja
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.