?
Solved

VPN to a PIX behind another PIX

Posted on 2005-05-09
7
Medium Priority
?
593 Views
Last Modified: 2010-05-18
Ok here's my issue.

I have a 501 PIX and I can connect to VPN fine, once conencted though I cannot ping or access anything.

I see this issue here at work only. I can access everything fine at home. Any ideas why? The network I am VPNing into is 192.168.8.x.

Is there something on our work PIX (which is a 515E) that I need to change. Here is the config on the work PIX:

PIX Version 6.3(1)
interface ethernet0 auto
interface ethernet1 auto
interface ethernet2 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 dmz security4
hostname Firewall
domain-name
clock timezone CST -6
clock summer-time CDT recurring
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
names
name x.x.x.x WebServer
name x.x.x.x FTPServer
name x.x.x.x MailServer
object-group service FTP tcp
  port-object eq ftp
  port-object eq ftp-data
access-list outside_access_in permit tcp any interface outside eq www
access-list outside_access_in permit tcp any interface outside eq https
access-list outside_access_in permit tcp any interface outside object-group FTP
access-list outside_access_in permit tcp any interface outside eq smtp
access-list outside_access_in permit icmp any any
access-list inside_outbound_nat0_acl permit ip any 10.10.31.0 255.255.255.128
access-list inside_outbound_nat0_acl permit ip any host FTPServer
access-list outside_cryptomap_dyn_40 permit ip any 10.10.31.0 255.255.255.128
pager lines 24
mtu outside 1500
mtu inside 1500
mtu dmz 1500
ip address outside x.x.x.x 255.255.255.248
ip address inside 10.10.11.15 255.255.0.0
ip address dmz 10.254.1.2 255.255.0.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpn-pool 10.10.31.30-10.10.31.79
pdm location 10.10.11.1 255.255.255.255 inside
pdm location WebServer 255.255.255.255 inside
pdm location MailServer 255.255.255.255 inside
pdm location FTPServer 255.255.255.255 dmz
pdm location 10.30.0.0 255.255.0.0 inside
pdm location 10.40.0.0 255.255.0.0 inside
pdm location 10.50.0.0 255.255.0.0 inside
pdm location 10.10.0.0 255.255.0.0 outside
pdm location 10.10.11.192 255.255.255.192 outside
pdm location FTPServer 255.255.255.255 inside
pdm history enable
arp timeout 14400
global (outside) 10 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 10 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface www WebServer www netmask 255.255.255.255 0 0
static (inside,outside) tcp interface https WebServer https netmask 255.255.255.255 0 0
static (inside,outside) tcp interface smtp MailServer smtp netmask 255.255.255.255 0 0
static (dmz,outside) tcp interface ftp FTPServer ftp netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 x.x.x.x 1
route inside 10.30.0.0 255.255.0.0 10.10.1.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 10.10.0.0 255.255.0.0 outside
http 10.10.0.0 255.255.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 40 match address outside_cryptomap_dyn_40
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup vpn-group address-pool vpn-pool
vpngroup vpn-group dns-server 10.10.11.3
vpngroup vpn-group wins-server 10.10.11.2 10.10.11.5
vpngroup vpn-group default-domain
vpngroup vpn-group idle-time 1800
vpngroup vpn-group password
telnet 10.10.0.0 255.255.0.0 inside
telnet timeout 5
ssh timeout 5
management-access inside
console timeout 0
terminal width 80
Cryptochecksum:41f5cf6e1693bc5993bb50f9126e6e8d
: end
Firewall#



Thanks
0
Comment
Question by:Justin Durrant
  • 3
  • 3
7 Comments
 
LVL 104

Accepted Solution

by:
Sembee earned 2000 total points
ID: 13964007
If I am working on a site where there is PIX and I want to VPN home (to my own PIX) there is just one line I add to the configuration:

ISAKMP NAT-TRAVERSAL

Nothing else.

I also have it in my own PIX as well to ensure that everything is working correctly.

Simon.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13967202
Agree with Sembee, simply add the nat-traversal command
0
 
LVL 23

Author Comment

by:Justin Durrant
ID: 13968076
Ok,

I added the command and no luck. It looks like there is also a 20 after the command (which I did not add) when I do a show run.
0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 
LVL 79

Expert Comment

by:lrmoore
ID: 13968116
It should be added to both your pix and the remote end-point pix.
The "20" is default timeout
0
 
LVL 23

Author Comment

by:Justin Durrant
ID: 13968872
Ok.. I will have to do it on the remote pix tonight. Do I need to add any routes?
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13971095
You will not need to add any routes anywhere.
0
 
LVL 23

Author Comment

by:Justin Durrant
ID: 13971613
Thx
0

Featured Post

A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article I will be showing you how to subnet the easiest way possible for IPv4 (Internet Protocol version 4). This article does not cover IPv6. Keep in mind that subnetting requires lots of practice and time.
LinkedIn blogging is great for networking, building up an audience, and expanding your influence as well. However, if you want to achieve these results, you need to work really hard to make your post worth liking and sharing. Here are 4 tips that ca…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question