www issue in webmail

Posted on 2005-05-10
Last Modified: 2010-03-18
Hello Everyone

I am using a cobalt webserver for both email & web service. and in the set up the settings are as follows

hostname: www
domain name:
web server aliases:
email server aliases:

When I access the webmail (open webmail) the eails are all prefixed with www e.g the user shows as

But if I send using outlook or outlook express as email client I am able to send and recieve from

I need to know how I can adjust it such that all users can access the webmail and their email addresses wil reflect on the openwebmail

Thank you
Question by:cobuba
    LVL 1

    Assisted Solution

    I have that problem with Squrrielmail before and the Squrrielmail have an option to change the display email address. I didn't use Open webmail but I guess it should be the same problem. Sorry cannot help much.


    Accepted Solution

    Well!!!. I have used Sendmail with Webmail. I don't know if its similar to Openwebmail. If it is , then use this....

     For the user to send and receive his mail as, you have to see the settings of
    in /etc/mail/ file and recompile it using m4 prepocessor. If you are using any other mail server , then find out similar line using the documentation.

     Also , check the configurations of Squirrelmail using /usr/share/squirrelmail/

    Hope that you get some help from this.
    LVL 3

    Assisted Solution

    I assume the problem you are describing is that when a user sends mail using Open Webmail the "From" address is by default Unless administratively prohibited in the Open WebMail configuration, each user can add new From addresses such as, but this shouldn't be necessary. Open WebMail builds its initial list of From addresses by looking in /etc/mail/virtusertable for addresses that map to the mailbox name. If these are specified as, then this is the problem. (Open WebMail has other sources too, such as custom mapping files and a fallback to the hostname of the machine. I don't remember the exact algorithm.) It might just be that you shouldn't call your machine, but rather just with an alias for I don't know Cobalt enough to tell you how to do this, but it may just be a matter of leaving the "hostname" setting blank or setting it to "" (which hopefully won't result in

    Hope this helps,

    Author Comment

    I discovered that because I was using cobalt server ther was no way I could input the  domain Iwanted to display. since IWas hosting multiple domains

    So it was set to AUTO in the and if set to auto it chooses the host name as prefix (in this case it is www)

    thanks for the pointers to the file

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    How your wiki can always stay up-to-date

    Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
    - Increase transparency
    - Onboard new hires faster
    - Access from mobile/offline

    I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
    Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
    Hi everyone! This is Experts Exchange customer support.  This quick video will show you how to change your primary email address.  If you have any questions, then please Write a Comment below!
    Sending a Secure fax is easy with eFax Corporate ( First, Just open a new email message.  In the To field, type your recipient's fax number You can even send a secure international fax — just include t…

    761 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    11 Experts available now in Live!

    Get 1:1 Help Now