error copying bigint values through DTS package

hi experts,

I have a strange behavior in my DTS package when copying tables with bigint values.
e.g. data 123456789 will become somethimg like -809823092 in the destination table.

I can resolve this when unchecking allow null values in the source table for this field  !?
Unfortenatly I have also a table WITH null values...

any idea?






duke63Asked:
Who is Participating?
 
rafranciscoConnect With a Mentor Commented:
This also happens to me when copying across different servers.  The only workaround that I do is to create the destination tables first before performing the import/export.
0
 
duke63Author Commented:
Might be of interest...

Our Microsoft SQL Server Versions

Source DB: 8.00.760  1  3
Microsoft SQL Server  2000 - 8.00.760 (Intel X86)
      Dec 17 2002 14:22:05
      Copyright (c) 1988-2003 Microsoft Corporation
      Enterprise Edition on Windows NT 5.0 (Build 2195: Service Pack 4)


Destination DB: 8.00.760  3  2
Microsoft SQL Server  2000 - 8.00.760 (Intel X86)
      Dec 17 2002 14:22:05
      Copyright (c) 1988-2003 Microsoft Corporation
      Personal Edition on Windows NT 5.0 (Build 2195: Service Pack 4)
0
 
JulianvaCommented:
does your other database table  has the datatype bitint

0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
duke63Author Commented:
Yes Julianva.
rafrancisco, I thought this is allready done with activated "drop destination objects first" option in my dts package.
0
 
rafranciscoCommented:
duke63, somehow even if you have activated the "drop destination objects first", it still doesn't transfer bigint properly.  You really have to create the table first as a separate step before copying the data for the bigint to be properly copied.
0
 
duke63Author Commented:
Thanks rafrancisco !
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.