?
Solved

getting time out with Secure copy file

Posted on 2005-05-10
10
Medium Priority
?
1,806 Views
Last Modified: 2008-03-04
Hello

I am getting a timeout while using the scp function to copy a file from server to WS.

thror root ~ # scp root@xxx.xxx.xxx.xxx:label.txt user@yyy.yyy.yyy.yyy:/home/
Password:
ssh: connect to host xxx.xxx.xxx.xxx port 22: Connection timed out
lost connection

OS: Linux - gentoo

thank you

Dany Namroud
0
Comment
Question by:dnamroud
9 Comments
 

Author Comment

by:dnamroud
ID: 13969744
I can add, both sshd are up and running and i am able to open an ssh connection to the server from my WS...

0
 
LVL 2

Expert Comment

by:Shan_rocks
ID: 13969838
Do the following :

1. ssh to the server machine(xxx.xxx.xxx.xxx)
2. scp the file(label.txt) to WS(yyy.yyy.yyy.yyy) by using the below command
    scp label.txt user@yyy.yyy.yyy.yyy:/home/
0
 

Author Comment

by:dnamroud
ID: 13970040
i got time out too...

scp label.txt user@yyy.yyy.yyy.yyy:/home
ssh: connect to host xxx.xxx.xxx.xxx port 22: Connection timed out
lost connection

***************************
yyy.yyy.yyy.yyy Ip for my WS
and xxx.xxx.xxx.xxx IP for my server...

maybe i forget to say that i already tried before

I also added  -P 22  to my function but i got the same result


thank you

dany
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 1

Expert Comment

by:it_stops
ID: 13970472
Is it pingable? Do you have firewall enabled and not set to pass 22 on either machine?
0
 

Author Comment

by:dnamroud
ID: 13970538
yes it pingable from both side too...
I only disabled Port 21 and 23...
0
 
LVL 1

Expert Comment

by:it_stops
ID: 13971219
That's good. IIRC, I had to configure hosts.allow in /etc/ and enter the hosts or network. That was on OpenBSD. Miaswell(that's central floridian for:"[You] might, as well") check the hosts.deny(also in /etc/). Just for giggles, after verifying that your computer is not in the remote machine's hosts.deny, enter it in the hosts.allow or make hosts.allow in /etc if it isn't there already.
Steve
0
 

Author Comment

by:dnamroud
ID: 13971391
thank you for your help..
I checked /etc/hosts.deny my computer`s IP is not there...

Dany
0
 

Author Comment

by:dnamroud
ID: 14030187
I found the problem,

The problem was related to an application running over the network and causing this timeout while copying files from/to server.

Thank you guys for your help...

Dany
0
 

Accepted Solution

by:
modulo earned 0 total points
ID: 14557543
Closed, 125 points refunded.
modulo
Community Support Moderator
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It’s 2016. Password authentication should be dead — or at least close to dying. But, unfortunately, it has not traversed Quagga stage yet. Using password authentication is like laundering hotel guest linens with a washboard — it’s Passé.
Fine Tune your automatic Updates for Ubuntu / Debian
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses
Course of the Month17 days, 4 hours left to enroll

862 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question