It takes a long time to open any File (even 1KB .txt file).

Anybody to help me?
It takes a long time to open any File (even 1KB .txt file).
Task Manager also does not show anything special.

This started happening since today morning. I do not remember, if I did some changes to my PC.

Can anybody tell me how I should diagnose this problem?
LVL 5
chinawalAsked:
Who is Participating?
 
Pete LongTechnical ConsultantCommented:
Windows XP running slowly?

The following is a list of tweaks and tips for speeding up Windows XP.

------------------------------

Make Sure You're virus Free

Go To http://security.symantec.com/ssc/vc_about.asp?ax=0&langid=ie&venid=sym&plfid=23&pkj=LUDKIHKERRDTIPOKYJL
For a Free online check

------------------------------

Make sure you don't have any Spyware or Adware running on you're PC

Visit http://www.lavasoftusa.com/software/adaware/

------------------------------

Turn off automatic updates!

Start >Control Panel > Performance and Maintenance > System >Automatic Updates tab > Tick "Turn off Automatic Updating"

Or if you're on Windows Classic view

Right Click My Computer and select Properties > Automatic Updates tab > Tick "Turn off Automatic Updating"

You will now need to stop the service

Start >Control Panel > Performance and Maintenance > Administrator Tools > Services >Locate the "Automatic Update" service > Right click it and select Properties > Change the Startup Type to "Disabled".

**Warning its now up to you to keep up to date with any hot fixes or service packs.

------------------------------

Disable "System Restore" service and "Indexing" service

Start >Control Panel > Performance and Maintenance > System >System Restore Tab > Tick "Turn off System Restore"

Or if you're on Windows Classic view

Right Click My Computer and select Properties > System Restore Tab > Tick "Turn off System Restore"

You will now need to stop the service

Start >Control Panel > Performance and Maintenance > Administrator Tools > Services >Locate the "System Restore" service > Right click it and select Properties > Change the Startup Type to "Disabled". Then Locate the Indexing Service and disable that also.

------------------------------

Tweak the Page File settings.

See http://www.geocities.com/ziyadhosein/wxptwks.htm

------------------------------

Defrag the Hard Drive!

Even if XP tells you it doesn't need doing!

------------------------------

Find out what’s running in the background!

Press Ctrl + Alt + Delete

Then click the processes Tab (Lot of stuff there eh!) Find out what all that means here

http://www.answersthatwork.com/Tasklist_pages/tasklist.htm

If there's anything that shouldn’t be running, uninstall it! Or find out where it was launched from, either the startup folder, or from the registry, look at this registry key

HKLM\Software\Microsoft\Windows\CurrentVersion\Run

------------------------------

Find out what services (You don’t need) are running in the background

Look here http://www.blackviper.com/WinXP/service411.htm

------------------------------

Ensure You’ve got all the latest Service Packs and Hot fixes From Microsoft
http://v4.windowsupdate.microsoft.com/en/default.asp
Ensure You have all the latest Drivers for Your Hardware (And Windows XP supports it!)
http://www.microsoft.com/whdc/hcl/default.mspx

------------------------------


If you don’t see any improvement after that lot GO AND BUY SOME RAM!!!
0
 
Pete LongTechnical ConsultantCommented:
Hi chinawal,
files on what? locally, on a domain server - or in a workgroup

PeteL
0
 
chinawalAuthor Commented:
It's on my local PC. Windows XP.
0
Network Scalability - Handle Complex Environments

Monitor your entire network from a single platform. Free 30 Day Trial Now!

 
chinawalAuthor Commented:
I will the things you mentioned. But my PC was in good condition till morning. I did not use internet yesterday/today.
I do not have any virus on my PC. I am not running any spyware. I had automatic updates OFF.

This is what is surprising to me:
When I double-click on file, say 1.txt (with 1KB size) in explorer, it takes me 2 minutes to open the file.
When I run notepad/msword from start-->programs-->..., it opens the application within second.
When I open the same 1.txt file from notepad/msword, it opens that file within a blink of an eye.

Same thing happens to other files (.exe, .dat, .pdf, .doc, .xls etc.)
------------------------------------------------------------------------------------------
I had modified ODBC DSN registry yesterday. But PC was working fine after that.
0
 
MrArubaCommented:
If you know the manufacturer of your hard drive go to the website and download the tool to test your hard drive.
It could be a dying hard drive or some bad sectors on it. If you're lucky (and with most manufacturer's tool you will be) you get a much better test result.

good luck
0
 
ZoidlingCommented:
Check to see if you have a mapping to a resource (such as a network share) that is no longer available.  If so, delete the mapping.
0
 
bsochanCommented:
What did you modify in the ODBC DSN registry yesterday.

If you feel comfortable undo the change then reboot the box and see if it has any effect.
0
 
veaceslavzCommented:
Try to open file throuth Windows Explorer, but without left side of Explorer (uncheck "Folder" button in Windows Explorer). If it works for you then seems to be only Explorer indexations problem.
Try the folowing: Right click on the hard-disk (where you store needed files)-> Properties uncheck "Allow Index services..."
Also which version of Windows you have? Service Packs?
0
 
chinawalAuthor Commented:
I tried all above options (including Defragmentation, ODBC undo,  disconnected all network drives, removed "Allow index servies" checkbox. But it seems it still did not work.
Now, when I double click on any file in Explorer, sometimes it opens within a blink of eye. But most of the times, when I do the same thing, it takes a minute to open the same file. (Also, when I open the same file directly from the respective application through menu, it opens quickly).
0
 
chinawalAuthor Commented:
I tried alomst everything, but still could not resolve this problem.
It is happening only when I right click/double click the file.

Also, I have an old hardware profile that I had created 2 months back. If I restore it, I think it may work.
What implications would it have on my other softwares, if I restore my old hardware profile?
0
 
Tim HolmanCommented:
Can you scan for viruses?  This sounds like worm / viral activity.
0
 
veaceslavzCommented:
Did you use antivir/spyware/ad-ware?
0
 
chinawalAuthor Commented:
Yes. I did run anti virus- E-Trust. Also, I ran spywares too. But i could not solve this.
0
 
Tim HolmanCommented:
Can you read OK from alternate media - eg a CD ROM, or loading a WWW page from the Internet?

0
 
chinawalAuthor Commented:
Same problem with CD-ROM also. Loading www page from internet is works fine.
When I try to double-click on a file or right-click on file or copy using Menu bar or do Cntr +C etc., my Windows explorer hangs for almost (2 to 3 minutes).

But when I do 'Copy to Folder' or 'Move to Folder' using Menu bar, my windows explorer behaves perfectly fine.
0
 
Tim HolmanCommented:
When you try and open a file, what does Task Manager report - are there any processes taking up 100% CPU ?
0
 
MrArubaCommented:
This is strange behavior, try this :

open a command prompt, use the command SFC /SCANNOW
this will restore your system files without you losing any data/configurations.
have your os cd at hand, you probably gonna need it.
0
 
teamltiCommented:
I have the same problem (i.e. double-clicking on a file takes 1 minute to open while if I open Word, it opens in 2 seconds).  However, I ran a couple of checks to see what could be going on when I try to open the file.  Only the anti-virus and Word are affected by double-clicking on the .doc file.  However, I decided to look at the TCP traffic log and noticed that one connection timed out...  the system was trying to access a computer that was not on the network anymore.  Disabling the network card fixes the problem.  Also, if I set the IP of the problematic computer to be the one of that "deleted" computer, everything works fine (double-clicking opens instantly)...  It is a decent workaround, but I still don't know why the problem occured in the first place (or how to properly correct it)
0
 
Tim HolmanCommented:
Delete contents of c:\windows\prefetch
Clean out all Temporary Internet Files
Go to Network Connections and remove all shared drives
Disable findfast -

Findfast, now the Indexing Service, is enabled by default for Windows 2000 and XP as part of the base installation. Unless you have a special need for a full text index of all local files, I recommend disabling it.

In Control Panel
Select Add / Remove Programs
Select Add / Remove Windows Components
Uncheck the Indexing Service
or simply change the Indexing Service from Automatic to Manual in the Services manager console.

from http://www.windowsnetworking.com/kbase/WindowsTips/WindowsNT/UserTips/Customization/GetRidofFindFast.html

Run Stinger on the machine -

http://vil.mcafeesecurity.com/vil/averttools.asp#stinger

If this doesn't pick up anything, please use HijackThs for diagnosis:

http://www.tomcoyote.org/hjt/

..and post the log @ www.hijackthis.de.

Autoruns is also useful in working out whether or not something has latched on to your system that shouldn't have:

http://www.sysinternals.com/Utilities/Autoruns.html

Then try SpyBot to clean up the rest of the mess:

http://www.safer-networking.org/en/download/

If any of these applications pick anything up, bear in mind you may need to disable System Restore AND run them again in SAFE MODE to ensure disinfection.

If this doesn't work, then at least we've elimnated 99.99% of what the problem may be...  :)
0
 
chinawalAuthor Commented:
I should have given points to teamlti. I got the temporary fix.
Disabling the network card/connections solve my problem.
But, I do not want to keep my network disabled while I am working. I need a permnent solution for this problem.
0
 
Tim HolmanCommented:
To properly diagnose, take a trace whilst opening a problematic .doc file:

How to setup a network trace using Etherreal -

1)  Go to http://www.ethereal.com/download.html
2)  Under Windows 98/ME/2000/XP/2003 Installers, select a site near you
3)  Download WinPcap_3_0.exe and ethereal-setup-0.10.11.exe
4)  Install WinPcap_3_0 - double click on the WinPcap_3_0.exe file, just click OK / Yes throughout
5)  Install ethereal-setup-0.10.11 - double click on the file, accept all the defaults (OK / Yes throughout)
6)  Start the Ethereal application
7)  Go to Capture > Start
8)  Under Interface, select your Internet facing interface.  If you're unsure, then select one, and continue.  If it displays results, then you've got the right interface, if your capture is empty, then select another interface and carry on...
9)  Under Capture Files, put \capture.cap
10)  Click OK
11)  Capturing will commence....
12)  Do what you want capturing
13)  Go back to Ethereal, click Stop
14)  Send me the c:\capture.cap file - email address is in my profile, so click tim_holman.

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.