Run-Time Error '1004' Unable to set the PaperSize Property of the PageSetup Class

Ok.
I get this error when trying to print a shared Excel file

Run-Time Error '1004':
Unable to set the PaperSize Property of the PageSetup Class

.PaperSize = xlPaperLetter

Not familar with this.
Thanks
kditroiaAsked:
Who is Participating?
 
moorhouselondonCommented:
My second para: IF you have added a third party product: then uninstalling Excel, deleting the Office directories, then reinstalling will cure the problem.

Warning: There is a risk uninstalling Office as it may not then reinstall smoothly.
0
 
moorhouselondonCommented:
You would be better off asking this question in the Microsoft Office section.  The folks in this (the WordPerfect Office) section are more likely to suggest "upgrading" to Quattro Pro to resolve your problem.  ;-)

However to be serious for one moment, it looks as if the error you have is to do with a macro that is being run by the spreadsheet (or the startup macro which executes every time you go into Excel).  Try editing the macro, finding the line with that line in it, then editing that line.  Have you recently installed a third party product which "drives" Excel?  If so, this might be where your problem lies.
0
 
kditroiaAuthor Commented:
This job works/prints fine from another workstation to the same printer.

 Wondering if I should re-install Excel.  Hoping not to.
0
 
kditroiaAuthor Commented:
ok I fixed it.  I added a Network printer and created a new tcpip port
Everything works now.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.