?
Solved

Weird old Problem in SUSE

Posted on 2005-05-10
8
Medium Priority
?
496 Views
Last Modified: 2013-12-06
When I installed SUSE 9.3 for the first time all went OK. But the next morning when I woke up, I booted up the system and it gave me this error message below:

Linux kernel: ACPI-0484: Warning: **error getting cpuindex for acpiid 0X2
linux ifup: No configuration found for sit0
linux kernel: end_request: I/O error, dev fd0, sector 0


I asked everyone on different forums but no one seems to know what was the cause. I had no fix for this. The only way I fixed it is by reinstalling.

My question is, how can I prevent this from happening again and what was the cause of this issue in the first place?
0
Comment
Question by:jslayton01
  • 3
  • 2
  • 2
  • +1
8 Comments
 
LVL 2

Accepted Solution

by:
Shan_rocks earned 280 total points
ID: 13975487
Hey Jslayton,

1. Linux kernel: ACPI-0484: Warning: **error getting cpuindex for acpiid 0X2

Not sure about this message. On most desktop machines better to disable the ACPI to avoid the warning.

2. linux ifup: No configuration found for sit0

sit0 is the interface to tunnel IPv6 packets over IPv4 networks. Unless you really are using IPv6, this is nothing to worry about. You can comment out the lines
alias sit0 ipv6
alias net-pf-10 ipv6
in /etc/modprobe.conf if you want.

3. linux kernel: end_request: I/O error, dev fd0, sector 0

Perfectly normal message when any process tries to access the floppy disk drive and there is no floppy disk.
The fd0 error is for your floppy disk drive. Did you have a disk inserted at bootup?
0
 

Author Comment

by:jslayton01
ID: 13983129
I reinstalled Linux selecting WITH ACPI....(I think)  and no problems whatsoever.

So, what caused this errors? The only things I disabled is the SUSEFirewall2 and NFS. And the next morning the errors came.

What should I do to prevent this from happening again? And just incase it does happen again, how can I fix it?

0
 
LVL 2

Assisted Solution

by:Shan_rocks
Shan_rocks earned 280 total points
ID: 13983845
To prevent this error from happenning again you can disable the ACPI. I assume that you're using Grub as your bootloader.

Edit the /etc/grub.conf file using "vi" or some other editor.

Here's a chunk of my original grub.conf:

default=0
timeout=10
splashimage=(hd0,0)/grub/splash.xpm.gz
title Red Hat Linux (2.4.20-6)
root (hd0,0)
kernel /vmlinuz-2.4.20-6 ro root=LABEL=/
initrd /initrd-2.4.20-6.img

Here's the changed section, note only the "kernel" line was changed:

default=0
timeout=10
splashimage=(hd0,0)/grub/splash.xpm.gz
title Red Hat Linux (2.4.20-6)
root (hd0,0)
kernel /vmlinuz-2.4.20-6 ro root=LABEL=/ acpi=on
initrd /initrd-2.4.20-6.img

"<<Do not mess with anything else in here. If you make a typo or an error, your system WILL not boot.>>". So be careful handling this grub.conf file.

Now, after you are done adding the "acpi=on" line.
Reboot your box, and you should now have ACPI enabled and your built-in peripherals should work now.

It's better to remove only the "acpi=on" to prevent that warning message. Since it's warning message you need not worry about this.

Have you corrected this  "2. linux ifup: No configuration found for sit0 and 3. linux kernel: end_request: I/O error, dev fd0, sector 0 " in your linux box?
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
LVL 2

Assisted Solution

by:sekargopi
sekargopi earned 400 total points
ID: 13985654

IMHO, these are only warning messages and nothing else. you can ignore them as long as your system boots up fine :)

Older mother boards are not so much compliant to ACPI standard which SUSE uses. So you are getting this warning message from ACPI module in kernel.

as the other member pointed out, other warning messages can be ignored

Gopi
0
 

Author Comment

by:jslayton01
ID: 13989425
The error messages did not let me login any furthur inorder for me to correct the problem. That was the problem.

What do the other error messages signify?
0
 
LVL 2

Assisted Solution

by:sekargopi
sekargopi earned 400 total points
ID: 13993455

oh ok, then it is serious problem :)

First disable ACPI. either update grub.conf as the other member pointed out, or just go to BIOS and disable power saving feature

second message is that by default SUSE is trying to set up sit0 interface which is not configured, so it gives the warning message

third message, suse is trying to mount the floppy device for some reason (good investigation would be to check SUSE startup scripts), since there is no floppy inserted in the device it gives this message.

or may be the floppy is the issue, if any floppy is in the system remove it and try to boot the system

Gopi
0
 

Assisted Solution

by:scope3k
scope3k earned 320 total points
ID: 13995833
i had this problem too it would boot into a grey login screen etc

heres how i fixed mine
start yast
go to System -> edit /etc/sysconfig-files
do a Search at thr bottom for xdm
find DISPLAYMANAGER xdm and open it
change it to kdm
reboot
0
 

Author Comment

by:jslayton01
ID: 14249146
Ok, now if the ACPI is activated how can I disable it?

And also, does the Screensaver have anything to do with the ACPI?
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In my business, I use the LTS (Long Term Support) versions of Linux. My workstations do real work, and so I rarely have the patience to deal with silly problems caused by an upgraded kernel that had experimental software on it to begin with from a r…
It’s 2016. Password authentication should be dead — or at least close to dying. But, unfortunately, it has not traversed Quagga stage yet. Using password authentication is like laundering hotel guest linens with a washboard — it’s Passé.
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Suggested Courses
Course of the Month13 days, 12 hours left to enroll

755 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question