[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3094
  • Last Modified:

No DNS servers are available

Don't know much about DNS so hopefully this will be easy.
We keep getting this event log on our only DC (SBS 2000)...

Event Type:      Warning
Event Source:      NETLOGON
Event Category:      None
Event ID:      5781
Date:            5/10/2005
Time:            2:09:01 PM
User:            N/A
Computer:      EXSERVER
Description:
Dynamic registration or deregistration of one or more DNS records failed because no DNS servers are available.


I looked at the Forwarders tab in the DNS properties and see we have two IP addresses we were told to use by our ISP. As far as I can tell, nobody is having any problems with email or internet access whatsoever.
I don't know what other information I need to provide to track down these event logs...hopefully somebody here can guide me...thanks.


0
DVation191
Asked:
DVation191
1 Solution
 
DVation191Author Commented:
If it makes any difference, the event is being logged every 2 hours consistently...
0
 
119supportCommented:
http://support.microsoft.com/?kbid=311354

See if that helps....

Do a google search for event id: 5781 and you should find some fixes to you issues.

There a way to many possibilties for DNS errors so its tough to diagnose your problem with out knowing a bit more information.

does you domain end with anything other than .local?

Have you always had the errors, or did they just start?

When they started, what changes were made to the server?

0
 
DVation191Author Commented:
I realize it can be difficult to diagnose. My lack of experience in this area makes it very intimidating to read through the 23 possible solutions to this particular event id, especially when I actually understand less than half of it.

our domain name is and always has taken the form of domain.local and the domain name has never changed.

i'm not positive about this, but at one point, for some odd reason, it was configured to use its own IP as DNS, and some people could not get to some pages, while others could. As soon as we used the ISP's dns servers, everything worked...except now we get these event logs.
0
Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

 
Chris DentPowerShell DeveloperCommented:

Basically your SBS server must use itself as DNS - it needs that to be able to find Active Directory (even though there's only itself).

I take it you have Forwarders configured in the DNS on SBS to your ISP?

HTH

Chris
0
 
DVation191Author Commented:
Yes on the forwarders tab in the DNS properties we have the two DNS IP addresses that our ISP told use to use. Are you saying that I should also put its own IP in that list as well?
0
 
Chris DentPowerShell DeveloperCommented:

No...

In the TCP/IP Configuration for the server it should use itself as Preferred DNS. Is that what it's doing at the moment?

I could have just misunderstood :)
0
 
DVation191Author Commented:
oh ok...no you understood fine...I just might not be using the right terminology.

I can go to Administrative Tools > DNS > right-click the server, choose Properties > click the "Forwarders" tab ...
here, the two IPs from our ISP are listed here.

In the TCP/IP properties of the only NIC we have enabled, the same two DNS addresses are listed here as well.

If I understand you right, this should not be the case. I should remove those two IPs from the TCP/IP Properties and only put itself in as the DNS address...right?
0
 
Chris DentPowerShell DeveloperCommented:

That's it yes :)

Locations of all the servers for Active Directory (like password servers and such) are stored in DNS, so it's quite important that it can see it all.

If you set that up can you still browse the web as normal?
0
 
DVation191Author Commented:
I made the change and all functionality seems to be intact.

Unfortunately the last event was logged at 12:09 EST...so i won't know until 2:09 EST that the DNS change actually worked. I'll post back as soon as I can though...thanks!!!
0
 
Chris DentPowerShell DeveloperCommented:

You can probably force it to produce the error again by running this lot from the command prompt:

ipconfig /flushdns
ipconfig /registerdns
net stop netlogon
net start netlogon

Otherwise later is fine :)
0
 
internocCommented:
It may help you if you wip blank the IP numbers (first write them down) for your DNS forwarders.
Next, put 127.0.0.1 as the first
and put your first DNS server address from you ISP on the second line.

Marc

PS: the 127.0.0.1 will refer your server to its own built-in DNS
0
 
DVation191Author Commented:
So you think I should add my ISP's DNS server as a secondary DNS in the TCP/IP Properties? Why would I need to do that when the ISP's DNS server is already in the Forwarders list?
0
 
DVation191Author Commented:
Looks like 2:09 EST has come and gone...and there are no events logged with DNS errors...woohoo!

lol...thank you!
0
 
Chris DentPowerShell DeveloperCommented:

You shouldn't need to do anything else with the ISPs DNS - you definately don't want them in the TCP/IP configuration.

Equally there is no point in adding something like 127.0.0.1 in the forwarders list (shouldn't be confused with the list in TCP/IP configuration). Basically all that happens when you add Forwarders is that any question your DNS doesn't know about is passed onto someone else - they do all the work looking around for the answer.

Anyway, I'm glad it's all working :)
0

Featured Post

New Tabletop Appliances Blow Competitors Away!

WatchGuard’s new T15, T35 and T55 tabletop UTMs provide the highest-performing security inspection in their class, allowing users at small offices, home offices and distributed enterprises to experience blazing-fast Internet speeds without sacrificing enterprise-grade security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now