[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 351
  • Last Modified:

failing to access samba from windows

Hi EE,  below is my smb.conf file.  I have (i think) installed samba.  But when I try and access the shares from a windows machine,  my password is not accepted.  I have tried this on both win98 and xp.  I can see the pc in the network neighbourhood. And the user on the windows system (including password) is a valid user on the linux system, but it keeps prompting me for password.  On another note.  when I allowed null password, then I have access and it even shows the correct home folder for the user logged in.



[root@Turtle1 data]# vi /etc/samba/smb.conf
# This is the main Samba configuration file. You should read the
# smb.conf(5) manual page in order to understand the options listed
# here. Samba has a huge number of configurable options (perhaps too
# many!) most of which are not shown in this example
#
# Any line which starts with a ; (semi-colon) or a # (hash)
# is a comment and is ignored. In this example we will use a #
# for commentry and a ; for parts of the config file that you
# may wish to enable
#
# NOTE: Whenever you modify this file you should run the command "testparm"
# to check that you have not made any basic syntactic errors.
#
#======================= Global Settings =====================================
[global]
        log file = /var/log/samba/%m.log
        load printers = yes
        idmap gid = 16777216-33554431
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        enne which starts with a ; (semi-colon) or a # (hash)
# is a comment and is ignored. In this example we will use a #
# for commentry and a ; for parts of the config file that you
# may wish to enable
#
# NOTE: Whenever you m line which starts with a ; (semi-colon) or a # (hash)
# is a comment and is ignored. In this example we will use a #
# for commentry and a ; for parts of the config file that you
# may wish to enable
#
# NOTE: Whenever you mcrypt passwords = yes
        winbind use default domain = no
        template shell = /bin/false
        dns proxy = no
        server string = Turtle1
        idmap uid = 16777216-33554431
        workgroup = netcon
        os level = 20
        printcap name = /etc/printcap
        security = user
        max log size = 50

[homes]
   comment = Home Directories
   browseable = no
   writable = yes

# Un-comment the following and create the netlogon directory for Domain Logons
; [netlogon]
;   comment = Network Logon Service
;   path = /home/netlogon
;   guest ok = yes
;   writable = no
;   share modes = no


# Un-comment the following to provide a specific roving profile share
# the default is to use the user's home directory
;[Profiles]
;    path = /home/profiles
;    browseable = no
;    guest ok = yes


# NOTE: If you have a BSD-style print system there is no need to
# specifically define each individual printer
[printers]
   comment = All Printers
   path = /var/spool/samba
   browseable = no
# Set public = yes to allow user 'guest account' to print
   guest ok = no
   writable = no
   printable = yes

0
aduhwale
Asked:
aduhwale
1 Solution
 
wesly_chenCommented:
>         security = user
Did you create Linux accoount whose account name is the same as your Windows'?
0
 
jlevieCommented:
For any version of windows since the original release of win95 you'll need:

security=user
encrypt passwords = yes

in smb.conf. In addition to that you'll have to execute 'smbpasswd -a linux-username' for each user.
0
 
aduhwaleAuthor Commented:
jlevie, ur a genius!  It's working now. I didnt have to execute the smbpassword command as above since i used webmin to create the accounts and had syncronisation configured.  Thanks
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

Tackle projects and never again get stuck behind a technical roadblock.
Join Now