?
Solved

Read only after restore

Posted on 2005-05-11
5
Medium Priority
?
608 Views
Last Modified: 2009-04-17
After running a restore of a volume with Bright Store v 1.11 the files and dirs were marked read only.  Went in to the root dirs and took the read only attribute off the command ran but once you go back into the directory properties it's set as read only again.  Ran the same thing from the command line and still no luck.  Ran CHKDSK but found no errors.  Any ideas?  System is running Windows 2003 Standard.  After playing with it I go the folder contents to not  be read only but all the directories are set as read only.  When a user goes (that has permissions to the directory) to add or modify they get an access denied.

Any ideas?
0
Comment
Question by:chilemoore
3 Comments
 
LVL 25

Expert Comment

by:mikeleebrla
ID: 13980951
folders cannot have the read only attrubute, this is a FILE attrubute. that little checkbox on a folder doesn't do anything.

http://support.microsoft.com/default.aspx?scid=kb;en-us;326549
http://www.annoyances.org/exec/forum/winxp/1065399208
http://www.experts-exchange.com/Operating_Systems/Q_20941466.html
0
 
LVL 18

Accepted Solution

by:
luv2smile earned 750 total points
ID: 13980995
You need to check the NTFS permissions (security tab).

NTFS permissions are what control access to files/folders. If someone is getting an access denied message that means that they don't have the appropriate rights. But you don't change these by that little check box...you need to go to the SECURITY tab and change the permissions there. Also make sure you have the share permissions set correctly. Best practice is to give everyone full control to share permissions and use NTFS to control access.

As Mike said, ignore that little check box on the general tab. It is bad design and doesn't do anything and you can't change it.  
0
 

Author Comment

by:chilemoore
ID: 13981109
As a world famous philosopher said may a time, DOHHH!   Feel stupid now.  When I shared the folder I didn't change the default everyone read that Windows 2003 assigns by default.

I had compred the folder read-only check box to some other shared dirs and had noticed that the checkbox was grayed out.

Hmmm...  Just one of those days..
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A quick step-by-step overview of installing and configuring Carbonite Server Backup.
Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
Are you ready to place your question in front of subject-matter experts for more timely responses? With the release of Priority Question, Premium Members, Team Accounts and Qualified Experts can now identify the emergent level of their issue, signal…
Screencast - Getting to Know the Pipeline

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question