• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1173
  • Last Modified:

Starting httpd: perl: warning: Setting locale failed.

Starting httpd: perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "en_US:en"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").


CAn someone help ? I'm not sure how to fix this
0
dehutchings
Asked:
dehutchings
  • 4
  • 4
  • 2
  • +1
1 Solution
 
TintinCommented:
Edit /etc/sysconfig/i18n to set the locale.
0
 
sekargopiCommented:

the local langugae variable is not set

these are basically $LANG, $LC_ALL etc

try echo $LANG from your shell, if you are able to get values like en-US, then your perl is not configured to use the local settings. otherwise you have not configured local for your system.

if you are using redhat then try editing /etc/sysconfig/i18n file to set your language, or you could manually export these variables by
export LANG=¨en-US¨

Gopi
0
 
dehutchingsAuthor Commented:
This is what the output was from i18n, what next?

LANG="en_US:en"
SUPPORTED="en_US.UTF-8:en_US:en"
SYSFONT="latarcyrheb-sun16"
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
sekargopiCommented:


did you check output of echo $LANG from shell prompt, it will show whether LANG is actually set for your environment or not.

also check the perl (did you compile perl your self), its likely that perl is not compiled to use the local settings.

Gopi
0
 
dehutchingsAuthor Commented:
yep, this is what I got.

LANG="en_US:en"
0
 
sekargopiCommented:

ok i got your problem, its the perl which is warning that your system locale settings are wrong.

your system installation has some wrong locale settings. to find out how to fix this problem, check the man page

man perllocale

go to section LOCALE PROBLEMS and it states the exact problem you are referring to and solution to fix that problem

Regards,
Gopi
0
 
dehutchingsAuthor Commented:
I checked my locale list and it looks like this..


[root@linux locale]# ls
af             el           es_PE  ia            nb_NO         sv
all_languages  en           es_SV  id            nl            ta
am             en_AU        et     is            nn            tg
ar             en@boldquot  et_EE  it            nn_NO         th
az             en_CA        eu     ja            no            tr
be             en_GB        eu_ES  ja_JP.eucJP   no_NY         uk
bg             en@IPA       fa     ja_JP.SJIS    pl            uk_UA.cp1251
bn             en@quot      fi     kn            pt            vi
bs             en_SE        fi_FI  ko            pt_BR         wa
C              en_US        fr     l10n          ro            xh
ca             eo           fr_FR  locale.alias  ru            zh
cs             es           ga     lt            ru_RU.cp1251  zh_CN
cs_CZ          es_DO        gl     lug           ru_RU.koi8r   zh_CN.GB2312
cy             es_ES        gr     lv            sk            zh_TW
da             es_GT        he     mk            sl            zh_TW.Big5
da_DK          es_HN        hi     mn            sp            zu
de             es_MX        hr     ms            sq
de_DE          es_PA        hu     nb            sr
[root@linux locale]#

------------------------------------------------------------

it is supposed to resemble this..

en_US.ISO8859-1     de_DE.ISO8859-1     ru_RU.ISO8859-5
              en_US.iso88591      de_DE.iso88591      ru_RU.iso88595
               en_US               de_DE               ru_RU
               en                  de                  ru
               english             german              russian
               english.iso88591    german.iso88591     russian.iso88595
               english.roman8                          russian.koi8r

----------------

The manual tells me to set LANG_ALL to en_US.ISO8859-1 but everytime I try the settings dont stick, maybe en_US.ISO8859-1 isnt installed.
0
 
sekargopiCommented:

yes i believe so. may be you may have to install the missing language, i dunno how to do it. may be the manual can be of helpful in acheiving that.

meanwhil there is a section in the manual which says how to fix this problem temporarily, just see whether this solves your problem. if so then go for permanent solution.

Also you have to set LANG_ALL using export command to set it permanent.

Did you take a look at locale and localedef commands, they might also be of helpful.

I would suggest you to go by the perl documentation on how to fix this issue.
0
 
TintinCommented:
Edit /etc/sysconfig/i18n and set:

LANG="en_US"
SUPPORTED="en_US.UTF-8:en_US:en"
SYSFONT="latarcyrheb-sun16"
0
 
dehutchingsAuthor Commented:
Tintin,
its already set to that.
0
 
idmiskCommented:
what dist are you running?
try 'locale-gen'
please post the output of 'locale'

edit your /etc/profile or (better if works) /etc/profile.local  or ??? (this is distribution dependant) and add
export LC_ALL="en_EN"
export LANGUAGE="en_EN"
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 4
  • 4
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now