WinZip problem via Citrix ICA client

Hello... we have published an application vis Citrix MetaFrame XPe... When users login via ICA client over the browser and try to open a .zip file from that application, WinZip always starts in setup mode, where the users has to finish the installation. WinZip is installed on the server, but not sure why it prompts again and again via ICA client to complete installation for the users. Pls help???????????
yasmagicAsked:
Who is Participating?
 
moduloConnect With a Mentor Commented:
PAQed with no points refunded (of 500)

modulo
Community Support Moderator
0
 
ignusbCommented:
If one user finishes the install, does it still prompt the next time they try to open a .zip?
Although it sounds obvious, have you tried re-installing it on the server getting a different version?
0
 
Mohammed HamadaSenior IT ConsultantCommented:
Try once the installation is finished to delete everything in the temp...
Or copy the whole setup file to the client.
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

 
ignusbCommented:
copying the whole setup file to the client will not fix many problems, because on a large scale network, installing a program on everyones username which is probably disabled from user initiation is very impractical, maybe on a small windows 2003 server based network it would be a good solution.
0
 
yasmagicAuthor Commented:
Thanks guys... I have fixed the issue by myself... The problem was that WinZip's user registry settings are not preserved between sessions, and so WinZip was repeating the installation process again and again via Citrix ICA client. The following steps were taken to correct this problem:

1) Create a plain text file called, "AUTOINST.TXT" and place it in the WinZip folder. This file contains the exact phrase, "I agree to the WinZip Computing License Agreement". (Without quotes)

2) Delete the file WZSHLEXT.DLL from the WinZip folder as WinZip 7.0 was first installed and then upgraded to 8.1 for licensing reasons.

3) Add the following line in C:\Winnt\System32\usrlogon.cmd

          c:\progra~1\winzip\winzip32.exe /autoinstall

The above is needed to avoid a blank WinZip window appearing in Citrix.
0
 
Mohammed HamadaSenior IT ConsultantCommented:
Glad you solve it Yasmagic.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.