• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 432
  • Last Modified:

Microsoft wireless optical mouse always "double-clicks" on left mouse button click for Windows XP laptop

Greetings wize wizards of EE:

I have a friend with a Sony Vaio laptop, running Windows XP, 1+ GHz processor, 512 MB RAM. He has a Microsoft wireless optical mouse that will ALWAYS "double-click" when the left mouse button is clicked; left-clicked only once, that is. So, it is not possible to SELECT anything with the left mouse button by a single-click....wherever the left click button is hit, it acts like a "double-click", and opens whatever item/icon is clicked on.

I thought this was a simple fix, in that I could open up the MOUSE icon in the Control Panel, and change the "double-click" setting to just a "Click" setting for the left button. To my dissapointment, the left button was set for just "Click", and not "Double-Click". This mouse utility however, showed a diagram of the laptop thumbpad, and NOT the wireless mouse itself... The thumbpad & laptop left button were working normally...only the wireless mouse was misbehaving.

I didn't think to ask my friend if he had actually installed any drivers for this Microsoft wireless mouse...could that be it? Does a Microsoft wireless mouse even need a driver for Windows XP? My friend is out of town for a week, and I'm trying to find an answer for when he returns. Please advise with your infinite wisdom.

Many thanks in advance,

Zovoth
0
zovoth
Asked:
zovoth
  • 2
2 Solutions
 
rudy_baggaCommented:
Check out this microsoft knowledgebase article:

http://support.microsoft.com/default.aspx?scid=kb;en-us;266738

XP will generally recognize almost any mouse as a standard human interface device (HID).  It is necessary, however, to load the MS Intellipoint S/W to take full advantage of the features of the Wireless Optical Mouse.

Go here and select the exact device you have to get the appropriate driver:

http://www.microsoft.com/hardware/mouseandkeyboard/Download.mspx
0
 
rindiCommented:
Open Control Panel, Folder Options, and check the "General Tab". Probably The "click Items as Foolows" section is set for on of the single click options, and not your preferred "double-click to open an item (Single click to select)".

I personaly prefer the single click option.

If this is not the cause for your "problem", it may be the buttons on your mouse arent working correctly. Do you get the same result if you change the mouse for another one?
0
 
zovothAuthor Commented:
Greetings rudy bagga & rindi:

Many thanks for your help & super-fast response. I don't visit my friend for another week, but I am confident you have provided me with the answers I seek, particularly from the useful links from rudy bagga.

I shall use the information in the Microsoft troubleshooting links, and use a second wireless optical mouse to confirm that the trouble is isolated to my friend's mouse.

You've shown me the way to illumination, thank you indeed.

Zovoth
0
 
rindiCommented:
Thanx too.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now