?
Solved

Microphone Problem

Posted on 2005-05-12
12
Medium Priority
?
5,204 Views
Last Modified: 2007-12-19
I am running a brand new HP Pavilion T860a computer with an AsusTek PTGD1-LA motherboard with an intergrated 8-Channel Azalia audio sound card with front and rear microphone jacks, and using the very latest RealTek sound drivers .

My problem is that when I try internet telephony using Skype, I can hear the other person perfectly, BUT THEY CANNOT HEAR ME AT ALL.

Other than that, the sound system works perfectly.

I have read and followed all the advice on both the HP and Skype websites  but all to no avail.

I can record my voice using the windows recorder and play it back perfectly. I have also made sure that my mic is not muted.

It is interesting to note that when I disable the onboard sound card and add the Creative sound card from my old computer, the Skype program works perfectly.

Lookint forward to hearing your solutions - Inkie
0
Comment
Question by:Inkie
  • 3
  • 2
  • 2
  • +3
12 Comments
 
LVL 93

Assisted Solution

by:nobus
nobus earned 300 total points
ID: 13984524
i would try updating the chipset  and sound board drivers first
0
 
LVL 8

Assisted Solution

by:ddrdan
ddrdan earned 150 total points
ID: 13984908
Have you tried turning off your firewall?
0
 
LVL 69

Assisted Solution

by:Callandor
Callandor earned 300 total points
ID: 13985605
Check if your onboard sound card is using nonstandard IRQ or I/O address settings that your telephony program doesn't recognize.  These are usually configurable in the BIOS.  A different soundcard driver would be something to check also, as nobus recommends.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 2

Assisted Solution

by:Greenandroid
Greenandroid earned 600 total points
ID: 13988169
I would be inclined to say this is a problem with skype, and how it is set up on your computor.

I'm sure you have probably already tried  :
http://support.skype.com/index.php?_a=knowledgebase&_j=questiondetails&_i=147&nav2=Technical
(i know this isn't technically the problem you have, but will verify if some of your sound settings are correct)

Also please go to Tools/Options/Sound Devices, and tell me what it has listed for Audio In and Audio Out. If you haven't already, try changing these options and see what it does.

Have you tried uninstalling skype, and reinstalling it afterwards? Same problem?
0
 
LVL 23

Accepted Solution

by:
gecko_au2003 earned 150 total points
ID: 13990971
Probably a silly suggestion, but after you open up the program, make sure that in the recording devices that you have checked and selected the mic and make sure that you are using or have the mic as the selected recording device !

Only reason I say that is because with yahoo messenger and other apps that you can use the mic with, it some times selects another recording device :)

I mean just to test it , what happens if you use yahoo messenger with regards to talking to other people ? Can the other people still hear you ? Also yahoo messenger has an audio setup wizard and so does msn messenger, not sure if thats of any use to you though ??

Windows has netmeeting which can be downloaded for win 9x, windows 2000 platforms and I am pretty sure is already included with windows xp.

So maybe test it out with NetMeeting ??
0
 

Author Comment

by:Inkie
ID: 13991893
First a thank you to everyone for their assistance.

nobus - I have downloaded the latest sound drivers from realtek but this has not helped. With regard to the chipset, I must be perfectly honest and admit tht I do not how to do this. Could you please advise me on how to go about it.

ddrdan - I not only turned it off but actually uninstalled it - all to no avail.

Callondor - How can I check what I/O address my Skype telephony program recognizes? Also what would a nonstandard IRQ address be?
                I see that all my communication devices are using IRQ 16. The list is as follows Agere Systems PCI soft modem, Intel 82801FB/FBM PCI express root port 2660, Intel 82801FB/FBM USB universal host controller 265B, Intel 915G/P/GV express root port 2581, Microsoft UAA bus driver for high definition audio and Radeon X300 series. Is any of this a problem?

Greenandroid - HP agrees with you. I have used the article you suggest but it also was not of any use. I have e-mailed Skype but have not heard back from them.
                      On my Sound playback there is only one choice - Realtek HD Audio rear output.
                      On the sound recording tab there are 4 choices - Realtek HD digital input, Realtek HD front green jack, Realtek HD front pink jack and lastly "back line-in/Mic, front line in".
I have tried changing these but it has also been of no value.

gecko au2003 - I have done all that you suggest but also of no use.

Thanks - Inkie
0
 
LVL 69

Assisted Solution

by:Callandor
Callandor earned 300 total points
ID: 13992628
A standard IRQ and I/O address for a sound card is IRQ 5 or 7 and I/O address 0x220 - these are legacy SoundBlaster values.  You will need to check the manual for the Skype program to see what they use.
0
 
LVL 93

Assisted Solution

by:nobus
nobus earned 300 total points
ID: 13993725
you can download the motherboard drivers from HP; here how to do it :

Restoring software and drivers in Windows XP

Perform the following steps, in order, to restore a software application or driver using the Application Recovery software:


NOTE: If the software application that you are looking for is not listed in the application recovery software, the same software may be downloadable from the Web, or you can perform an entire system recovery, or you can purchase and use a full version.


Click Start, All Programs, HP Tools or PC Help and Tools, and Application Recovery.

In the Recovery window, select either Drivers or Applications, and click Next.

Select the software driver or application that is to be reinstalled, and click Next.

The driver or application is automatically reinstalled and may take a long time to complete.



http://h10025.www1.hp.com/ewfrf/wc/document?dlc=en&lc=en&product=449306&lang=en&cc=us&docname=bph07142
0
 
LVL 2

Assisted Solution

by:Greenandroid
Greenandroid earned 600 total points
ID: 13996021
Hmm,

On your skype sound devices page, are there any more options you can specify for audio in and audio out (other than those you mentioned).... I say this because mine were automatically set to 'Windows Default Device' when i installed Skype.

As you previously mentioned.. :
"On my Sound playback there is only one choice - Realtek HD Audio rear output."

Does it not list 'Windows Default Device' AND 'Realtek HD Audio rear output' ?
>> If it does list the default device, select this option for both audio in and audio out.

Can you also check to see whether 'Enable Automating Sound Device Settings Adjustment' is enabled.


0
 

Author Comment

by:Inkie
ID: 13998593
Hi Guys

I have just had an e-mail from Skype and the solution they sent has resolved my problem.

The first step was to change certain settings in the Skype options (as Greenandroid suggested) - uncheck the "enable automatating sound device setting" and selecting my preferred audio in jack.

The next step involved making changes to the Skype connection settings found in the Skype Application Data folder.

If any of you want the exact details let me know and I'll willingly provide them.

Thanks for your assistance - Kind regards - Inkie
0
 
LVL 23

Expert Comment

by:gecko_au2003
ID: 13998952
Full details would be good for future reference, if it is too much to post here. Then if it is ok with EE rules, then if you could please email me them :) My email addy is in my profile ;)

Thanks and kind regards

Gecko
0
 

Author Comment

by:Inkie
ID: 14003997
Here are the instructions from Skype as sent to me -

1. Go to Skype --> Tools --> Options --> Sound devices --> Uncheck the box "enabling automating sound device settings adjustment.
2. Select your preferred mic as the "Audio In" device.
3. Go to Start -> Programs -> Accessories -> Entertainment -> Volume control.
4. In the volume control window go to Options -> Properties and select the "microphone" radio button.
5. Then goto Options -> Advanced and toggle "boost" if available.
6. Set the mic volume to 50% or more. Ignore if mic is muted. It is controlled by Skype.
7. Test your sound with Skype echo123.

If it didn't help then proceed as follows.

8. Quit Skype.
9. Navigate to C: -> Documents and Settings -> All Users -> Application Data -> Skype and delete "shared.xml".
10. Next navigate to Documents and Settings -> "WindowsUserName" -> Application Data -> Skype -> "SkypeUserName" - config.xml.
11. Open using any word editor.
12. In <Call> find <AGC>1</AGC>.
13. If the entry is missing, add it.
14. In <General> find the entries <AEC>1</AEC> and <AGC>1</AGC>.
15. If the entries are missing add them.
16. Try toggling the entries in <Call> and <General> ( always similtaneously) from 1 to 0 or vice versa.
17. In <MicVolume>xxx</MicVolume> (xxx represents a number) try increasing the number up to 255.
18. Note 1 - This value can only be increased when AGC is set to 0.
     Note 2 - Skype MUST NOT BE RUNNING  while you make these changes.

Hope this is of value,

Regards - Inkie
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I use more than 1 computer in my office for various reasons. Multiple keyboards and mice take up more than just extra space, they make working a little more complicated. Using one mouse and keyboard for all of my computers makes life easier. This co…
pc, laptop  monitor connection configurations
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…
Want to learn how to record your desktop screen without having to use an outside camera. Click on this video and learn how to use the cool google extension called "Screencastify"! Step 1: Open a new google tab Step 2: Go to the left hand upper corn…
Suggested Courses

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question