?
Solved

How to create a vpn connection on a Cisco 837 Router?

Posted on 2005-05-12
3
Medium Priority
?
1,176 Views
Last Modified: 2012-05-05
I want to connect with vpn on a Cisco 837 router, but it won't work. Can anybody help me with my config.

This is my config:

VORT01#sh ru            
Building configuration...                        

Current configuration : 2561 bytes                                  
!
version 12.3            
no service pad              
service timestamps debug datetime msec                                      
service timestamps log datetime msec                                    
service password-encryption                          
!
hostname VORT01              
!
enable secret 5 ****                                              
enable password 7 ****                                  
!
username **** privilege 15 password 7 ****                                                      
username **** privilege 15 password 7 ****                                                              
username **** password 7 ****                                              
no aaa new-model                
ip subnet-zero              
!
!
ip audit notify log                  
ip audit po max-events 100                          
vpdn enable          
!
vpdn-group pptp              
! Default PPTP VPDN group                        
 accept-dialin              
  protocol pptp              
  virtual-template 1                    
!
no ftp-server write-enable                          
!
!
!
!
!
!
!
interface Loopback0                  
 ip address 172.16.4.254 255.255.255.0                                      
!
interface Ethernet0                  
 ip address 192.168.0.250 255.255.255.0                                      
 ip nat inside              
 hold-queue 100 out                  
!
interface Virtual-Templa                      
 ip unnumbered Loopback0                        
 peer default ip address pool pptp                                  
 ppp encrypt mppe auto                      
 ppp authentication ms-chap -chap                                
!
interface ATM0              
 no ip address              
 no ip mroute-cache                  
 atm vc-per-vp 64                
 no atm ilmi-keepalive                      
 pvc 8/48        
  encapsulation aal5mux ppp dialer                                  
  dialer pool-member 1                      
 !  
 dsl operating-mode auto                        
 hold-queue 224 in                  
!
interface FastEthernet1                      
 no ip address              
 duplex auto            
 speed auto          
!
interface FastEthernet2                      
 no ip address              
 duplex auto            
 speed auto          
!
interface FastEthernet3                      
 no ip address              
 duplex auto            
 speed auto          
!
interface FastEthernet4                      
 no ip address              
 duplex auto            
 speed auto          
!
interface Dialer1                
 ip address negotiated                      
 ip access-group 111 in                      
 ip nat outside              
 encapsulation ppp                  
 dialer pool 1              
 dialer-group 1              
 ppp authentication chap pap callin                                  
 ppp chap hostname ****@****                                    
 ppp chap password 7 ****                                    
 ppp pap sent-username ****@**** password 7 ****                                                                    
 ppp ipcp dns request                    
 ppp ipcp wins request                      
 hold-queue 224 in                  
!
ip local pool pptp 172.16.4.1 172.16.4.30                                        
ip nat inside source list 102 interfac                                    
ip nat inside source static tcp 192.168.0.254 25 interface Dialer1 25                                                                    
ip classless            
ip route 0.0.0.0 0.0.0.0 Dialer1                                
ip http server              
no ip http secure-server
!
access-list 23 permit 192.168.0.0 0.0.0.255
access-list 23 permit 172.16.4.0 0.0.0.255
access-list 102 permit ip 192.168.0.0 0.0.0.255 any
access-list 111 permit tcp any any eq 1723
access-list 111 permit udp any any eq isakmp
access-list 111 permit gre any any
access-list 111 permit tcp any any eq www
access-list 111 permit tcp any any eq smtp
access-list 111 permit ip 192.168.0.0 0.0.0.255 any
dialer-list 1 protocol ip permit
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 password 7 ****
 login
!
scheduler max-task-time 5000
!
end
0
Comment
Question by:Matthijs_Luijt
  • 2
3 Comments
 
LVL 1

Accepted Solution

by:
jajjones earned 1500 total points
ID: 13985761
Are you trying to set up a VPN tunnel from/to this router ?  There is no config in there for a crypto map, although I aint sure if the IOS you have on the router will work..........
If the IOS is OK and the router can handle it, you need to set up a crypto map and set up a peering etc.  If you could explain what you are trying to do a little further it might help.......
0
 
LVL 1

Expert Comment

by:jajjones
ID: 13985809
0
 

Author Comment

by:Matthijs_Luijt
ID: 14016806
Thanx Jones, it was an old IOS. With the new one it was solved.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you connect to your workplace's VPN, you may not notice that you are using your workplace's servers to serve up webpages.  This might be undesirable since the workplace can log all the places you've been.  It also might be very slow to load pag…
Let’s list some of the technologies that enable smooth teleworking. 
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question