Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Cant mount cdrom drive

Posted on 2005-05-12
11
Medium Priority
?
1,735 Views
Last Modified: 2008-02-01
Hi, I'm using the freeware sme server ver 6.0 and cannot mount the cdrom drive.

This is the fstab entry..

/dev/cdrom   /mnt/cdrom    iso9660 noauto,owner,ro 0 0

but none of the following work

mount /mnt/cdrom  >returns  mount: wrong fs type, bad option, bad super block on /dev/cdrom,
                                                      or to many mounted file systems
                                                       ( could this be the IDE device where you in fact use ide-scsi
                                                       so that sr0 or sda so is needed?)
mount -t iso9660 /dev/cdrom /mnt/cdrom >returns the same error message

dmesg shows that hdd is the cdrom drive but using /dev/hdd instead of /dev/cdrom returns the same error messages.
this is a new install of sme 6.0

doing this as root.

any help appreciated.

B
0
Comment
Question by:BobNZ2
  • 4
  • 3
  • 2
  • +2
11 Comments
 
LVL 1

Expert Comment

by:redzkull
ID: 13992128
Hi,
I don't think you have to specify the fs type, try 'auto' instead.
Also you should try to mount /dev/hdd instead of /dev/cdrom or make a symlink of hdd pointing to cdrom.

here's a sample of my cdrom mount on /etc/fstab
/dev/hda   /media/cdrecorder    auto  pamconsole,exec,noauto,managed 0 0

hope this helps.
good luck.

redzkull

0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 13992246
> could this be the IDE device where you in fact use ide-scsi
1. Check the /etc/grub.conf for
kernel ........ hdd=ide-scsi ....
take it out and reboot.

Please also post
ls -al /dev/cdrom
cat /proc/ide/hdd/model
dmesg | grep -i hd
fdisk -l
0
 

Author Comment

by:BobNZ2
ID: 13992533
redzkull: thanks but that didn't do it.

wesly_chen: thanks, had already tried  

> could this be the IDE device where you in fact use ide-scsi
1. Check the /etc/grub.conf for
kernel ........ hdd=ide-scsi ....
take it out and reboot

without success :(

ls -al /dev/cdrom >returns   lrwxrwxrwx 1  root  root   8 may 13 20: 40 /dev/cdrom -> /devhdd

cat /proc/ide/hdd/model  >returns   CD-RW IDE5232

dmesg |grep -i hd

there is a lot of output from this commend to much for me to type all but here is  some

kernel command line still has hdd=ide-scsi at the end of it even though this has been removed from grub.conf I have checked that.

hdd: CD-RW IDE5232, ATAPI CD/DVD-ROM drive
hdd: attached ide-scsi driver
hdd: dma disabled

ide-scsi: hdd: unsupported command in request queue (0)
end_request: I/O error, dev 16:40 (hdd), sector 0

there are 6 of these  each for a different sector ( 0,2,4,6,0,64)

fdisk -l >returns  

/dev/hda1   *  1     13    104391          83 linux
/dev/hda2      14     46    265072*       82 linux swap
/dev/hda3      47    9729  77778697*   83 linux

B
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 38

Expert Comment

by:wesly_chen
ID: 13993477
> cat /proc/ide/hdd/model  >returns   CD-RW IDE5232
It's CD-RW, edit /etc/fstab
/dev/cdrom   /mnt/cdrom    udf,iso9660 noauto,owner,ro 0 0
Then as root,
mount /mnt/cdrom
0
 

Author Comment

by:BobNZ2
ID: 13993646
Wesley_chen: Thanks for the reply. Did as you suggested but the same results...

wrong fs type, bad option, bad super block on /dev/cdrom,
  or to many mounted file systems
 ( could this be the IDE device where you in fact use ide-scsi
  so that sr0 or sda so is needed?)

B
0
 
LVL 38

Expert Comment

by:wesly_chen
ID: 13993676
> kernel command line still has hdd=ide-scsi at the end of it even though this has been removed from grub.conf
That's odd.
Check /boot/grub/grub.conf or /boot/grub/menu.lst  and make sure there is no "hdd=ide-scsi".
Or do you use LILO boot loader?
check /etc/lilo.conf.
0
 
LVL 2

Accepted Solution

by:
Shan_rocks earned 1600 total points
ID: 13993719
Hi Bob,

Try using any of the below and see whether you can fix it.

1. Did you set the CDROM back to the Master? Sometimes - when an IDE drive is the only device on a bus - it doesn't even want to be jumpered as Master - so I remove the jumper all together (or jumper it across the top pins of
master & slave).

2. Are you sure the cdrom modules are loading? lsmod results.(check cdrom)

3. How about "tail -f /var/log/messages" while you try to mount the drive?  Is the drive using SCSI emulation?  
    Maybe it's /dev/scd0 or 1?

4. If the drive using scsi, you need to use /dev/sr0 for the cdrom drive not /dev/hdc.
    so try:
    mount -t iso9660 /dev/sr0 /mnt/cdrom

Regards
Shan
0
 

Author Comment

by:BobNZ2
ID: 13993801
Shan_rocks: hi thanks for the reply.

lsmod  >results   ide-cd                 32256       0
                         scsi_mod             107596     1       [ide-scsi]
                         ide-scsi               11000       0
                       
"If the drive using scsi, you need to use /dev/sr0 for the cdrom drive not /dev/hdc.
    so try:
    mount -t iso9660 /dev/sr0 /mnt/cdrom"
returns same error messages

"Maybe it's /dev/scd0 or 1?"
success!!!! tried mount  /dev/scd0 /mnt/cdrom and no error messages; navigated to cdrom and there where the files on cd. :)

thanks again Shan_rocks

would like to give wesley 100 points for effort that ok?

B

0
 

Expert Comment

by:dk_yadav
ID: 13993883
Hi,

    i think your kernel does not have support for  iso9660 filesystem.  Pls  check if you there any module in /lib/modules/<version of your kernel/fs/ corresponding to iso9660 filesystem. If it is present there than load it using modprobe command. Otherwise you may have to recompile your kernel.

Dinesh


0
 
LVL 2

Expert Comment

by:Shan_rocks
ID: 13995668
Hi Bob,

You can give wesley 100 points for his effort, no problem. He has contributed much to your issue.

Regards
Shan
0
 
LVL 38

Assisted Solution

by:wesly_chen
wesly_chen earned 400 total points
ID: 13997915
I see no SCSI disk nor SATA disk in his system (from the output of "fdisk -l").
But the dmesg show up "hdd=ide-scsi" which is odd and unecessary.
So I would say check the other files
/boot/grub/grub.conf , /boot/grub/menu.lst   for GRUB boot loader and
/etc/lilo.conf   for LILO boot loader.

SME server is the rebuilt version of RedHat 7.x. It has the same setting of RedHat Linux.

Anyway, I'm glad that the issue resolved.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension . This reminded me of questions that come up here at EE along the lines of, "How can I tell the type of file from its cont…
In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Suggested Courses
Course of the Month15 days, 13 hours left to enroll

580 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question