User Log in script in group policy not working

Posted on 2005-05-13
Last Modified: 2010-04-19
I am attempting to use a user log on script in group policy.

 Under User configuration - Windows settings - scripts - log on

I am trying to add some printers. However to test the working I have just added a simple .bat file. I have tried this with no more than an echo and text line in the batch file in order to see it on the screen, followed by a pause. I am not seeing it at all. I have been on the Microsoft site and checked all the requirements and to my knowledge I have set it correctly but to no avail. My client computer is Windowx XP and it is connected to my domain. The user is a domain user.
Help would be very much appreciated as I need to get a VBS script working to connect a complicated set of printer options at the computer level.
Question by:davidatgemini
    LVL 18

    Expert Comment

    Are you applying the policy at the domain level? ou level?

    If it is to an OU, make sure of course that the user objects are in the OU.  

    Where are you storing your script at?

    Make sure the policy is actually being applied to the workstations. From a command line on your client, you can run a gpresult.exe

    This will show you what policies are and are not being applied.

    For a little bit more information you can do a start - run- rsop.msc and that will show you all the individual settings which are being applied.
    LVL 4

    Accepted Solution

    Did you set the path to the batch file as UNC path?

    So when adding a batch file to GPO, you must take care that the file is run as:


    and not as


    Propably you have the batch file on the server, so when selecting the file dont browse for it locally (C:\WINDOWS\....) but through network (\\MyServer01\MyFileShare\batches\...)

    When users log to workstations they will run the batch from the server, not locally.


    Author Comment

    Thank you for the swift repsonse.

     Policy is at OU level, although I have tried at domain level.

    To narrow this down I have created an OU of printtest. It has a user and a computer in it.
    User and computer configuration settings are not disabled.

    Script stored:-


    In GPresult.exe. It appears it is being run. Suspecting it is just not echoing batch files

    In the  UK Weekend is here

    Will continue Monday and update.

    Have a nice weekend.



    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Why You Should Analyze Threat Actor TTPs

    After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

    I've always wanted to allow a user to have a printer no matter where they login. The steps below will show you how to achieve just that. In this Article I'll show how to deploy printers automatically with group policy and then using security fil…
    Learn about cloud computing and its benefits for small business owners.
    Internet Business Fax to Email Made Easy - With eFax Corporate (, you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
    This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor ( If you're looking for how to monitor bandwidth using netflow or packet s…

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    14 Experts available now in Live!

    Get 1:1 Help Now