[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

PIX 501 - Can't VPN Outbound

Posted on 2005-05-13
2
Medium Priority
?
383 Views
Last Modified: 2013-11-16
I have a PIX 501, PIX A we'll call it, (see config below) and am having problems with a VPN session to a  remote PIX 501 , PIX B we'll call this one, from a VPN client behind PIX A.

VPN client ------> PIX A ------> Internet ------> PIX B

From a third location I can independantly VPN to either PIX A or B via the Cisco VPN Client and access all resources on those networks..  On PIX A's network I can establish the VPN Session to PIX B, but I cannot access any resources on PIX B's network.

Here's my config for PIX A:  (I created this config based on Cisco examples and another working config I have access to.  I'm no very experienced with the PIX OS and would welcome any and all suggestions.)

PIX Version 6.3(1)
interface ethernet0 100full
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password mw0ZSV9DB/0f9A60 encrypted
passwd mw0ZSV9DB/0f9A60 encrypted
hostname Pix
domain-name domain.net
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
no fixup protocol sqlnet 1521
names
access-list 101 permit ip 10.1.1.0 255.255.255.0 10.1.2.0 255.255.255.0
access-list allow-in permit tcp any host x.x.x.x eq https
access-list allow-in permit tcp any host x.x.x.x eq 444
access-list allow-in permit icmp any any echo-reply
access-list allow-in permit icmp any any time-exceeded
access-list allow-in permit icmp any any unreachable
access-list allow-in permit icmp any any source-quench
access-list allow-in permit tcp any host x.x.x.x eq smtp
access-list allow-in permit tcp any host x.x.x.x eq pop3
pager lines 24
icmp permit any echo-reply outside
icmp permit any echo inside
mtu outside 1500
mtu inside 1500
ip address outside x.x.x.x 255.255.255.0
ip address inside 10.1.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 10.1.2.1-10.1.2.254
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface 444 10.1.1.100 444 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface https 10.1.1.100 https netmask 255.255.255.255 0 0
static (inside,outside) tcp interface smtp 10.1.1.100 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface pop3 10.1.1.100 pop3 netmask 255.255.255.255 0 0
access-group allow-in in interface outside
route outside 0.0.0.0 0.0.0.0 12.221.229.1 1
route inside 10.17.1.0 255.255.255.255 10.1.1.2 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
ntp server 10.1.1.100 source inside prefer
ntp server 130.126.24.53 source outside
http server enable
http 10.1.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap interface outside
isakmp enable outside
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup vpn3000 address-pool ippool
vpngroup vpn3000 dns-server 10.1.1.100
vpngroup vpn3000 wins-server 10.1.1.100
vpngroup vpn3000 default-domain domain.net
vpngroup vpn3000 split-tunnel 101
vpngroup vpn3000 idle-time 1800
vpngroup vpn3000 password ********
telnet 10.1.1.0 255.255.255.0 inside
telnet timeout 10
ssh timeout 5
console timeout 0
terminal width 80

Regards,

Jamie
0
Comment
Question by:jamie177
2 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 2000 total points
ID: 13999599
Jamie,
Make sure all pix's have this command added:

 isakmp nat-traversal 20

0
 

Author Comment

by:jamie177
ID: 14000858
Excellent!  Worked like a champ!!!  Thanks for you help lrmoore.

Regards,

Jamie
0

Featured Post

Threat Trends for MSPs to Watch

See the findings.
Despite its humble beginnings, phishing has come a long way since those first crudely constructed emails. Today, phishing sites can appear and disappear in the length of a coffee break, and it takes more than a little know-how to keep your clients secure.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This past year has been one of great growth and performance for OnPage. We have added many features and integrations to the product, making 2016 an awesome year. We see these steps forward as the basis for future growth.
There’s a movement in Information Technology (IT), and while it’s hard to define, it is gaining momentum. Some call it “stream-lined IT;” others call it “thin-model IT.”
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Suggested Courses
Course of the Month17 days, 14 hours left to enroll

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question