• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1488
  • Last Modified:

"This is the protected text area of the form" Message

Experts,

As I continue to learn how to develop, I am using books and tutorials some from the Redbook site.  I came across a tutorial which I am building and am puzzled on a message that is appearing when I open the example database on my laptop only, and it does not appear on my desktop.

The message is:
"This is the protected text area of the form"
which sits in between the top frame and the lower frame in a 3 frame design.

I also opened this file on someone else's Laptop and they get the same message, but on the desktop it does not appear.

Anyone have ideas of why this message is appearing and how to get rid of it?  We are on Notes 6, and I'd like to use the tutorial to build a similar portal database, but the users will be primarily laptop users.

I hope someone can figure this out!!  I'd like to show someone this demo db next week, but dont' want this message appearing.

Thanks in advance.

-AliciaVee

Example Database
ftp://www.redbooks.ibm.com/redbooks/REDP0019/

RedBook:
http://publib-b.boulder.ibm.com/abstracts/redp0019.html?Open
0
AliciaVee
Asked:
AliciaVee
  • 4
  • 4
1 Solution
 
Sjef BosmanGroupware ConsultantCommented:
It does ring a (distant) bell, but you might get some clues here:

http://www-10.lotus.com/ldd/nd6forum.nsf/0/efe259350975e6cb85256c500046408b?OpenDocument
0
 
AliciaVeeAuthor Commented:
sjef,

Okay, in reading the post, I can see how this message can be turned off, by disabling field help on the user's pc, but I don't think that is an ideal solution.  the posts doesn't mention anything about how to get rid of the message or, how to workaround it.  The sample database doesn't 'really' have roles set up.  I wonder if setting document security, would alleviate it to some extent.  So, if the document the user is viewing, is not editable for them, do you think they will still see this message?  If you opened the database, you will see that for all the home pages of each deparment, the message appers on the top part of the form.  If most users were 'readers' of the db, and not able to edit or create, do you think the message will go away?  (I can deal with the admins of each department who might be responsible for creating pages, to see the message).

I think this is very wierd to have that message appear as a default by IBM when no field help is displayed.
0
 
Sjef BosmanGroupware ConsultantCommented:
You're not the only one feeling that way. When you search with Google, you get  many links to questions asking for this message to be removed. Seems quite harmless, though. I'm sorry to say that I don't have the solution for you.

I somehow seem to remember that the message had something to do with protected sections. Are they used in that demo application??
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
AliciaVeeAuthor Commented:
sjef,

Yeah, I hear you on that one -- maybe someday IBM will listen.

No, I do not believe the section is protected?  Maybe you can look at the sample db and see if I'm wrong or a way to work around it?  I tried going into each field on the 'pages' form which is what loads in the main right frame, and just typed blanks -- thinking maybe if there was something there -- it would trick the default message from not appearing, but that didn't work.
0
 
AliciaVeeAuthor Commented:
sjef,

Is there a way to disable display of field help with an @command -- since it is located on the menu?  So, then maybe for this particular database, the only option is to deselect the VIEW / SHOW / FIELD HELP in the menu bar?  How can I do that on open of the database?

Anyone else have any workarounds?  Upping points for quicker resolution (if possible)

AliciaVee
0
 
Sjef BosmanGroupware ConsultantCommented:
Pray don't rush things. It's weekend in Europe (Whit Monday), and lots of people had a 2 weeks holiday.

There is
    @Command([ViewShowFieldHelp])
that works as a toggle on/off. It's LS equivalent is
    NotesUIDocument.FieldHelp
a property that you can set to True/False.

Maybe one of them is used explicitly in the application? I didn't download it (yet), too busy with some repairs to our house. Will do though...
0
 
Sjef BosmanGroupware ConsultantCommented:
I downloaded the database. I think it isn't meant to be used in the Notes client, but (only) by a browser. Developers usually don't give a rat's behind about what's happening in a web-only database when used in Notes.

The message comes from the Search form. If you remove the Field Help in both SearchType and SearchText, the "protected text area"-message is history. The Field Help as well... :|
0
 
AliciaVeeAuthor Commented:
sjef,

Awesome!  Thanks so much for figuring this out -- yep, it did work and the message no longer displays.  Yay!

AliciaVee
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now