[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 353
  • Last Modified:

Unable to implement new changes in DNS server- in redhat 8

I am running a DNS server for some time on RedHAt 8. There
was no issue for more then 400days now. Recently, I made some changes to one of the zone files.

Since then I am not able to restart the named service correctly. Hence the
new changes cannot be reflected.

I get the error :-

   [root@durga etc]# service named restart
     Stopping named: rndc: connect failed: connection refused
     [FAILED]
     Starting named: [  OK  ]

I have tired to make the /etc/named.conf and /etc/rndc.conf
to 755 with out much success.

Last 40 lines from the the var/log/messages

[root@durga etc]# tail -40 /var/log/messages
May 16 19:51:07 durga named[12384]: zone localhost/IN: loaded serial 1
May 16 19:51:07 durga named[12384]: running
May 16 19:51:08 durga named: named startup succeeded
May 16 19:54:24 durga named[12384]: shutting down: flushing changes
May 16 19:54:24 durga named[12384]: stopping command channel on 127.0.0.1#953
May 16 19:54:24 durga named[12384]: no longer listening on 127.0.0.1#53
May 16 19:54:24 durga named[12384]: no longer listening on 192.1.1.174#53
May 16 19:54:24 durga named[12384]: no longer listening on 192.1.1.165#53
May 16 19:54:24 durga named[12381]: exiting
May 16 19:54:24 durga named[12423]: starting BIND 9.2.1 -u named
May 16 19:54:24 durga named[12423]: using 1 CPU
May 16 19:54:24 durga named[12426]: loading configuration from '/etc/named.conf'
May 16 19:54:24 durga named[12426]: no IPv6 interfaces found
May 16 19:54:24 durga named[12426]: listening on IPv4 interface lo, 127.0.0.1#53
May 16 19:54:24 durga named[12426]: listening on IPv4 interface eth0, 192.1.1.174#53
May 16 19:54:24 durga named[12426]: listening on IPv4 interface eth0:1:0, 192.1.1.165#53
May 16 19:54:24 durga named[12426]: command channel listening on 127.0.0.1#953
May 16 19:54:24 durga named[12426]: zone 0.0.127.in-addr.arpa/IN: loaded serial 1997022700
May 16 19:54:24 durga named[12426]: zone localhost/IN: loaded serial 1
May 16 19:54:24 durga named[12426]: running
May 16 19:54:24 durga named: named startup succeeded
May 16 19:54:38 durga named[12426]: shutting down: flushing changes
May 16 19:54:38 durga named[12426]: stopping command channel on 127.0.0.1#953
May 16 19:54:38 durga named[12426]: no longer listening on 127.0.0.1#53
May 16 19:54:38 durga named[12426]: no longer listening on 192.1.1.174#53
May 16 19:54:38 durga named[12426]: no longer listening on 192.1.1.165#53
May 16 19:54:38 durga named[12423]: exiting
May 16 19:54:44 durga named: named shutdown failed
May 16 19:54:44 durga named[12463]: starting BIND 9.2.1 -u named
May 16 19:54:44 durga named[12463]: using 1 CPU
May 16 19:54:44 durga named[12466]: loading configuration from '/etc/named.conf'
May 16 19:54:44 durga named[12466]: no IPv6 interfaces found
May 16 19:54:44 durga named[12466]: listening on IPv4 interface lo, 127.0.0.1#53
May 16 19:54:44 durga named[12466]: listening on IPv4 interface eth0, 192.1.1.174#53
May 16 19:54:44 durga named[12466]: listening on IPv4 interface eth0:1:0, 192.1.1.165#53
May 16 19:54:44 durga named[12466]: command channel listening on 127.0.0.1#953
May 16 19:54:44 durga named[12466]: zone 0.0.127.in-addr.arpa/IN: loaded serial 1997022700
May 16 19:54:44 durga named[12466]: zone localhost/IN: loaded serial 1
May 16 19:54:44 durga named[12466]: running
May 16 19:54:45 durga named: named startup succeeded

Could any one help me resolve the issue.

Asidu
0
asidu
Asked:
asidu
  • 4
  • 4
2 Solutions
 
DonConsolioCommented:
forgot to increment the serial number in your zone file ?
0
 
asiduAuthor Commented:
Could you elaborate a little more  on your pointer please.
Thank u
0
 
DonConsolioCommented:
sample:

$TTL 86400
@     IN SOA   mxhost.mydomain.net.     admin.mydomain.net.(
          2003060919;     serial <--- increase THIS number every time you change this file
          21600;          refresh every 6 hours
          3600;           retry after one hour
          604800;         expire after a week
          86400 );        minimum TTL of 1 day

                IN      NS      mxhost.mydomain.net.
                IN      MX      10      mxhost.mydomain.net.

mxhost          IN      A       10.0.0.1
...
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
DonConsolioCommented:
1) make changes you want in zone file
2) increase number (must be larger than before changes)
3) reload/resatrt nameserver
4) check syslog for errors and verify that changes are visible
0
 
asiduAuthor Commented:
DonConsolio

I have done the changes increaed serail to 2003041922  from 200304190.
Restart the named service. DNS is still is not responding to changes.

When I use the dig command the old serial number still appears in the output of the command.
My zone file is appended. Cannot get a translastion for  the last CNAME. ( new addition)
The rest working fine.

$TTL    86400
mycom.org.sg.      IN      SOA     ns1.mycom.org.sg.  root.localhost.  (
                                      2003041922 ; Serial
                                      28800       ; Refresh
                                      14400      ; Retry
                                      3600000    ; Expire
                                      86400 )    ; Minimum
              IN      A      10.42.199.166
              IN      NS     ns1.mycom.org.sg.

ns1     IN      A       10.42.199.165
oldguard IN     A       10.42.199.166
durga   IN      A       10.42.199.168
wwwint  IN      A       10.1.1.166
mail    IN      A       10.42.199.166
        IN      MX 10   10.42.199.166
        IN      MX 20   10.42.199.163

www     IN      CNAME   oldguard
internal IN     CNAME   wwwint
int     IN      CNAME   wwwint
test1   IN      CNAME   durga
atma    IN      CNAME   oldguard

Any other thing need to be amended and checked ?
Thanks
Asidu
0
 
idmiskCommented:
are you still getting this

> May 16 19:54:44 durga named[12466]: zone localhost/IN: loaded serial 1

in messages? i am wondering about the serial 200304190 - it is not in your first post.

can you please post /etc/named.conf and the last part of messages after you did the changes to zone file (i propose it is localhost)

-michael
0
 
DonConsolioCommented:
does "/etc/named.conf" REALLY point to YOUR zone file ?
0
 
asiduAuthor Commented:
Thank you Guys,

The problem has been resolved.
One line in the named.conf was missing
include "/etc/named.custom"

I have included the above line into the named.conf  and the problem resolved.
Now able to make changes to the DNS.

/var/log/messages

May 18 13:13:47 durga named[24033]: starting BIND 9.2.1 -u named
May 18 13:13:47 durga named[24033]: using 1 CPU
May 18 13:13:47 durga named[24036]: loading configuration from '/etc/named.conf'
May 18 13:13:47 durga named[24036]: no IPv6 interfaces found
May 18 13:13:47 durga named[24036]: listening on IPv4 interface lo, 127.0.0.1#53
May 18 13:13:47 durga named[24036]: listening on IPv4 interface eth0, 192.1.1.174#53
May 18 13:13:47 durga named[24036]: listening on IPv4 interface eth0:1:0, 192.1.1.165#53
May 18 13:13:47 durga named[24036]: command channel listening on 127.0.0.1#953
May 18 13:13:47 durga named[24036]: zone 0.0.127.in-addr.arpa/IN: loaded serial 1
May 18 13:13:47 durga named[24036]: zone localhost/IN: loaded serial 1
May 18 13:13:47 durga named[24036]: zone premiertravel.org.sg/IN: loaded serial 2003041922
May 18 13:13:47 durga named[24036]: zone sasco.org.sg/IN: loaded serial 2003041922
May 18 13:13:47 durga named: named startup succeeded
May 18 13:13:47 durga named[24036]: zone tcc.org.sg/IN: loaded serial 2003041922
May 18 13:13:47 durga named[24036]: running
May 18 13:13:47 durga named[24036]: zone tcc.org.sg/IN: sending notifies (serial 2003041922)

===============================================
The content of
/etc/named.conf.

[root@durga etc]# more named.conf
// generated by named-bootconf.pl

options {
        directory "/var/named";
        /*
         * If there is a firewall between you and nameservers you want
         * to talk to, you might need to uncomment the query-source
         * directive below.  Previous versions of BIND always asked
         * questions using port 53, but BIND 8.1 uses an unprivileged
         * port by default.
         */
        // query-source address * port 53;
};

//
// a caching only nameserver config
//
controls {
        inet 127.0.0.1 allow { localhost; } keys { rndckey; };
};
zone "." IN {
        type hint;
        file "named.ca";
};

zone "localhost" IN {
        type master;
        file "localhost.zone";
        allow-update { none; };
};

zone "0.0.127.in-addr.arpa" IN {
        type master;
        file "named.local";
        allow-update { none; };
};

include "/etc/rndc.key";
include "/etc/named.custom";  
============================================

Last line has been inserted again.
0
 
asiduAuthor Commented:
Decided to split the points.
Thanks for your time and pointers.
Asidu
0

Featured Post

Transaction-level recovery for Oracle database

Veeam Explore for Oracle delivers low RTOs and RPOs with agentless transaction log backup and transaction-level recovery of Oracle databases. You can restore the database to a precise point in time, even to a specific transaction.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now