• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 761
  • Last Modified:

Remote Desktop for Administration

How do I setup Remote Desktop for Administration on my 2003 server. I have already enabled it under the System Properties, Remote tab and added myself as a user. When I go to my workstation and browse my domain I get the following message:

Domain does not contain any terminal servers.

This is not a WAN... it is a single server LAN.
0
comtekso
Asked:
comtekso
  • 14
  • 11
  • 6
  • +2
3 Solutions
 
sirbountyCommented:
Try Start->Run->MSTSC /Console <Enter>
and input the Name or IP address of the server you are trying to reach...
0
 
sirbountyCommented:
There may also be some additional settings needing adjustment under:
Start->Run->tscc.msc /s <Enter>
0
 
comteksoAuthor Commented:
Nope... entering either the IP addres or the \\servername get the Remote Desktop Diconnected error.

When I refered to browsing the domain above, I meant that Iwas browsing thru the Remote Desktop, Computer name browse option.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
cyberdevil67Commented:
Hi comtekso,

 You'll need to install the terminal services licensing, under the add/remove windows options

Cheers!
0
 
sirbountyCommented:
Did you configure it from the server?
0
 
comteksoAuthor Commented:
When I type "tscc.msc /s" I get an error
0
 
sirbountyCommented:
From the Server?
0
 
comteksoAuthor Commented:
OK so I do need to install Terminal Services for the "Remote Desktop for Administration" to work?  The help file I read for this didn't say anything about having to install it.... just said to enable remote desktop thru system properties.
0
 
comteksoAuthor Commented:
Sirbounty, where should I be entering the run commands? I was trying on my workstation.
0
 
cyberdevil67Commented:
The licensing is needed to say how many can connect to it as far as I know.

The other thing is that if it is a domain then you'll need to enter the username and password and domain to RDC to the server.
0
 
comteksoAuthor Commented:
Ok I have ran tscc.msc /s from my server

Licensing is set to Remote Desktop for Administration What other settings do I need to check?

I have tried entering my username, password, and domain name in... all with the same resaults.
0
 
sirbountyCommented:
No - on the server you want to remote into.
Or, am I confused and you are trying to remote into your workstation?

0
 
itmaximumCommented:
you need to install terminal services on your windows 2003 server
the default is administrative mode which allows 2 simultaneous logins without the need for a license.

http://support.microsoft.com/default.aspx?scid=kb;en-us;306624

once your server has the service installed you can then connect using RDP
and login as administrator or other user that has remote access permissions (usually all users have remote access unless specifically denied)

the method you outlined above...is not the recommended method for setting up administrative remote access to a server specifically, so I would recommend following the KB article I linked.

good luck.

0
 
comteksoAuthor Commented:
I want to access the server from different workstation thru the building so I can do things like add users, check event logs, etc.
0
 
itmaximumCommented:
I just  re-read the original post as well and got a little turned around..

if your remote access FROM your server INTO your workstation, you would setup the access in the control panel -> system-> remote (on the workstation) and enable remote access...

it sounded like you did this on the server... from the post, hence my kb article link...

in the case that you're trying to admin the workstation from the server... you would setup like i mentioned above and just go by IP, make sure your network is setup correctly, as you said this is a small 2 node lan (server and workstation) you should have a small network range and have both systems in the same subnet to get them to talk via IP.

it sounds like your trying to use RDP over NETBEUI/NETBIOS?!?! when it needs to be done over ip (so no go,  on browsing network neighborhood/my network places) to connect via RDP.

you need to setup a static IP on both the server and the workstation within the same subnet (so the two systems can ARP to each other) and then use RDP normally (by connecting via IP address)

ITM
0
 
mikeleebrlaCommented:
if you are trying to set up RDC (called TS remote admin mode in 2000) you do it just like you do on an XP box.  (by rightclicking my computer).  you do NOT need to install TS from add/remove programs. you do NOT need a licensing server for RDC on a 2003 box.  A licensing server is only needed if you are using TS (called TS application mode back in 2000)

the reason you get the "Domain does not contain any terminal servers" is b/c it doesn't contain any terminal servers just like the error says.  It does however have a RDC "server"

it sounds as though rdc isn't "listening" as it should.  to test this run netstat -an and see if port 3389 is listening.

0
 
itmaximumCommented:
qutoe:

 I want to access the server from different workstation thru the building so I can do things like add users, check event logs, etc.

end quote:-----


GREAT follow my first post... and you're good to go.

use this link for step by step

http://support.microsoft.com/default.aspx?scid=kb;en-us;306624

servers are not setup the same as workstations for RDP, at least its not recommended...
so setup terminal server services and wallah .. instant admin login is available from your network workstations using RDP.




0
 
mikeleebrlaCommented:
"I want to access the server from different workstation thru the building so I can do things like add users, check event logs, etc"
 if all you want to do is add users, check even logs etc.. you dont have to RDC into your server at all.

to add users and use ADUC just install adminpak which will install all the "administrative tools" onto your local workstation.
to check event logs just open event viewer and choose connect to another computer.
0
 
sirbountyCommented:
Only thing I'd add to itmaximum's post is that you do not have to have a static IP on the desktop/workstation for this...I run DHCP on all my clients and can access the server over RDP from any of them, even over VPN.

Presumably this is a domain controller?  If so, I strongly caution you to adjust the setting to drop inactive sessions.
I have had a problem in the past with a connected session crashing my Active Directory!

Secondly, are you using the same PC to do this?  Or one of a few "admin" PCs?  You might just as well install the Administrative tools and add users with it...
0
 
mikeleebrlaCommented:
itmaximum
  your post is for windows 2000 which is 100% irrelevant in this case since he is using 2003.  TS changed ALOT from 2000 to 2003 as i mentioned in my above post.

there is no such thing as TS app mode in 2003
there is no such thing as TS remote administation mode in 2003...
0
 
comteksoAuthor Commented:
OK. I checked the netstat -an, port 3389 was listed as Established but it didn't say listening.

Yes the admin pack would do the majority of what I want, but still would prefer to use Remote Destop.

I will install Terminal services if necesary, but it sounds as if I don't need to.
0
 
mikeleebrlaCommented:
if you install TS on a 2003 server then you are actually installing what WAS called TS app mode in 2000 and you will licenses. Since you only need one or 2 connections you can install RDC (called TS remote administration mode in 2000).

that fact that yours says established is your problem. apparently there was a connection that got currupt or hung or whatever you want to call it. But the point is your server thinks there is an active connection (or 2) and thier isn't any.  So to correct this the best thing to do would be to simply restart the server, check netstat -an again and make sure it is listening and then connect.  

if restarting the server isn't an option you can go to start>run and type in services.msc to open the services MMC.  from there stop and start the "terminal services" service.  It might not stop and start cleanly since there is a hung connection however. that is why restarting the whole server would be best.
0
 
comteksoAuthor Commented:
I did another scan with Active Port and the local port 3389 is listed as C:\Prog Files\Exchsrvr\emsmta.exe
0
 
mikeleebrlaCommented:
I'm not familar with active port... is it a port scanner???  if so im confused as what you mean by you say 3389 is listed as C:\Prog Files\Exchsrvr\emsmta.exe.... an open port is just an open port,,, no path is involved anywhere.
0
 
comteksoAuthor Commented:
I checked the Services and all tasks for Terminal services are greyed out, so I can restart. I will have to do a restart possibly at lunch.
0
 
mikeleebrlaCommented:
they are probably grayed out b/c the service is hung like i mentioned earlier, restart the server and keep us posted.
0
 
comteksoAuthor Commented:
Yes Active Prot is a port scanner that shows you all the active ports on that system. It is saying that port 3389 is being used by emsmta.exe which appears to be part of MS Exchange
0
 
mikeleebrlaCommented:
if you used active port to scan a LOCAL machine then that would explain why it gave the path to the exe that opened the port. port scanners are usually used to scan remote machines which is what threw me off.  In any case the fact that this exchange exe has port 3389 is pretty odd.  I found this link that shows where vnc (another remote admin program) wasn't woking b/c emsmta.exe was using port 5800 which is vnc's port.  it's very odd that emsmta.exe is using 3389. in the case with vnc below stopping and starting the exchange services casused emsmta.exe to use another port. hopefully the same will be true for your server and a restart will solve the issue.

http://www.realvnc.com/pipermail/vnc-list/2005-April/050579.html
0
 
itmaximumCommented:
to be technically more appropriate, the link i had was a quick link that was intended to show how Terminal services is installed and that is all, so the relevance exists for that point.

for windows 2003 terminal services manager does NOT have to be running, thats correct however the ease of managemnet it affords in stopping and restarting services should be apparant to anyone who has ever done remote administration, and those same individuals would also see the relevance of using that windows component.

ITM
0
 
itmaximumCommented:
"he ease of managemnet it affords in stopping and restarting services should be apparant to anyone who has ever done remote administration,"


change that to disconnecting an idle session or a "hung" session.. is easy and doesnt require a server reboot.

ITM
0
 
mikeleebrlaCommented:
http://www.windowsnetworking.com/articles_tutorials/Using-Remote-Desktop-Windows-XP-Pro.html

the above link backs up everthing i have said. Again there is NO such thing as TS remote administration mode on a windows 2003 server.  It is now called RDC and you enable it totally different than how you did back in 2000.
0
 
mikeleebrlaCommented:
if you install TS on a 2003 server and dont have any TS licenses you won't be able to do anything at all as far as connecting remotely.  As soon as you attempt to connect it will say "unable to find a TS license server" so if you want to shoot yourself in the foot and have no remote administration capabilites at all, so ahead and install TS.
0
 
comteksoAuthor Commented:
Sorry guys, I haven't been able to restart my server yet. I will post once I am able to one day this week.
0
 
comteksoAuthor Commented:
OK, I got the server restarted last night, however I am still not able to gain access. I checked my active ports and can not find port 3389 listed now.

When trying to connect thru Remote Desktop what information is necessary to connect? I have tried putting in the servers IP address with and without logon and domain info. Also have tried the server name with and without user and doamin info.

I can connect to my workstation from the server using remote desktop.
0
 
mikeleebrlaCommented:
if 3389 isn't listed then the service apparently isn't listening. id run netstat -an on the server just to doublecheck to see if 3389 is listening.  Also check to see that the terminal services service is started in the services MMC. you can access the services mmc by going to start>run services.msc
0
 
comteksoAuthor Commented:
I checked my services... Terminal Services is started... and Terminal Services Session Directory is disabled. And just like the the other day I do not have the option of stopping or restarting the services. Could this be a security setting in Win2003? I am logged in as Admin. This is a fairly new clean install of 2003 and I have not made any changes to any of the security settings.

I also double checked netstat for port 3389 and it is not there.
0
 
mikeleebrlaCommented:
the reason that it is greyed out is b/c another service depends on it more than likely, you can look at the dependency tab to see which one it is.  I dont have a 2003 server where i am today so im testing it on an xp box instead.  The TS service on XP is on all the time even if both remote assistance and RDS is turned off. this is b/c the fast user switching service is dependent on the TS service.  The odd thing is im in a domain so fast user switching can't even be used, just odd.  But in any case, as soon as I enable RDC, port 3389 starts listening.  For some reason something on your 2003 box isn't allowing 3389 to come on.  The fact that you dont get an error message when you enable 3389 is odd.  The only thing i can think of now is to check the event logs and see if they reveal anything as to the cause.
0
 
comteksoAuthor Commented:
OK... got it... I disabled RDC and restarted the server...once server came up then enabled RDC. Now I have port 3389 and I can now connect. Thanks for everyones help.
0

Featured Post

NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

  • 14
  • 11
  • 6
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now