[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1022
  • Last Modified:

Cannot load Windows Update web page - runtime script error

I first thought this was an internet explorer problem not being able to load the windows update page, but I found multiple DLL's for IE that I cannot register and the Automatic Updates service cannot start saying an internal Windows error has occured.

I'm trying to update windows 2000 server on a data storage server.  This server is also running SQL 2000.  Norton Antivirus has found nothing on the server, and I have not found any spyware either.

One topic recommended re-registering the following DLL's
regsvr32 Shdocvw.dll  -  Failed
regsvr32 Oleaut32.dll  -  Failed
regsvr32 Actxprxy.dll   -  Succeeded
regsvr32 Mshtml.dll     -  Failed
regsvr32 Msjava.dll     -  Succeeded
regsvr32 Browseui.dll  -  Failed
regsvr32 Urlmon.dll     -  Succeeded
regsvr32 Shell32.dll     -  Succeeded

I tried reinstalling IE 6.0 with no luck.
I'm out of ideas and don't really want to reload the server - as that would take a day of downtime.
Does anyone have any ideas?

Thanks for your help.
0
JMorsch
Asked:
JMorsch
  • 4
  • 3
1 Solution
 
JMorschAuthor Commented:
One more thing is when opening any explorer window it gives me a similar runtime error and sometimes will not load.  For example, when opening windows explorer the main system folder "winnt\system32" would come up with an error and show nothing in it, just like the windows update page in IE.  

This also happens when you try to go to uninstall programs.  So there is no list of programs to uninstall, it won't load.
0
 
JMorschAuthor Commented:
The only recent addition in programs was outlook 2003, though this problem appeared a few days/week after.
0
 
spiderfixCommented:
Check settings on
Folder Options...
File Types(tab)
N/A URL:Hypertext Transfer Protocol

http://www.oehelp.com/ielnk.aspx
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
JMorschAuthor Commented:
All the settings were correct.
and the regsvr32 Urlmon.dll like the article mentioned i had tried before and it does succeed, but with no effect.  The other DLL's still fail to register.
0
 
spiderfixCommented:
Have you tried booting to "Safe Mode with Networking" and trying Windows Update from there?
0
 
JMorschAuthor Commented:
I have not,
It is not easy to take the server down and i've been avoiding it being that the services it provides are still operating properly.
Though I'm realizing this is not an easy fix so I may have to take it down.  
I'm not sure safe mode would cure anything, being that windows doesn't like those dll files, though I agree it is worth a shot.  I'm going to attempt it at lunch maybe.  
0
 
spiderfixCommented:
A Safe Mode test would verify that nothing third party is involved.

If you still have probs in Safe Mode then the libraries are most likely corrupted. You could try
expanding libraries from the CD to the System32\dllcache folder. I would attempt expanding
one library and if it didn't register after a reboot then you probably looking at an over-top install.
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now