• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 12625
  • Last Modified:

DCOM eventid 10016

The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
{BA126AD1-2166-11D1-B1D0-00805FC1270E}
 to the user NT AUTHORITY\NETWORK SERVICE SID (S-1-5-20).  This security permission can be modified using the Component Services administrative tool.
------------------

I get this DCOM error 8-12 times per day, and I have been unsuccessful in finding a working remedy.

it started after an update to service pack1 on my windows 2003 server(s)
my server(s) are a clustered pair, I have made the exact same updates to both servers.

The CLSID represents the "network connection manager"
I have read that this pertains to Netman as far as a DCOM object goes, (not sure tho)
I have made modification to the Netman object on both servers in the following manner...
1) set permissions to "use default"
2) ensured that remote launch and remote activation are enabled

the error still increments...

I also found one wierd anomaly, the dates event viewer entries on one of the servers is incorrect
it reads 4-19-2005 while the system time/date reads 5-16-2005

however in a clustered the event viewer of both systems always have identical entries, so checking the second system, they entries match up for each 24 hour periord (cleared all entries last firday)
just the dates are wrong (time is correct) on the primary server, (the secondary server the entries have the correct date) VERY WIERD!



0
itmaximum
Asked:
itmaximum
  • 6
  • 5
  • 3
  • +2
1 Solution
 
coderlenCommented:
The following link has the solution. Apparently others have had this exact same problem:

http://www.gotdotnet.com/Community/MessageBoard/Thread.aspx?id=288398
0
 
itmaximumAuthor Commented:
Thanks for the link codelen

unfortunately it doesnt do that much for me, I haev read that thread already,
I did not create any com+ objects, the clsid that is giving me the issue is for an object that does NOT exist in the dcom listing.  netman has a different CLSID then the one listed in the error, which is probably why making changes to the permissions did not effect anything.
generally speaking I need to figure out which DCOM app is tied to the clsid involved (network connection manager) and then correct the permissions on that object, normally that all pointed to netman, but since all the changes have been made, without effect... I have to think i need to look elsewhere.

0
 
coderlenCommented:
Sorry the link didn't help. I'm out of ideas myself.

I would suggest that you create some pointer questions. Here's an EE link explaining pointer questions:

http://www.experts-exchange.com/help.jsp#hi262

Just to increase your exposure within EE, I would suggest the following 2 topic areas, so that you get a good mix of people looking at your problem:

Networking>WinNT Net
Security>Windows Security

This should hopefully bring in enough people who really know networking well. They should be able to help you solve the problem, I would think. Without the pointer questions, you may not get enough responses to be of help.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
itmaximumAuthor Commented:
Still having the same issue, at a loss, I am increasing the point value.
0
 
coderlenCommented:
Try these steps. I found this on the Internet, in German, so I had to translate it into English, and edit it for clarity. I think it will solve your problem, because the person who posted this also had a problem after upgrading Windows 2003 to Service Pack 1.

Problem:After bringing in Service Pack 1 for Windows 2003 the following error appears in the event log:

Type of event: Error
Source of event: DCOM
Event category: None
Event identification: 10016
Date: (Date)
Time: (Time)
User: NT authority network service
Computer: Server name
Description:The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID {BA126AD1-2166-11D1-B1D0-00805FC1270E} to the user NT AUTHORITY\NETWORK SERVICE SID (S-1-5-20). This security permission can be modified using the Component Services administrative tool.

Solution:This can be repaired with following steps:

In order to find out which COM application caused the error you must look in the Registry. In the above case this is the key:

HKEY_CLASSES_ROOT\CLSID\{BA126AD1-2166-11D1-B1D0-00805FC1270E}

Here there is a value AppID - in this case it is {27AF75ED-20D9-11D1-B1CE-00805FC1270E}

Continuing the search in the Registry tree, you navigate to this key:

HKEY_CLASSES_ROOT\AppID\{27AF75ED-20D9-11D1-B1CE-00805FC1270E}

There the name of the local service concerned is found. It is probably Netman.

Now in order to give this service the necessary rights again, you proceed as follows:

- Use the administration tool for component services: start/settings/control panel/administrative tools/component services
- Under component services, expand Computers, expand My Computer, expand DCOM configuration, right-click Netman and select properties.
- Select the security tab
- Now grant the necessary rights to the user specified in the error message (NT authority/NETWORK SERVICE) Perhaps just click “Use default” on all permissions listed here.
- Finished

Let me know if this works. I don't have a Windows 2003 setup, just Windows XP. So, the navigation might be slightly different in places. I think you'll get enough of an idea to navigate correctly. Good luck.

0
 
valiconCommented:
I habe the exact same issue and I have tried every thing and I cannot resolve this.  This too is a by product of installing SP1 on 2003.
0
 
valiconCommented:
Okay I resolved it.  What I did was to add the Network Service to the security tab and then I granted that user local activation rights and it stopped generating the DCOM error.
0
 
coderlenCommented:
valicon, did my suggestion help you? Just curious, because itmaximum would probably like to know that, so he or she can resolve it, too. Thanks.
0
 
valiconCommented:
Actually I did not read the whole thread thoroughly, but what I did was to add the user, in my case Network Service and grant it local activation rights. It is essentially what you have suggested, although I didn't need to use the default setting. :)
0
 
coderlenCommented:
valicon, thanks for the response. That proves that this solution does work. I don't have Win 2003 Server, so it's good to get some real results from the actual environment.

Now, if we can just get itmaximum to respond...

Thanks.
0
 
itmaximumAuthor Commented:
you were on the money Val, I had to do it to both servers in the cluster but it worked... now I get Kerebos event ID4 messages.. hopefully the network service account addition didnt cause it but... its still makes me happy not to see the DCOM.

My thanks to everyone for the help.
0
 
itmaximumAuthor Commented:
Darn ... I hit accept on Vals anwer instead of Cords... how do i get that remedied?

I really appreciate all the help guys... I will work on getting the points moved over
0
 
itmaximumAuthor Commented:
Cordelen,

I sent an email to customer support in order to get your answer accepted and award you the points, (THANK YOU) since I think i did not direct my appreciation to you directly :)

The wording on Valicons post, threw me off, (and I was a bit distracted) the way I read it was
Valicon said

"Okay I resolved it.  What I did was to add the Network Service to the security tab and then I granted that user local activation rights and it stopped generating the DCOM error"

and I just went with that instead of reading the post right above it, belonging to Cordelen, that actually gave the solution :)

so you knocked out two birds Cord, and hopefully I can get the points to you.

ITM
0
 
coderlenCommented:
No problem, itmaximum, just so you got your problem resolved. We all like points, but in reality it's just a big game to us experts. It was fun coming up with the answer, and it gives me great pleasure that it worked for you.

And valicon's input is much appreciated, because he was the one who found that the solution got rid of the DCOM messages. Thanks for that input, valicon.
0
 
petegibCommented:
coderlen accepted answer was only half of the solution, i was still getting the errors with 2003 server, there was two places i needed to add NETWORK SERVICE into and add launch permissions in Dcom config. One was OSearch and the other was SPSearch, once NETWORK SERVICE was added in the errors stopped and some sharepoint 7076, 7888, 6481, 6398 errors i was getting also disappeared
0
 
nerdofreakCommented:
Here is a step by step on how to resolve this problem from Microsoft:
http://support.microsoft.com/kb/931355/en-us
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

  • 6
  • 5
  • 3
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now