?
Solved

sql5035N the database requires migration to current release

Posted on 2005-05-16
14
Medium Priority
?
1,887 Views
Last Modified: 2008-02-20
hi,

we have DB2 UDB v8.1 with spatial extender v8.1 enabled on it. it was running pretty stable. recently we hit max-lock error, so we updated the parameter to higher value (from 22 to 50) and restarted the instance and the machine.

after restarting the machine, we are hitting the following error.
sql5035N the database requires migration to current release. if happened during restore, drop existing database.

we dont want to migrate(?). i can't access data. how do i get out of this.
any clues are greatly appreciated.

madhuri
0
Comment
Question by:madhuri_R
  • 7
  • 4
  • 3
14 Comments
 
LVL 7

Expert Comment

by:db2inst1
ID: 14015670

Did you install any fixpak lately?
0
 

Author Comment

by:madhuri_R
ID: 14015960
no, we havent
0
 

Author Comment

by:madhuri_R
ID: 14016009
well, its been more than 5 months we updated fixpak. but we restarted machine and database multiple times after that.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
LVL 7

Expert Comment

by:db2inst1
ID: 14016094

Might be a stupid question!!

But where you using those databases, after installing the fixpak? Atleast did you connect to the database.

Also give you version information and the fixpak you installed. You might have migrate the db depending on that.

0
 
LVL 13

Expert Comment

by:ghp7000
ID: 14018487
please detail what procedure you followed in response to this question:
http://www.experts-exchange.com/Databases/IBM_UDB/Q_21049877.html

did you install fixpack on old machine before backing up the db?
if so, what level/fixpack did you install on old machine?
what is the current level of your new machine, run db2level from db2 command prompt
0
 

Author Comment

by:madhuri_R
ID: 14021325

db2insti, yes client applications connect to database all this time and query data. we did connect yesterday manually to update max locks parameter.

when i run db2level i got:

DB21085I  Instance "DB2" uses "32" bits and DB2 code release "SQL08015" with
level identifier "02060106".
Informational tokens are "DB2 v8.1.5.449", "s040212", "WR21334", and FixPak
"5".

ghp7000,  yes i did install fixpack on old machine before backing up the db.
fix pack level 5. i have the old machine still available (but off the network). i ran db2level on both old and new machines, the  output is exactly same. as pasted above.

there are 2 other databases running in the db2 instance which doesnt have the this problem. i dont understand the migration error. i have a backup.
0
 

Author Comment

by:madhuri_R
ID: 14022028
to make matters worse, it does not allow to restore the database and not letting to access data. pls help.
there is no migration involved. i dont know why db2 is giving this error.
0
 
LVL 13

Expert Comment

by:ghp7000
ID: 14022895
If you upgraded your db2 software on the old machine from v7 to v8 and then did not properly migrate the databases on the old machine, that may be the source of your problem. When going from v7 to v8, you have to migrate the databases AND also migrate the instance.
On the other hand, if you installed V8 on the old machine from scratch, then created the database, then backed up that database, you indeed have a problem which I think you will need the intervention of IBM support to resolve. I have checked IBM Apar listings and there is nothing there which is similar to your problem, so I think it must relate to the manner in which you handled the upgrade from V7 to V8, although correct me if I am wrong.

To fix your problem, have you tried stopping the instance?
Another thing you can do is to use your backup to restore the database on your new machine to a NEW DATABASE NAME, that should work. However, you will probably find that you cannot drop the old database, nor can you migrate the exisiting problem database.

0
 

Author Comment

by:madhuri_R
ID: 14023632
i installed v8 on the old machine from the scratch and built the database on it.

i tried stopping and starting instance, no change:-(

if i create a new database from the backup existing problem database, is there a way to retain the name(same as existing problem database) to the new database
all my client applications use this name in their code.
0
 
LVL 13

Expert Comment

by:ghp7000
ID: 14027426
hmmm, very tough problem you have. Have you tried looking in the db2diag.log file for additional clues as to what is wrong?
If you built the db from a newly installed v8, then I would think that the message you are getting is wrong, I mean db2 is returning sql5035 in error.
Have you tried resetting your maxlock parameter to the orginal value? (you may get same error message if you try and do this)
Have you verified your spatial extender installation? see:
http://publib.boulder.ibm.com/infocenter/db2help/topic/com.ibm.db2.udb.doc/opt/tsbp2004.htm

In answer to your last post:
first, make sure you can restore your backup into a new database name:
db2 restore database <db name> into <new db name>
if the restore succeeds, connect to the database, make sure it works.
second, change your maxlock parameter as before, reconnect to the db, make sure it works

Please post the result,if it works,  I will show you how to retain the old db name while using a new db name.
Do not drop the existing bad database until later.






0
 

Author Comment

by:madhuri_R
ID: 14033360
hi ghp7000,

db2diag.log is not of much help. there is nothing about migration error or max lock param.

reset maxlocks parameter back to orginal value. still providing the same error after restart.

Passed "verifying spatial extender installation" with flying colors.

while trying restoring to new database from the backup of existing problem database using
db2=> restore database <old db> from c:\backup into <newdb>  
i am getting error:
The container is already in use sqlstate=42730
Extremely bad day.

0
 
LVL 7

Assisted Solution

by:db2inst1
db2inst1 earned 600 total points
ID: 14034369

Regarding your extender. See if there is any new version available. I am not sure about spatial extender, but for Netsearch Extender i had a situation where i need to upgrade it after installing the fixpak for DB2.

For restore:
The error means you are trying to use the file/folder which have already been set as container.

may be u should try doing a redirected restore.

HTH
0
 
LVL 13

Accepted Solution

by:
ghp7000 earned 1400 total points
ID: 14036912
db2inst1 has  good suggestion, make sure you are using the latest version of the extender.
For the restore, yes, do a re directed restore, or make sure you are not restoring into an existing database name.
I think you may be getting this error because spatial extender uses the same tablespace for its catalog tables as those used by the database that is giving you a problem. Try restoring onto another drive if available, remember you are just trying to see if you can duplicate the same problem.
If you are really stuck, you can try dropping the instance, re create a new instance, re catalog the db's and nodes as necessary. If you decide to drop the instance, make sure you save the instance parameters before doing so:
db2 get dbm cfg > save into file.txt
This will make setting up the new instance a lot easier.
0
 

Author Comment

by:madhuri_R
ID: 14071411
spatial extender has a latest version. however it is not stable. i could not again enable the spatial feature for database after disabling it for testing purposes. suprisingly db2diag.log reports no errors. anyway, planning to reinstall both the database and spatial extender from scratch. and populate it with data i will get from backup of existing problem database. hopefully everything works.
ghp7000, db2inst1 thanks for helping me to troubleshoot.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Recursive SQL in UDB/LUW (you can use 'recursive' and 'SQL' in the same sentence) A growing number of database queries lend themselves to recursive solutions.  It's not always easy to spot when recursion is called for, especially for people una…
Recursive SQL in UDB/LUW (it really isn't that hard to do) Recursive SQL is most often used to convert columns to rows or rows to columns.  A previous article described the process of converting rows to columns.  This article will build off of th…
This video shows how to quickly and easily deploy an email signature for all users in Office 365 and prevent it from being added to replies and forwards. (the resulting signature is applied on the server level in Exchange Online) The email signat…
Integration Management Part 2
Suggested Courses

621 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question