cannot map drive in XP PRo to Samba on SuSe enterprise server 9

Posted on 2005-05-16
Last Modified: 2010-03-18
I have setup Samba on Suse 9.0, bought a new server with Enterprise server and am trying again.  In XP, Samba 3.0.4-SUSE shows for BDKHost (server name).  I created a share using the Suse Control center for /u.  I named the share u
browseable = yes
guest ok = false
path = /u
public = yes
writeable =yes

I added the public property.

The workgroup is Urat.

When i try to map the network drive, i can see BDKHost under Urat, but nothing under BDKHost.  If I type "\\BDKHost\u and enter the root user and password then it attempts to connect but fails with "Tne network path \\BDKHost\u could not be found.

Question by:sdpbdk

    Author Comment

    This is my first qestion.  I don't understand the points thing.  Please let me know if i have included enough information
    LVL 38

    Expert Comment

    1. Check the smbd is running or not.
    /etc/init.d/smb status
    If not, then start it
    /etc/init.d/smb start

    2. Make sure /u is readable.
    chmod 755 /u
    chmod -R 744 /u/*

    If still not working, then temporarily edit /etc/samba/smb.conf  (or /etc/smb.conf)
    and change to
    security = share
    in the global section then restart the smbd
    /etc/init.d/smb restart
    LVL 6

    Expert Comment

    you did remember to create a samba user???

    # smbpasswd --help
    smbpasswd: invalid option -- -
    When run by root:
        smbpasswd [options] [username]
        smbpasswd [options]

      -L                   local mode (must be first option)
      -h                   print this usage message
      -s                   use stdin for password prompt
      -c smb.conf file     Use the given path to the smb.conf file
      -D LEVEL             debug level
      -r MACHINE           remote machine
      -U USER              remote username
    extra options when run by root or in local mode:
      -a                   add user
      -d                   disable user
      -e                   enable user
      -i                   interdomain trust account
      -m                   machine trust account
      -n                   set no password
      -w PASSWORD          ldap admin password
      -x                   delete user
      -R ORDER             name resolve order

    smbpasswd -a username

    or link into active directory using LDAP
    LVL 19

    Expert Comment

    you told it:

    guest ok = false

    you force a user to be authenticated before he/she can access to the share.

    then the comment about create the user in samba is right.

    you didn't included the general part of your smb.conf, so I do not know if your server is acting as a domain, user, or share. it would be good to know.

    To have a user autenticated, you must:
    1. add a system user to your linux.  (I use adduser)
    2. add it to the samba database (smbpasswd -a USERNAME)

    To give rights to the user to access /u, you must do
    chown -R USERNAME /u

    because if the user is not owner of the directory, then he/she will not have rights to access.

    remember that in samba, external user is maped with system user, and follow linux rights system for files/directories access. so if you want a group to be able to access /u then do this:

    1. create all users belonging to the same group (i.e. GROUP)
    2. add them to samba as told
    3. give the group ownership to the directory (chgrp -R GROUP /u )
    4. modify the share in smb.conf

    browseable = yes
    guest ok = false
    path = /u
    public = yes
    writeable =yes
    valid users = @GROUP
    force group = GROUP
    force create mode = 660
    force directory mode = 770

    with that, only users belonging to the group GROUP will be able to access, and if one user write/modify something, file will retain group membership and will still be accessable for group members.

    hope this help

    Author Comment

    I did the 3 steps suggested by wesley and no change.

    I also tried    # smbclient -L localhost -U%   and  # smblient -L BDKHost -U-root%password  and everything looks good.

    From XP, I get Bdkhost is not accessible.  You might not have permission to use this network resource.  Contact ...
    The network path was not found.

    I cannot understand why this was so easy with Suse 9.0 but now with SuSe Enterprise Server it is very difficult.

    from prof666 i did nothing as i do not understand what a samba user is.  Is this an XP user account ?  The user on the XP machine named Scott is Work.  I created a Suse user named work.  Is this an Upper lower issue.  Anyway I tried to create an samba user for work;

    # smbpasswd -a work    this failed
    # smbpasswd -a Work    this also failed

    I tried
    # smbpasswd -a pet010   this succeeded without an error message and I created with no password

    to be sure i did

    # smbpasswd -n pet010

    I then tried to map the network drive X: to \\BDKHost\u  using a different user name (pet010) and this failed.

    So, ... is a samba user an XP user (Work), or a Suse user (pet010, or root) ?

    Ok, I figured it out.  Services for ports 137 and 139 seemed to be active.  I tried the firewall, entering to see if that were the problem,
    still failed.  So, I disabled the firewall, and it works.  

    Now I know why it was easy with Suse 9.0   ...   the firewall

    Now, how do I close this question, understand points, and thanks for the help...


    LVL 38

    Expert Comment

    > Now I know why it was easy with Suse 9.0   ...   the firewall
    Well, enterprise version will enable firewall by default for security concern.
    Glad to hear you resolvee your issue by your own.
    You can ask for refund

    Author Comment

    I would like a refund
    LVL 1

    Accepted Solution

    PAQed with points refunded (250)

    Community Support Moderator

    Featured Post

    Highfive + Dolby Voice = No More Audio Complaints!

    Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

    Join & Write a Comment

    Suggested Solutions

    Title # Comments Views Activity
    Replication of Nagios surveilance data 2 87
    E-mail settings for Fail2ban 7 88
    Lame BIND 9.3 10 47
    linux, squid server 23 42
    I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
    Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
    It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
    Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

    731 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    19 Experts available now in Live!

    Get 1:1 Help Now