• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1305
  • Last Modified:

Can't telnet to Solaris BOX ???

Hi Epxerts,

I having a problem in telnet to a Solaris V240 server.

inetd.conf file is ok
telnet service is running
I can ping to the server using  client (Windows) but the server can’t ping to the same client. (client dose not have eny firewall)
The both the machines are in the same network with same subnet mask.

Please Refer : http://www.experts-exchange.com/Operating_Systems/Solaris/Q_21423125.html#14010999

Thanks !
0
Affno
Asked:
Affno
  • 6
  • 6
2 Solutions
 
yuzhCommented:
It might be a DNS problem, check your Sun box (V240):

1. make sure your /etc/resolv.conf file looks like:

nameserver 123.123.20.5

replace "123.123.20.5" with your DNS server IP

2. check  your /etc/nsswitch.conf  file, and make sure that it has:

hosts:     files dns [NOTFOUND=continue]

# you can just modify the record to make it use files and DNS
   then try to ping a machine with proper DNS record in your network by name

3. If you had done step 1 & step 2 and it still not working, try:
to specify the defaulterouter:

vi /etc/defaultrouter
and put 123.123.10.1   in the file, replace "123.123.10.1 " with your router IP

or
echo "123.123.10.1" > /etc/defaultrouter

then reboot.

PS: also check your PC client's setting to make sure it use DNS. check if you can  ping by IP as well.

0
 
AffnoAuthor Commented:
1. make sure your /etc/resolv.conf file looks like:

I don't have a such file there please advice, do i need to create one ?
0
 
yuzhCommented:
That's why you box can't use DNS!

You can use a text editor (vi or dtpad) to create the file, and make the permissions looks
like:
-rw-r--r--   1 root     root         155 Jul  1  2004 /etc/resolv.conf

PS: you can put more  than one DNS server in the file, eg:

nameserver 123.123.20.5
nameserver another-dns-server-IP


You can also have a look at the Solaris doc (adm, network guides) in:
http://docs.sun.com/app/docs



0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
AffnoAuthor Commented:
I just add the DNS and defaultrouter,
But now arp -a is taking very long time to respond

root@texas# arp -a

Net to Media Table: IPv4
Device   IP Address               Mask      Flags   Phys Addr
------ -------------------- --------------- ----- ---------------

0
 
AffnoAuthor Commented:
When I ping to the cliet machine,

root@serverhostname# ping 192.168.1.15
no answer from 192.168.1.15
0
 
yuzhCommented:
Did you reboot the box after you add/modified the files?

Can you post the output of the following commands:

ifconfig -a

grep hosts /etc/nsswitch.conf  


0
 
yuzhCommented:
also have check you windows PC, have a look at the answer in:
http://www.computing.net/solaris/wwwboard/forum/3280.html
0
 
AffnoAuthor Commented:
root@serverhostname# ifconfig -a
lo0: flags=1000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4> mtu 8232 index 1
        inet 127.0.0.1 netmask ff000000
bge0: flags=11000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4,FAILED> mtu 1500 index
2
        inet 192.9.229.175 netmask ffffff00 broadcast 192.9.229.255
        groupname failover_group
        ether 0:3:ba:46:e9:cb
bge0:1: flags=11000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4,FAILED> mtu 1500 inde
x 2
        inet 192.168.1.39 netmask ffffff00 broadcast 192.168.1.255
bge0:2: flags=19040843<UP,BROADCAST,RUNNING,MULTICAST,DEPRECATED,IPv4,NOFAILOVER
,FAILED> mtu 1500 index 2
        inet 192.9.229.150 netmask ffffff00 broadcast 192.9.229.255
bge1: flags=79040803<UP,BROADCAST,MULTICAST,DEPRECATED,IPv4,NOFAILOVER,FAILED,ST
ANDBY,INACTIVE> mtu 1500 index 3
        inet 192.9.229.151 netmask ffffff00 broadcast 192.9.229.255
        groupname failover_group
        ether 0:3:ba:46:e9:cc
root@serverhostname#
0
 
AffnoAuthor Commented:
root@serverhostname# grep hosts /etc/nsswitch.conf
hosts:      files dns [NOTFOUND=continue]hots#
# "hosts:" and "services:" in this file are used only if the
hosts:      files
root@serverhostname#
0
 
yuzhCommented:
Can you ping to your router and other Unix boxes in the same network, any firewall in
the network?

also
go to your Windows PC, at command prompt, type in:

ipconfig /all

and post the output.
0
 
yuzhCommented:
If you can't ping to your router, you need to check the cable connetion, switch etc.
0
 
Hanno P.S.IT Consultant and Infrastructure ArchitectCommented:
First: There is no need (at least at this stage) to enable DNS
Second: As found in /etc/resolv.conf the system does not use DNS anyway ;-)

What did you ping: Hostnames or IP-addresses?
  ping IP-address
should always work. If this is NOT the case you have a network/routing problem.
If this DOES work but pinging a host by it's name does NOT, you have a name
resolution problem (/etc/hosts, DNS, NIS/YP, NISplus, LDAP)
0
 
AffnoAuthor Commented:
I found the answer at http://www.experts-exchange.com/Operating_Systems/Solaris/Q_21423125.html

THanks for all your comments !
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 6
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now