We help IT Professionals succeed at work.
Get Started

Configuring dynamic IPSec VPN between PIX and Cyberguard SG

Doctorlloyd
Doctorlloyd asked
on
587 Views
Last Modified: 2013-11-16
I have a pix 506 as my office firewall, and a cyberguard SG570 that I want to configure for remote access dynamically.  In my current config, I get phase 1 to complete, but not phase 2.
I set up the cyberguard per the instructions on their website : http://www.cyberguard.info/snapgear/faqomatic/public_html/fom-serve/cache/264.html

And have the following config in my pix:
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password
passwd
hostname Pix
domain-name pix.com
clock timezone CST -6
clock summer-time CDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
no fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list compiled
access-list 99 permit ip 10.10.10.0 255.255.255.0 10.10.80.0 255.255.255.0
access-list acl_out permit ip any any
access-list acl_out permit icmp any any
access-list acl_out permit ip 10.10.10.0 255.255.255.0 any
pager lines 24
logging on
logging buffered debugging
mtu outside 1500
mtu inside 1500
ip address outside 10.11.12.13 255.255.255.248
ip address inside 10.10.10.1 255.255.255.0
ip verify reverse-path interface outside
ip audit info action alarm
ip audit attack action alarm
ip local pool pptp-pool 172.30.1.1-172.30.1.254
pdm logging debugging 500
pdm history enable
arp timeout 300
global (outside) 1 interface
nat (inside) 0 access-list 99
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group acl_out in interface outside
route outside 0.0.0.0 0.0.0.0 10.11.12.13 1
timeout xlate 1:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
aaa authorization command LOCAL
http server enable
http 0.0.0.0 0.0.0.0 outside
http 0.0.0.0 0.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
tftp-server inside 10.10.10.11 c:\tftp-root
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set strong esp-des esp-md5-hmac
crypto ipsec transform-set cyberguard esp-des esp-sha-hmac
crypto dynamic-map dynmap 99 set transform-set cyberguard
crypto map ipsec 98 ipsec-isakmp dynamic dynmap
crypto map ipsec interface outside
isakmp enable outside
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0 no-xauth no-config-mode
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 1
isakmp policy 10 lifetime 86400
telnet 10.10.10.0 255.255.255.0 inside
telnet timeout 60
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 60
management-access inside
console timeout 0
vpdn group 1 accept dialin pptp
vpdn group 1 ppp authentication chap
vpdn group 1 client configuration address local pptp-pool
vpdn group 1 client configuration dns 10.10.10.11
vpdn group 1 client configuration wins 10.10.10.11
vpdn group 1 pptp echo 60
vpdn group 1 client authentication local
vpdn username VPN-LAP1 password *********
vpdn enable outside
terminal width 120


As near as I can tell from the cyberguard, It is not chosing a proposal.

any ideas?
Comment
Watch Question
This problem has been solved!
Unlock 1 Answer and 1 Comment.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE