Messages staying in "messages queued for deferred delivery" queue

Sid_F
Sid_F used Ask the Experts™
on
I run a piece of software called vpop3 as the program that retrieves my mail virus checks and filters it, it then passes the mail on to exchange 2003 (everything works great) I had to change exchange smtp port to 1025 and pop port to 1110 to avoid port conflicts with vpop3, so now all mail that comes into vpop3 is forwarded onto exchange server port 1025

My problem is that I have some users who are not part of my network so I have setup "forward all mail for unresolved receipients"  to my isp's relay how ever the mail sits in the "messages queued for deferred delivery" queue

How can I tell exchange to send these straight away, I though exchange would handle it the exact same as it does all other mail and simply forward it to vpop3 and let it do the sending.

Any ideas
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Expert of the Year 2007
Expert of the Year 2006

Commented:
The problem is that you have changed the SMTP port.
The SMTP Virtual Server is used for both inbound and outbound messages. The ISPs SMTP server cannot communicate on port 1025.
You need to put the virtual SMTP server back to port 25 so that outbound email messages can leave your server.

There are a couple of techniques available to stop conflicts with the built in SMTP Virtual Server.

1. Setup an extra SMTP Virtual Server. When doing so change the port.
2. Add an extra IP address to your server. Bind the Exchange SMTP virtual server to the first IP address and then your application to the second. Get it to forward email to the first IP address.

Simon.

Author

Commented:
Outbound messages are leaving the server and coming in fine its only when it has to forward mail to isp for unrecognised users that the problems start. I cannot change the port back to 25 as vpop3 needs it to communicate with ISP

I'm a little confused regarding what you have said about isp not being able to communicate with requests from port 1025 as when I look at my router log for requests on port 80 I can see the request being made by the local port which is not port 80. i.e port 80 source does not seem to have to communicate with port 80 destination.
 
Port 5553 can communicate with port 80 so how come port 1025 can't communicate with port 25 ?


"There are a couple of techniques available to stop conflicts with the built in SMTP Virtual Server."

"1. Setup an extra SMTP Virtual Server. When doing so change the port."

Is this not the same as I have done already?

Thanks

Expert of the Year 2007
Expert of the Year 2006

Commented:
Are you using your own domain or your ISPs domain for email?

username@isp.net
or
username@domain.com

You cannot compare the way that http traffic works and the way that SMTP traffic works. While they are both IP protocols, they operate in a different way.

My technique involves TWO SMTP Virtual Servers. You stated "I had to change exchange smtp port to 1025", which led me to believe that you have just corrected the existing SMTP Virtual Server. If that is not the case then you need to clearly indicate that. If you are able to send email elsewhere then a second SMTP virtual server would explain how that is working for you.
You need to remember that I am not in front of your machine. While something may appear obvious to you, I can only go by what you have written. I cannot presume anything.

Changing ports on Exchange will usually cause problems. The default settings should be left alone. If you need to use alternative ports then it is best practise to setup additional virtual servers. Ideally you should have a separate server which sits between the Internet and Exchange so that no changes to Exchange need to be made.

Are the messages that are stuck in the queue messages from outside being relayed through or messages sent by internal users?

Simon.
Acronis in Gartner 2019 MQ for datacenter backup

It is an honor to be featured in Gartner 2019 Magic Quadrant for Datacenter Backup and Recovery Solutions. Gartner’s MQ sets a high standard and earning a place on their grid is a great affirmation that Acronis is delivering on our mission to protect all data, apps, and systems.

Author

Commented:
I am using my own domain but it is hosted by my isp i.e they are all pop accounts.

Yes I have corrected port 25 to 1025 in exchange. I can't add a second exchange smtp virtual server port because port 25 is being used by vpop3.

Ideally I would have a second machine with vpop3 running on one and exchange on the other the only problem being my exchange server is also acting as the primary anti virus server and is supplying all the machines on the network with anti virus and vpop3 also uses this to scan incoming mail.
I would imagine by seperating the two machines that it would also make mail slower as it has another hop before reaching isp's relay.

The message stuck in the queue are from Internal users sending to users using the same domain name but not located on the same server i.e they need to be sent to isp.

Thank you for your help so far
Expert of the Year 2007
Expert of the Year 2006

Commented:
You can add a second SMTP Virtual Server.
First you have to add another IP address to the server. This should be on the same subnet as the existing IP address.
So if you are using 192.168.1.x then add another address so that the server has two.
Next.

Change the default SMTP Virtual Server setting for IP address from "All Unassigned" to one of the two IP addresses.

Next. Add another SMTP Virtual Server in ESM, Admin Groups, <your admin group>, Servers, <your server>, Protocols, SMTP. Right click and choose New. Assign this the other IP address.

Finally adjust your VPOP3 application the IP address that doesn't have the SMTP Virtual server bound to it.

This should allow outbound traffic to flow correctly.

Although... any reason why you are using POP3 accounts? Exchange is designed to work via SMTP. Even if you are on a dynamic IP address, if you have any kind of permanent internet connection you can get email delivered directly. If you have users collecting email off the ISP you could just switch them round to collecting email off your Exchange server.

Simon.

Author

Commented:
I have tried the above but it only works if vpop3 does not do the sending i.e exchange does all sending and vpop3 is taken off port 25. Its definetely a solution though !

To make a long story short I have joined the two networks together so all mail is routed locally rather than having external addresses I would have done this first only I was told the external users would be sending very large mail and would prefer to be on their own and away from exchange the very large files turned out to be 5mb

One final question can, you mention smtp direct which I have used for other customers can you advise what you use in front of exchange for anti virus spam filtering etc as currently their isp is filtering all spam. I have never looked into isa maybe this is an option

Thanks
Expert of the Year 2007
Expert of the Year 2006
Commented:
ISA isn't a spam filter. It is Microsoft's "firewall".

You should be looking at something like GFI Mail Essentials, possibly combined with their Mail Security product. This will do Spam filtering a lot more besides.

http://www.gfi.com/ 

For pure spam I have also used Sunbelt Software's "I Hate Spam". That works very well and their whitelist, blacklist and quarantine folder features are very popular with the users.

Simon.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial