Changed IP Address of Server - old IP keep reappearing in DNS.


Changed the IP address of our PDC (only server in the environment) from 192.168.30.10 this morning to 192.168.30.5

All seems well, DHCP is updated, clients can all connect... then suddenly no-one can log in (well, very, very slowly) nothing has changed on clients, but pinging the server resolves to the old IP address.

in DNS, Server > Forward Lookup Zones > DOMAIN.local, there is an "A" record for the server, with it's *OLD* IP address.

I reset it and all is well again - for a few minutes.

Every ten minutes or so (or instantly if I "reload" the zone) the old IP address re-appears.

I have did an ipconfig /flushdns then rebooted the server, searched the registry and replaced all occurences of the old IP with the new one, checked WINS - the only record I can find for the old IP address is the 1Ch DOmain Controller Record, which lists both the old and new addresses.

Any suggestions?

This is urgent, hence high points!
WintermuteCLAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gpriceeeCommented:
On the PDC, go to a cmd prompt
ipconfig /registerdns
Also, check hosts files.
Guy Hengel [angelIII / a3]Billing EngineerCommented:
I agree with gpriceee...
WintermuteCLAuthor Commented:
kay, tried that - so, find out in 15 minutes if it worked :)
Exploring ASP.NET Core: Fundamentals

Learn to build web apps and services, IoT apps, and mobile backends by covering the fundamentals of ASP.NET Core and  exploring the core foundations for app libraries.

gpriceeeCommented:
Are you replicating DNS or WINS?
oBdACommented:
Did you change the server's DNS server settings in the TCP/IP settings as well? The server needs to point to itself (only--no ISP DNS!) for DNS.
Anything in the event log?
Install the Support Tools (from CD, if Pre-SP1, from link below if SP1), then run netdiag.exe and dcdiag.exe.

Windows Server 2003 Service Pack 1 32-bit Support Tools
http://www.microsoft.com/downloads/details.aspx?familyid=6EC50B78-8BE1-4E81-B3BE-4E7AC4F0912D&displaylang=en
WintermuteCLAuthor Commented:
More info:

The server is multihomed, internal 192.168.30.0/24 - this card has no default gateway set, and it's DNS Server is set to 192.168.30.5 (new IP of the server)

external is 10.20.0.0/24, has the feaulf gateway pointing at the Internet router, and DNS also set to 192.168.30.5

THere are no other servers in the environment, so no replication of either WINS or DNS.
gpriceeeCommented:
Is it working?
Clear DNS registration and WINS registration for the external address, if they exist.
Also, you'll probably have to flush dns and nbtstat on the workstations if they have problems.
WintermuteCLAuthor Commented:
dcdiag shows:

 Although the Guid DNS name
 (6054508f-9a7e-4a64-b03c-b0ea733eaa9d._msdcs.DOMAIN.local)
 resolved to the IP address (192.168.30.10), which could not be pinged,
 the server name (SERVER.DOMAIN.local) resolved to the IP address
 (10.20.0.10) and could be pinged.  Check that the IP address is
 registered correctly with the DNS server.

Which is odd, as 10.20.0.10 is not registered with DNS!
gpriceeeCommented:
cmd prompt.

ipconfig /flushdns
nbtstat -RR

STOP DNS and WINS services

Start the services

ipconfig /registerdns

ping -a 192.168.30.5

ping  servername

route print

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
WintermuteCLAuthor Commented:

okay...

flush ok, nbstat ok

stop services
start services
ipconfig /register ok

ping -a resolves correctly to servername

ping servername resolves to *external* interface 10.20.0.10 :|

route table is correct.

*but* the server IP seems to be staying as 192.168.30.5 in DNS... I'll leave it for 15 mins or so to check, but it's looking good!


gpriceeeCommented:
Check DNS for another record for the server.
Also check WINS.
If you have a hosts entry for the 10. address, it will resolve, so if you have it, clear it.
C:\%OS%\system32\drivers\etc\
check both the hosts and lmhosts files.
If you find the entry, clear it.
In the WINS tab of network properties, import the hosts file again.
Don't reboot--just go back to the old cmd --> nbtstat -RR
fugazerCommented:
I'm having exactly the same issue.. I changed my server's IP from 192.168.1.100 to 192.168.1.2 a couple days ago b/c i started running into problems by using such a common IP for my server.. But now my dhcp service is still sending out the old DNS entry.. I've tried gpriceee's solution, but its not working for me...

when i run netdiag /test:dns it say's passed but shows the following warning:

DNS test . . . . . . . . . . . . . : Passed
[WARNING] Cannot find a primary authoritative DNS server for the name 'home.mydomain.com.'.

[ERROR_TIMEOUT]
The name 'home.mydomain.com.' may not be registered in DNS.
       
[WARNING] The DNS entries for this DC cannot be verified right now on DNS
 server 192.168.1.100, ERROR_TIMEOUT.
 
PASS - All the DNS entries for DC are registered on DNS server '192.168.1.2'
and other DCs also have some of the names registered.

I'm not sure what i'm doing really but i can see that .100 is still showing up which is most likely the problem.. Hope someone can lend a hand? Also, i'm new to EE so i hope it was okay that i posted my related problem here.. And advice would be appreciated.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.