Custom Recipient/Contact problem in Exch 2003

I have several people that have email addys with the same domain name that Exchange servers use that work exclusively out of the office. Therefore their email doesn't go thru servers, I have their boxes on ISP side. So that people internally can send them mail I set up some Custom Recipients (SMTP) in 5.5 which worked well. I am now in progress of moving users off of 5.5 and onto new '03 server. The people on the new server cannot send mail to anyone that was set up as a custom recipient (5.5) or as a contact ('03) that has same domain name ( as servers. BTW domain name didn't change only added new '03 to org of 2 5.5's.

How do I fix this?
Bob StoneIT GuruAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

For the people with custom domains. you will need to add a (A) host record on your dns server to point to the external ip address for that domain.
Bob StoneIT GuruAuthor Commented:
It is the same domain as the one that the Exchange servers use, will that still work?
Your server thinks it is responsible for all email for that domain, there's a walkthrough at

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

Sorry Bob, that won't work unless you're using POP3 since it will look  up the MX record and send it back to you if your server is the primary MX. Use instead:

Deselect the "This Exchange Organization is responsible for all mail delivery to this address" box under the recipient policy, and use the "Forward all messages with unresolved recipients to host" option under the messages tab of the default virtual server properties to enter the IP address of the ISP based mailbox server. If you can't deselect the exchange is responsible box then add mydomain.local to the recipient policy with the box ticked and then it should be deselectable on the other address.
I just remembered you've only got one server with a couple of domain names so use method 2 instead, just use the forward all messages with unresolved names to this address option and don't deselect the responsible for all mail delivery option.
Sorry about the 3 notifs.
Bob StoneIT GuruAuthor Commented:
I got 3 exchange servers, 3 domains (2 NT & 1 2003/AD), and 1 email domain name. I have 3 Exchange servers because 1 (5.5, for now) is in another loction connected via wireless bridge and the other 2 are an outgoing 5.5 and new incoming 2003.

Once I get the 2003 handling all the mailboxes at the one location I will build another 2003 for the other building, that one should be alot easier hopefully.

Keep in mind it is only me, myself and I in the IT dept.
Bob StoneIT GuruAuthor Commented:

I added old Exchange machine name to Forward All Undeliverable Mail to thing in SMTP policy.

When I added the mydomain.local to Recipient Policies and made it default it killed OWA. I took out the local one but left the "This Exchange Organization is responsible for all mail delivery to this address" on the original unchecked, OWA still works.

I picked one user and I deleted their Custom Recipient on 5.5 and their Contact on 2003. It worked well until the CR replicated into a contact on '03, then I started getting bounce messages again.
Bob StoneIT GuruAuthor Commented:

I had to remove the check next to "This Exchange Organization is responsible for all mail delivery to this address" on ALL 3 Exchange servers. Fun facking day figuring out that 30 second fix.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.