DAT24 drive will backup to DDS2 but errors on DDS3

I have an HP Surestore DAT24 drive.  Recently I began getting errors on my backups, the event log saying "The device, \Device\Tape0, has a bad block." After trying over 20 tapes & getting the same error I assumed my tape drive
was bad & replaced it (with a refurbished one I bought online).

I installed the new drive but kept getting the same errors (on multiple tapes).  Finally I replaced the SCSI controller with another I already had that I knew was good.  Same errors occurred.  I then put the original tape drive, original SCSI controller into another computer I had (both are running NT4sp6).  Same errors again.  

I put an old DAT8 drive on the second system & it worked fine with DDS2 tapes.  I then began trying out the DDS2 tapes on the first system with the new drive in it & was able to get successful backups , but got the errors on ALL of my DDS3 tapes.  Finally I bought a box of new DDS3 tapes.  I just tried them out & still got the same errors.

Why would I be able to run backups on the DAT24 drive using the DDS2 tapes & not brand new DDS3 tapes?  I looked at the install guide for the drive but couldn't find any settings/switches that would be doing this.  
BHRAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rindiCommented:
What backup software are you using? Have you looked for new drivers for the device?
BHRAuthor Commented:
I'm using NT Backup, though I have since put the tape drive/scsi controller into a Win98 machine & have gotten similar errors trying to use it's Windows Backup program with my new DDS3 tapes.

I've looked & I'm using the latest drivers for the tape drive & the controller.  I re-installed the Tape drive controller just in case, but with no change.
rindiCommented:
If you are getting this on another PC with w98 on it too, then looks a bit like your refurbished drive isn't refurbished that well. What you could check if it works better using other cables, and make sure it is properly terminated on the SCSI Bus.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BHRAuthor Commented:
I've returned the drive to where I purchased it.  They said it'll take about a week or so.  If that takes care of the problem I'll post & accept rindi's 2nd comment as the answer.
BHRAuthor Commented:
Well it turned out that the drive was bad.  I just got a replacement & it works fine.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.