TightVnc binds to local ip instead of internet ip

I put tightvnc on a client's computer and set it to run as a service.  Problem is that it grabs the local ip at startup - how do I make it smart enough to wait for an internet ip assigned of course by the isp and answer to that instead?

LVL 13
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Lee W, MVPTechnology and Business Process AdvisorCommented:
It should be listening on all IPs.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Lee W, MVPTechnology and Business Process AdvisorCommented:
Or is the system behind a firewall or router?
gsgiAuthor Commented:
Ok. I'll try it out.  I just noticed the local ip when I put my cursor over it in the little system tray, so I assumed that it was only listening to it.
I try tomorrow to actually connect to it, I think my client has gone to bed for the evening.  Thanks.  -Greg
Tim HolmanCommented:
DependOnService registry key may help - this can force tightvnc to start after a particular service has.

Or, you could create an icon that ran a batch script that ran the dial-up, and then ran tightvnc ?  The user would click this, so that tightvnc would run after setup.

eg:  dialup.exe && tightvnc.exe would wait for dialup.exe to finish before launhcing tightvnc.

Or, delay the loading of the service:


If the client is set to DHCP, does tightvnc try and grab ?  Is the client already connected to something ?

It really depends on the network configuation, how is the client connected to the internet, is a router involved?

TightVNC will say it is listening on all currently active IP addresses, If the client is using a router to connect to the internet make sure ports are forwarded and it will be fine.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.