unexpected end of file while looking for precompiled header directive

Hi my experts,
In my application I use a classe CRijndael form this link
http://www.codeproject.com/cpp/aes.asp
When I compile my project, an error occur:
unexpected end of file while looking for precompiled header directive
So what I can't do to solve this problem?
Thanks
memorizerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

B1-66ERCommented:
try to include
#include "Rijndael.cpp"
instead of
#include "Rijndael.h"
B1-66ERCommented:
or better
using menu in VC++
Project->Add to Poject -> FIles ...
add Rijndael.cpp and Rijndael.h
and then only
#include "Rijndael.h"
must work :))
marcodalzottoCommented:
What B1-66ER of course is right,
 anyway if you are using the stdafx project, so if in your project is included the stdafx.h you should include it too the Rijndael.cpp.

At the top most of the file Rijndael.cpp:
#include "stdafx.h"

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Learn Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

RomualdVilletetCommented:
In Microsoft visual c++ 6.0 and 7.0 go to the project settings,select tab C/C++ you will find the tab precompiled headers.

set the first parameter to Not Using Precompiled Headers.

recompile it and your problem will be gone.

greets
RomualdVilletetCommented:
what i just said depends on what kind of project it is. But if you have a stdafx.h in your project include it in Rijndael.cpp

and when you still have a error you must set the precompiled header options to this file
krbatgeCommented:
Actually, if you are using a precompiled header (stdafx) you don't have to include stdafx.h in Rijndael. Instead you could simply select 'Not Using Precompiled Headers' just for this class.

To do this:
1. go to the project settings tab and select Rijndael.cpp instead of the whole project.
2. select the C++ tab
3. set the first parameter to 'Not Using Precompiled Headers'
hemakumarCommented:
in ur Rijndael.cpp top most inclusion should be #include"stdafx.h" and u don't want precompiled header use comment of  krbatge above.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
C++

From novice to tech pro — start learning today.