Restoring Exchange 2003 backup on new Exchange server

We had a serious crash of our Windows 2003 Server running an exchange server which resulted in a new installation from scratch. The system is up and running again. Luckily, a backup of the exchange database was done a day before the crash (with Windows Backup).

Unfortunately I am not able to restore the backup again. I have tried virtually all solutions and instructions I have found at EE, Microsoft or elsewhere on the Internet. I tried to restore with a Recovery Storage Group (RSG). I got stuck when actually restoring from the backup with an error. Nevertheless, there seems to be all data in the RSG but I am not able to mount the SG no matter what I do. I allso tried all repair, defrag /cc etc. but nothing helped.

Maybe I need to mention that the original data base was stored on a J: drive while the new one now resides on C:. I have come across some postings where it was mentioned that this might be potential for problems. Besides the drive letter all other names etc. are exactly the same, including the same hardware.

Nevertheless, for what reasons ever I cannot move the database back to a J: drive.

I also tried some some demos of the commercial utilities to recover OST files (which I recovered from all users) or old database files but I cannot afford paying Hundreds of bucks for them (demo seemed to work successfully).

Any ideas please? I am in trouble right now. Btw, the old Exchange database is about 1.5G...
domimAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NiclasHCommented:
Where does it go wrong? When you restore the databases, when you try to mount them? Please specify and what errors do you get. Check the application log. Clean it out before so you only capture the important one's.
domimAuthor Commented:
I fails at NTBACKUP after the entire file has been recreated in the Recovery Storage Group. It couldn't be completed for the following blah blah reasons which reffers to the event log which gives the following 4 errors (first error on top):

Failed to find a database to restore to from the Microsoft Active Directory.
 Storage Group specified on the backup media is 1ad2277e-99d7-4a48-940d-0ca73b469618.
 Database specified on backup media is Public Folder Store (XXX), error is 0xc7fe1f42.

Information Store (3464) Callback function call ErrESECBRestoreGetDestination ended with error 0xC7FE1F42 Database not found.

End Restore to 'XXX\Microsoft Information Store\First Storage Group' 'Failed'
       Verify:  Off
Consult the backup report for more detail.

End Operation: Warnings or errors were encountered.
Consult the backup report for more details.


I also checked the "Last restore set" box in NTBACKUP.

Again, all names are the same except for the drive which was J: before and is now C:

When I try to mount the RSG anyway I get the following error:

"An internal processing error has occured. Try restarting the Exchange System Manager or the Microsoft Exchange Information Store service, or both.
ID no: c1041724
Exchange System Manager"

Restart of both did not change anything. Also checked the numerous hints about this error code but all tries were unsuccessful.

Any ideas?

Dominik
NiclasHCommented:
I would do a normal restore. But if you want to continue with RSG read http://support.microsoft.com/default.aspx?scid=kb;en-us;824126 "Recovery SG Override Registry Key".

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

domimAuthor Commented:
I am already using the "new" database for a week now. How would I safe that and merge that back if I restored the database? And does the different drive letter not affect the whole restore thing?
NiclasHCommented:
If you've already used the new db for a week then RSG is the right thing to do. Read the article above.

Niclas
domimAuthor Commented:
I am stuck with two problems on the above mentioned article:

- NTBACKUP restore only produces an empty Restore.env with 0KB
- I followed all the instructions and repaired the database, defragmented it, checked its consistency (all ok) and copied the files to the RGS. Still the same prolem, cannot mount it and therefore cannot merge it :-(

ARGH!
domimAuthor Commented:
From the above article:

"To use a Recovery Storage Group, the Active Directory topology of the Exchange Server 2003 computer must be intact and must be in the same state as when the copy of the database was made. This means that the mailbox or the mailboxes that you want to recover must not be deleted or purged from the system, or moved to a different database or to a different server."

The old and new state are different in my case...
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.