Laptop will not connect to network!

Hi. I have a network of 3 pcs, and a laptop. I can access the network on all the pcs (although I do have to type in the network key manually before they will connect).

My laptop refuses to connect. I got the following error - Windows is unable to connect to the selected network. The network may no longer be in range. Please refresh the list of available networks and try to connect again -

I then did what Microsoft advise: 1.      Click Start, point to Connect To, click Show all connections, and then double-click your wireless network adapter.
2.      On the General tab, click Properties.
3.      Click the Wireless Networks tab, and then click Add.
4.      Type the service set identifier (SSID) of the access point.
5.      Set Network Authentication to Shared.
6.      Click to clear the following check box:
The key is provided for me automatically
7.      Type the WEP key for the wireless network access point in the Network key box.
8.      Type the WEP key in the Confirm network key box, and then click OK.

On my Netgear set up (wireless) I have:

1) SSID (as above)
2) Region - Europe
3) Channel 10
4) Mode g and b
5) Enabled wireless access point
6) Allowed broadcast of SSID
7) Set up access list (nothing changed here)
8) Authentication type - shared key
9) Strength 64 bit
10) Key 1 10 characters.

On trying to connect, now, the out of range error has gone. I get Please wait while windows connects to the "XXXXXXXX" network. But it doesn't connect!

Does anyone have any ideas how to fix this. Thank you.
NasturtiummanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rindiCommented:
Check the access point if the NIC's MAC address is in the list of allowed addresses.

Also, what make and model is that nic?
NasturtiummanAuthor Commented:
Hi rindi, thanx for your answer.

On the PC, the wireless router is a Netgear  WGR614v4

The Laptop has a mini pci wireless card - Am1772(tm)
I used ipconfig/all (laptop) and found the Physical address (Mac address) as you suggested.

There is a facilty in set up on the Netgear to set up an access list. I selected ADD, typed Medion (the network name foir the laptop), and entered the mac address. I then checked the box "Turn Access Control On". Apply.

This has had no effect I am sorry. It attempts to connect for 30 seconds, and then goes back to choose a wireless network, where NETGEAR - security enabled wireless network appears, with a really strong signal.
Automatic*

???
Thanx very much again.
rindiCommented:
Do you have more info on the Am1772? This is more or less just the amd chip being used, but normally OEM's will use this chip in their wireless cards, or is this a standard card coming directly from your laptop manufacturer? If so can you also provide me with the laptop model?
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

NasturtiummanAuthor Commented:
AMD®  WIRELESS  LAN BTO MINI PCI ADAPTER IEEE 802.11b
AMD wireless networking solutions enable network connectivity without wires or an add-on adapter card for desktop and notebook PC platforms. AMD products provide uncompromising performance, security and scalability for fast, flexible connectivity at work, at home, or on the road.
Wireless Local Area Network (WLAN) technology extends enterprise productivity by keeping employees connected to the corporate network at work, at home, and on the road.
AMD Wireless 802.11b LAN BTO Mini PCI Adapter
Model No: WL-1401

That was the spec on the card as I bid for it. It is not the original card. I damaged the original in removing it from the laptop (in attempt to solve this connectivity thing). This card SEEMS to work alright, but curiously there is no power connector (but the original card did have one ???). I could not source an exact replacement.

By the way there is a utilty supplied with the card that may be of some use to us?
Thanks...

rindiCommented:
That's the reason I asked about more info. AMD itself doesn't supply such drivers and utilities, but probably the company that packaged the chip. Can you run everest, maybe this program will be able to get more exact info about it and even provide a link to a download site:

http://lavalys.com
NasturtiummanAuthor Commented:
Hi again, Everest gives the device as Am1772(tm) Wireless Engineering version
and
sis 900-Based PCI Fast Ethernet Adapter

Decided to give the AMD utility a try ... (LAPTOP)
Site survey:
ssid:Netgear
BSSID:12 digit number which I dont recognise (Is this a mac address?)
WEP:Yes
Type: Infrastructure
Signal Excellent
Channel 10.
Wireless Networks: Netgear appears in the top window. In the lower window (connect in the order listed) Netgear has a red cross on the icon.

In statistics there is lots of activity in receive column, but none in transmit.

Network status:Not connected

Advanced. The channel was set to default 7. Thought I should change it to channel 10.
As I did so, instantly I got Found new hardware -- SM Bus controller. Need to locate the drivers for this.

Still no luck whatever I do it doesn't seem to want to connect.

BTW I put the points up because this is a real B-----D!

BFN.
makanaCommented:
Sure your Hardwares are well and working?
XGENTECHCommented:
I sometimes get this error - what i do is not exactly expert, but i enter the connection status then click on propertys then select the Wireless Networks tab and click Advanced then select either "any avalable network" or "access pont" and then click close and close on the other windows, this strangly fixes the problem, i usualy get this error when i am on the outskirts of my wireless range, i have no idea why this fixes the problem, let me know if it works, ok
ZabagaRCommented:
Just as a test, can you set your netgear to either G or B, not both "g and b"......change it to ONLY what your laptop network card uses.  See what the result it.

-z-
cooleditCommented:
hi, There

Just to check out for some mistakes.

Can you ping any other devices in the network from the Wireless card. ????

what kinda Operating system is on that Wireless card / Laptop. Win 98, Win XP home, Win XP Professional or else.

Br
Cooledit

NasturtiummanAuthor Commented:
Hi people.

I tried to set the router to first g only, then b only and finally back to g & b   ... no luck.

I tried XGENTECH's suggestion, and that didn't work either ...

I have tried to ping (from laptop) botth the IP address, and the default gateway. I get:

Ethernet adapter. Local area connection:Media state disconnected.
Destination host unreachable (x4). Sent 4, received 0.

Should I start to assume the card is faulty?
Regards.
XGENTECHCommented:
its maby falty, but there is more chance something is wrong in settings, it looks like a Encryption error, idoes the router support WPA-WSK as this is much better than WEP - i always had problems with WEP things like your describing
NasturtiummanAuthor Commented:
I can only see wep with options for automatic, open system and shared key.
XGENTECHCommented:
hummm.... oh well - WPA-WSK is a kind of new thing in SP2 from microsoft so it may not be on all routers yet... if at all... im 14 and wanting to become a network engineer and administrator of windows server 2003 domain networks etc... i struggle to help via words, oh well, i will try to help
cooleditCommented:
hi, there

As you can not ping the server is it possible to think there is a RJ45 jack into that laptop.
From that Onboard NIC is it possible to ping the server ...... ?

Cooledit
NasturtiummanAuthor Commented:
Hi cooledit I plugged a Rj45 cable into both router and laptop, looking at netgear documentation, a light should illuminate, but it doesn't. Tried to Ping again using run/cmd/ipconfig. No joy. In device manager there is an exclamation mark on PCI modem. I've tried to find drivers and load them. Will try to correct this, but I dont know if it is relevent.

The cable I am using to test was originally connected from D-Link wireless modem to pc. Could it be the wrong cable? Crossover etc...

Regards.
XGENTECHCommented:
Bit of a silly question, but is the network adapter on the laptop enabled and installed properly?
XGENTECHCommented:
plus yes this RJ45 cable could very well be a crossover - it should say if it is or is not wrote allont the rubber side of the cable
NasturtiummanAuthor Commented:
Have a box full of cables - will try a couple tomorrow to eliminate the crossover issue.
Okay ... now I AM gatting confused.... in response to XGENTECH (not so silly question)

Since connecting the cable, I have in device manager/network adapters:

1394 Net Adapter
Am1772(Tm) Wireless Engineering Version
SiS 900 Based PCI Fast Ethernet Adaptor

I'm sure the 1394 is new... but i only have the Lan and the wireless, why are there three?
Ping is not working still...
ktiedtCommented:
1394 is firewire (similiar to USB predates USB2.0, its a lot faster than USB 1.0 but slightly slower then the newer USB2.0 standard) and a cable running from a wireless modem to a PC should be a patch cable so that shouldnt be a problem.... sounds to me one thing you can try is running a SITE SURVEY on your wifi router from a PC thats is cabled to your router as this will kill the wireless links it has and it will generate a webpage that displays all the WIFI signals the router can see... this should elimiate the guess work on your WIFI adapter being bad.... your laptop should show up with its ocmputer name on the routers Survey.... (I'm heading home right now, so I will test this on my Linksys WRTG54 and make sure I got it right, but I'm fairly certain thats how it worked the last time I tested that feature.

just a few more ideas to try
NasturtiummanAuthor Commented:
I havent abandoned this -- I will get back soon!!
NasturtiummanAuthor Commented:
I installed Ethereal on the PC although I'm not sure exactly how to use it!

Under Capture:

These are the results:

1)  Generic NdisWan adapter: \Device\NPF_GenericNdisWanAdapter   nothing

2)  NVIDIA nForce MCP Networking Controller Driver (Microsoft's Packet Scheduler) : \Device\NPF_{5BDF5A2A-F17A-41F3-A
004-B25900EFC8D3}      nothing

3)  Marvell Gigabit Ethernet Adapter (Microsoft's Packet Scheduler) : \Device\NPF_{194AB053-629F-48C1-897B-C30ADA611C54}

TCP:87%
UDP:12%
ICMP:0.1%
ARP:0.1%
all the rest ... zero

4)  NET IP/1394 Miniport: \Device\NPF_{225A31AB-F403-4B3E-AC78-8ABD8FABDEF2}  nothing


It's all heiroglyphics to me. Would it be worth installing this on Laptop to see what traffic there is there?


harbinger79Commented:
Looks like this one is going to cause some bladness sorry about your luck thus far. I have two points to input.

1. A faulty nic can cause bad traffic and even slow a network down.
2. I would try disabling all other connections besides the wireless and try to ping the loop back address to see if the wifi nic is capable of communication. Ping 127.0.0.1 from a command prompt and see what results you get.


Note: I've had problems in the past with disabling my nic's sometimes so if you can't do it from the network connections screen you'll have to do it from the device manager. Also update any and all drivers you can, sometimes there's additional components hidden even to the expert eye when it comes to compatibility. Also the best way to rule out a problem with your laptop and your network is to test it from another wifi hotspot. Good luck.
NasturtiummanAuthor Commented:
Thanks harbinger. i am already bald with it. On network connections on my main PC (The one that has internet access),
I did as you suggested:

1394 connection (1394 net adapter) Disabled
Internet connection (cant seem to disable this)
Local area connection (NVidia NForce MCP Network Controller) Disabled
Local Area Connection 2 (Marvell Yukon Gigabit Ethernet 10/100/1000 base t adaptor, Copper RJ-45)  enabled.

The result of the Ping was: Reply sent 4 received 4 (encouraging?).
Not sure if I disabled the right things, but the router connects directly to the Marvell Yukon.
Well I'm amazed to see a successful Ping!
 I'm waiting for delivery of one of those PCMCIA cards! that I ordered in sheer desperation.

I still cant connect to the Network.
Thanks again ....

harbinger79Commented:
Nasturtiumman, I think there may have been a little confusion because of my lack of details on the network connection disabling. I was actually requesting you disable all other connections on the machine having the connectivity issue. If this is the one indeed then you followed my instructions fine.

How about some more details about the machine in question. What type of laptop if you can find the model info that will help and what O.S. are you running specifically. Start>Run>Winver will tell you that in Windows at least, with Linux I'm not too sure as I am only a novice.
NasturtiummanAuthor Commented:
No I disabled the wrong connections.  I am running XP Pro on all the machines, and all from the same installation disc.
On the laptop: I have disabled:
1394 connection (1394 net adapter)
local area Connection (Sis-900 based PCI Fast E5thernet Adapter

and I left the Wireless Networ Connection enabled. Tried the ping, and had the same result as before - packets sent and packets received  ...
rindiCommented:
What do you get when you run an ipconfig /all just with the wireless enabled? What do you get when only the Sis900 is enabled and connected to the LAN?
NasturtiummanAuthor Commented:
On the laptop if I disable everything but the wireless and I ipconfig - It says Ethernet adapter wireless network connection - media disconnected. (Ping works fine)

With the Sis900 only enabled and laptop cabled directly to router, I get Local area connection - Network cable unplugged and a red cross. Device properties indicate everything is fine. I exchanged the cable with the one that connects the cable modem to the router, to check for a bad cable, and it looks like the cable is okay, since my internet access on the PC is fine.
I will try switching the router on/off - no nothing. There is an illuminated 4 at the end of the panel on the router, which I presume means that there is a functional cable in socket4 (to the PC). I guess I should be getting a 3 with the other cable plugged in, but nothing  ...
Should I try to bridge connections?
rindiCommented:
Try resetting the router to factory defaults. This is usually done by pressing a small, recessed button at the back of it, then connecting the power and keep the button pressed for a couple of seconds. check your manual for details.
NasturtiummanAuthor Commented:
I reset the Netgear router. On resetting the PC there was a found ethernet controller, but i think it installed itself as I used the install new hardware wizard, and there were no new devices.

The laptop remains the same. When I type Ipconfig it shows:

Ethernet adapter wireless network connection:
Media state:disconnected
Ethernet Adapter Local area connection:
Media state:disconnected

Yet the wireless network is visible, and your Ping worked?
When I replaced the original MiniPCI card I noticed that on the original card there as a small connector for power supply, but on the replacement there was no need for this connector. Could that be an issue?
rindiCommented:
This might have been a connector for the internal antenna, not the powersupply. Maybe the new card has a builtin antenna.

To me it looks like something to do with the router, as you can't connect to the router with either the wireless nor the lan connection. Maybe the reset didn't really reset it to the factory defaults. Maybe you can configure the router using another, connected PC. Check for a setting which only allows certain AMC addresses to connect. If that is set to on, and those mac addresses of your not working PC aren't included, you may be able to see the router, but not connect to it. So you'll have to add the mac addresses of the NICs on the not working PC to the allowed list in the router.
NasturtiummanAuthor Commented:
Yes there is a facility to allow specific mac addresses. I'll try that a bit later. I may also borrow another pc to test the cable connection. However, as part of the same network I have a wife and kids pc downsairs that connects fine, they have internet access and we can share files. When I did the reset I lost all my port forwarding permissions(I had made a note of them), so it seems to have reset correctly. I can borrow a d-link router and have a go with that?
Thanks for your considerable help.
rindiCommented:
Yes sure.
NasturtiummanAuthor Commented:
Hi again. I borrowed my wife's PC, and connected the cable to the ethernet port from the Netgear router. The 3 illuminates and I can see the contents of drive C from my main PC. There's something about that Laptop?
NasturtiummanAuthor Commented:
The obvious thing to do then was to connect the spare pc with the laptop via the cable, and try to ping - result: destination host unreachable ...
rindiCommented:
If you connect two PC's together directly to the NICs you need a crossover cable for this to work, and you also have to set a static IP on each NIC, like 192.168.3.1 for nic 1, 192.168.3.2 for nic 2. Otherwise you won't get them to connect.
NasturtiummanAuthor Commented:
Thanks I think I have a crossover cable somewhere. Will try it.
NasturtiummanAuthor Commented:
hi, just received the pcmcia CardBus (Netgear) wireless adapter .. and it works !!!!
rindiCommented:
Nice going at last!

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
NasturtiummanAuthor Commented:
I'm going to accept this as the final answer. Although I was unable to troubleshoot the exact problem, at least I felt justified in going out and buying a PCMCIA adaptor which works very well!
rindiCommented:
Thanks too.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Hardware-Other

From novice to tech pro — start learning today.