Windows XP Pro after bootup always displays "could not reconnect all network drives" though all are available

After Windows XP Pro boots up an error message appears over the notification tray saying "could not reconnect all network drives".  I click on the message to see what hasn't connected but both mapped drives do NOT have an X over them and are in fact quite ready for use.

This PC is in a workgroup and has two drives mapped to folders on a Windows 2000 Pro PC that is always running.

I've tried enabling the group policy "Always wait for the network at computer startup and logon" but this does not eliminate the error message.

Any suggestions?
trwildeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AZ-AdministratorCommented:
Hi trwilde,
from research i did last year when i was having this problem (which persists a couple of times a week still), there was no clear reason for this behavior or how to stop it, however, i have come across a couple options from this thread: http://forum.osnn.net/showthread.php?t=73738
http://www.kellys-korner-xp.com/xp_abc.htm
Error Messages - When Booting (Disable)
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows
Value Name: NoPopupsOnBoot
Data Type: REG_DWORD (DWORD Value)
Value Data: (1 = disable messages)
Stops the annoying Windows pop-up messages notifying you a device is not
functioning when you boot-up Windows.
Create a REG_DWORD value of 'NoPopupsOnBoot' in the key below (if it doesn't
already exist). Set the value to '1' to disable pop-up messages from
appearing.

also from this thread:
Make a shortcut to the share location on your desktop instead of mapping
as a drive.




AZ-Administrator

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
trwildeAuthor Commented:
Thanks for the insightful tip and useful links.  While your solution does indeed successfully eliminate the error messages I'd prefer to understand and fix the underlying cause of the error message.  But since the message is actually bogus (the mapped drives are indeed available) I suppose one must fight it with whatever tool is available. I wonder what other error messages this solution will mask out?

If any subsequent reader knows another method of actually eliminating the specific error message please add to this thread.
StudonCommented:
Using the 'NoPopusOnBoot' solution only works for the first boot only. If the user logs off and back on the error message will re-appear.

I have found a solution that eliminates the popup completely. You have to map the drive with a custom .bat file script which you can add to the startup folder in the start menu or group policy. Use the /PERSISTENT:NO switch to make sure the drive is disconnected at logoff.

Example Syntax:
NET USE Z: \\servername\share /PERSISTENT:NO /USER:servername\username password

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.