Optical Drives Disappeared

I have a Dell Dimension 2350 that came with a 48x CD-ROM drive and a 48x CD-RW/DVD Combo drive.  A few months ago, I switched from Windows XP home to the Xandros Linux distribution.  I was working on a project to copy pictures to the CD-RW when both drives disappeared, although they would open and close using the manual button.  As I had experienced a few quirky hardware behaviors while using Xandros, I decided try to do a reinstall to get to a dual boot with XP and Linux.  So, I ran fdisk and fdisk /mbr and the system boots fine and the drive light on the CD-RW/DVD drive flickers as normal, but not the CD-ROM drive.

When I try to boot from a Windows98 boot diskette with CD support, the startup attempts to load a driver (MSCD001), but the driver load aborts, with the message: "No drives found.  Aborting installation."

Then I tried the debug option in the setup function and it, too was unable to find either drive.

The CD-RW/DVD drive will still open with the manual button.  I checked all the connectors in both drives and on the motherboard and they all were firmly seated.
fswopeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

zvitamConsultantCommented:
There may incompatibility between the drivers on the Windows start up disk and the drives installed on your system.

I recommend the following test method:
1. change the boot priority and let the CD-ROM(s) be the first.
2. put a bootable CD in one of the drive, and restart the system, if the system boots from it then it works.
3. do the same with the other drive

Good luck,
Zvitam.
stuartindigoCommented:
Are both drives on the same IDE channel? Are they seen in the BIOS?

I take it you've checked the cables etc...

Try disconnecting ONE of the drives (slave and just the power cable), and see if the remaining drive is seen.

If not, try it on the other IDE channel and check again.

If this fails, try using a different lead from the PSU - one of the rails on that line could have failed.

If this cures the problem, then change the PSU ASAP , you may be able to get by for now, but the psu will completely fail eventually.

Hope this helps

Stuart

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
fswopeAuthor Commented:
Right on, Stuart!  Swapped the master cable connections to the slave (CD-RW/DVD) and the system saw it just fine.

Experts Exchange, priceless.

For a $25 56x replacement CD-ROM, there's MasterCard.

(The 48x original equipment was deader than a doornail - whatever that is.  I'm gonna open it up and have a look.  Any suggestions on what to look for?)

Thanks again,
Fred
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.