error in sqlmangr.exe

Dear Experts

i have an SQL 2000 sp3 installed on win 2k sp 4 server

last week end i tried to add an new RAID controller to my server to increase performance of the server, i took full backup of the system includuing the system state of the server

i used the ntbackup.exe application which built in backup application in windows.

then i shutdown the server and replaced the RAID controller and the hard disks, then i istalled windows 2000

then i did restore for hole system includin the database and the system state, every thing restored properly except the sql manager is not restored.
in server when i tried to run the sql enterprise manager or the query analyser it show this error:


The ordinal 29 could not be located in the dynamic link library odbcbcp.dll

 i coect to the database from my laptop and i didn't find the problem, i fid that if i connect from any workstation then  i will not get any error i'm able to connect to the sql server and run the sql analyser and run my scripts. but if i connect locally from the server, the above error will accure, i checked the odbcbcp.dll file on the backup is different than the one restored, i don't know from where the windows got this version of this odbcbcp.dll file. any way i copied the odbcbcp.dll file from my workstation to the server and the sql analyser works fine and the service start working and the ordinal error stop shows, but when i connect to the enterprice manager and when i select the sql server and when i tried to expand the tree to check the databases available under that server i got an error that system could conect to the server.

please help what to do, what i did now is i return my privous hard disk and RAID controller.

and i wil try to re do the same thing in next thursday, and i don't want to face te same problem.

can a real expert help me on this critical issue?

regards
LVL 5
thabashAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Guy Hengel [angelIII / a3]Billing EngineerCommented:
Someone else had the same problem:
http://www.experts-exchange.com/Databases/Q_21074319.html

MDAC resinstall might help:
http://www.mcse.ms/archive82-2004-4-543603.html

Here is a good page with the notes about the restore procedures:
http://www.cryer.co.uk/brian/sqlserver/howtorestorew2ksql2000bkp.htm

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
arbertCommented:
You'll probably get rid of the problem by reinstalling SP3a on SQL Server.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.